Zone Builder

[Reusable] Zone Builder v2.14

This thread contains content that may be reused, modified, or ported by anyone.

sluggard

Formerly "RomioTheBadass"
I'd like to report a bug, The Copy and Paste feature doesn't work properly in 3D Mode, Appearantly i cannot copy and paste textures, Well i can copy the highlighted texture using CTRL+C but i cannot paste it with CTRL+V, Keeps saying "Nothing to paste, cut or copy something first" .
 

MascaraSnake

Developer
Sonic Team Junior
So, this computer is an old Mac I've installed Windows onto, which caused me to find a weird bug:

The delete key can delete anything.
The backspace key (this keyboard's delete key) cannot delete things. It can delete vertices, linedefs, and sectors, but not things.
This is because the delete key and the backspace key actually do different things. The backspace key is mapped to the "Dissolve Item" action, which deletes stuff while trying to keep the remaining level geometry intact. Obviously there's nothing to keep intact when you delete a thing, so it does nothing for them. You can of course reconfigure your controls so that the backspace key performs the regular delete action.

Sorry for the late reply :V

I'd like to report a bug, The Copy and Paste feature doesn't work properly in 3D Mode, Appearantly i cannot copy and paste textures, Well i can copy the highlighted texture using CTRL+C but i cannot paste it with CTRL+V, Keeps saying "Nothing to paste, cut or copy something first" .
You can paste textures with the middle mouse button (or by pressing the mouse wheel). Not exactly intuitive, I know, but Ctrl+V is already reserved for pasting map things.
 

sluggard

Formerly "RomioTheBadass"
Weird, It works that way on default GZDB for both Visual and Drawning modes, Can i make it work the same way ? .
 

MascaraSnake

Developer
Sonic Team Junior
Looks like GZDB's behavior in that regard changed fairly recently. At this point Zone Builder is several hundred commits behind GZDB and doesn't really have any hope of catching up though. You can try mapping the "Paste texture" action to Ctrl+V and see what happens, I guess.
 

Ritz

Subhedgehog
Sonic Team Junior
I just checked GZDB's changelog to see just how far behind we actually are, and oh my god can we please please implement the 3D floor and slope builder mode
 
Last edited:

sluggard

Formerly "RomioTheBadass"
implement the 3D floor

3D Floors are called FOFs in SRB2, I Suppose that's what you're looking for, They are supported currently :3 .

EDIT : Ah wait, you're asking for ... Nevermind FOF Generator, This would be a Welcome addition :S .
 

MascaraSnake

Developer
Sonic Team Junior
Zone Builder v2.5 is out! Apart from updating the config for 2.1.16, hopefully this one fixes most of the issues reported in the last few pages of this thread.
 

TelosTurntable

How the turns have tel- tab-
I just checked GZDB's changelog to see just how far behind we actually are, and oh my god can we please please implement the 3D floor and slope builder mode

yes yes yes please please please

Zone Builder v2.5 is out! Apart from updating the config for 2.1.16, hopefully this one fixes most of the issues reported in the last few pages of this thread.

yay
 
Last edited:

SteelT

Developer
Sonic Team Junior
Kart Krew™️
So, Zone Builder crashed with the standard windows crash dialog. And according to the logs, the faulting module is DINPUT8.dl, no idea if I can reproduce it again.
 

Chicmunk

Wew!🐊𝓕𝐈𝓝𝓓 𝐓𝓗𝐄 𝓒𝓞𝓜𝓟𝓤𝐓𝐄𝓡 𝓡𝓞𝓞𝓜!😜
If I load any map of sc_heroesv3.wad in Zone Builder it just crashes:
(I have tested this in 2.4 and 2.5 and crashes in both versions.)
Cs45QhxXgAAjKfN.jpg

Cs45QhyWEAAPUOJ.jpg

Cs45QhyWEAIEH4N.jpg

Cs45QhyXEAET1q8.jpg
 

SteelT

Developer
Sonic Team Junior
Kart Krew™️
That's because the way the map was saved by SRB2DB isn't supported by Zone Builder. So not a ZB bug.
 

MascaraSnake

Developer
Sonic Team Junior
That's because the way the map was saved by SRB2DB isn't supported by Zone Builder. So not a ZB bug.
Um, no. The reason it crashes is because the WAD contains two lumps with the name "LUA_ITEM". Now obviously it's not a good idea to have two Lua lumps with the same name in your WAD, but ZB still shouldn't be crashing when this happens. I'll fix this for the next release. If you want to open sc_heroesv3.wad in the meantime, make yourself a copy of the file and delete one of the LUA_ITEM lumps.
 

Sapheros

Member
Isn't having 2 MAINCFG lumps also a bad thing? sc_heroesv3.wad has a lot of weird and randomly pointless stuff within it.
 

MascaraSnake

Developer
Sonic Team Junior
ZB won't crash if you have two MAINCFG lumps, but it will ignore the second one. Making it recognize both would be kind of a hassle, so I'm probably not gonna do it. There's no real reason to have two MAINCFG lumps anyway, since SRB2 recognizes all lumps with the SOC_ prefix as SOC lumps.
 

sluggard

Formerly "RomioTheBadass"
There's no real reason to have two MAINCFG lumps anyway.

It can get confusing though, Because usually while making a mod with Many custom objects of different types you'd want to keep thing organized so you can easily find objects you're looking for to modify later, I Think you should fix it instead of completely disallowing it .
 

MascaraSnake

Developer
Sonic Team Junior
The SOC_ prefix allows you to have as many SOC lumps as you want in your WAD, and all with different names too. That's much better for organization purposes than having multiple lumps with the same name.
 

toaster

トースタちゃん
Kart Krew™️
SOC_ENEM, SOC_BOSS, SOC_DECO... these are the lumpnames I'd use if I were making a level pack, and it would probably be wise to use ones along those lines as well.

Contrast with MAINCFG, MAINCFG, MAINCFG... which is terrible and makes me actively want to remove the game's ability to recognise a SOC lump with the name MAINCFG out of spite alone.
 

Monster Iestyn

Fangtastic
Sonic Team Junior
Kart Krew™️
Frankly I've never really known anyone to use multiple MAINCFGs per WAD before anyway.

...though if you seriously were going to do that, kill "OBJCTCFG" as well and end the myth that all characters must use it for character select SOCs once and for all. \o/
 

MoonDeLaAxel

FM Synthesized
So I have a bug that keeps recurring on my end with Zone Builder. I created a map with the program, which opened fine in 3D mode before but until recently, after latest saved with the map and trying to enter 3d mode causes the program to hang. It's memory usage skyrockets while the program is frozen. Within this frozen state, there are no error messages that come up at all, so I cannot give you an exact reason as to why this happens. Normal Doom Builder 2 does not do this when I use it.

If it helps. I'm using Windows 8.1 x64 with an Intel i7-4510U processor clocked at 2.0GHz, 8GB of ram, and AMD Radeon R9 M275X graphics card.

Edit: It seems shrinking the water transfer sector sixes fixed this problem.
 
Last edited:

Who is viewing this thread (Total: 2, Members: 0, Guests: 2)

Top