SRB2 Doom Builder 2.0

Status
Not open for further replies.

Snu

YEAAHHHHHHHHH
I found out the problem with my other post as the shortcut linked to the original db2. But when I load srb2 db2 it just says "Doom builder has stopped working". Can anyone help me with this?
 

Snu

YEAAHHHHHHHHH
the dotnetfx35 I already had but the slimdx crashed near the end saying "The installer has encountered a unexpected error installing this package. This may indicate a problem with this package. The error code is 2753." What do I do here?
 
Last edited:

glaber

Emblem Radar Ready
ok, I know this is a bump, but apparently version 2.1 is complaining that the level has no sectors when I try to test directly from SRB2DB2

Found the problem, it doesn't like the fast settings
 
Last edited:

Tyrannic

Member
I'm probably being extremely stupid, but I have a problem with the nodebuilder in Srb2DB2.0.
Every time I'm saving, the following message appears:
"Unable to build nodes: The nodebuilder failed to build the expected data structures. The map will be saved without the nodes."

When trying to test the level afterwards, it works, but has a frickin' lot of HOMs making it unplayable.

Does anybody have an idea how to fix this?

By the way:
Configuration is Srb2 2.1, Nodebuilder is Zen Node (Normal) and I have ZDoom's visual mode enabled.
 

Ritz

Subhedgehog
Sonic Team Junior
WEE WOO WEE WOO BUG REPORT

Moving textures in GZDoom visual mode (vanilla visual mode won't even start for me- thoughts?) doesn't update the offsets, so no change is made after saving, closing and reloading the map. Only way to alter texture positions right now is to autoalign or manually enter offset values.

Doing all my texturing in GZDoom Builder now, still works there. EDIT: Except saving a map with that messes with the Z-height of every object on the map so a proper fix would be real nice
 
Last edited:

Torgo

Member
I don't think Kalaron is even here anymore or he stopped working on srb2 stuff altogether. I don't think a bug report would help (unless someone else wants to update this)

I would like to see a plugin for vanilla DB2 to make z-offsets work and whatnot. I have not been able to get SRB2DB2 to work on my pc, but I am able to get DB2 working just fine.
 

Fred

Member
I would like to see a plugin for vanilla DB2 to make z-offsets work and whatnot.
This is a good idea and I hope one of our intrepid go-getters gives this a try. It would be pretty cool to have an officially sanctioned map editor that's not an unsupported dead-end branch of an old program for once.
 

Larz T

Siced
Judge
Sorry for the bump but I had recently switched from SRB2 Doom Builder to Doom Builder 2 and I can't help to ask, where is Move Mode?
 

glaber

Emblem Radar Ready
ok I'm getting that stopped working bug again, and the new doombuilder 2 is missing the gzdoombuilder plugin. (it doesn't use it)

I know I had this program working before, I just don't remember what I did to get it working. And yes, I do have the dependancies.
 

ChaosX

Member
ok I'm getting that stopped working bug again, and the new doombuilder 2 is missing the gzdoombuilder plugin. (it doesn't use it)

I know I had this program working before, I just don't remember what I did to get it working. And yes, I do have the dependancies.

I downloaded Srb2 Doom Builder "2", the first one kinda doesn't works properly.
I donwloaded the second file that Inuyasha posted, the Doom Builder 2 configuration, that one made it work good, if that is your problem, I'll check the other posts and update this comment if something is wrong.
 

glaber

Emblem Radar Ready
my problem is it says "Doom builder has stopped working" and doesn't even let me configure it.
 

ChaosX

Member
my problem is it says "Doom builder has stopped working" and doesn't even let me configure it.

Can you tell me what OS are you using? I use Windows 7 Professional 32-bit.
You should see if the program is compatible with the build you use.

I think it needs a runtime installation of a library I don't remember the name right now.
If that doesn't works, you can try running it on Administrator. Siply right-click the launcher and select Run as Administrator.
If that still doesn't works, then you should check if you didn't forget something important to make the program work.
If after all that it still doesn't works, then I don't know what your problem could be. Sorry.
 
Last edited:
Status
Not open for further replies.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top