SRB2 Doom Builder 2.0

Status
Not open for further replies.

Sparkz

Advanced FOFing Concepts
A new problem developed in my builder, out of nowhere. In 3D mode the camera's jumping back and forth. I try to move and I'm suddenly somewhere off my map. It's nearly impossible to find my way back most of the time because everything's so dark. Why is it so dark? Anyway, the whole camera thing makes it difficult to zero in on details and make fine adjustments. Sometimes this rattling is just too much and I have to take a break:p Any suggestions?
 

Monster Iestyn

Fangtastic
Administrator
Sonic Team Junior
Kart Krew™️
Judge
Tried going into SRB2DB2's Preferences and changing the 3D Mode speed?

Not sure what you should do about the camera rattling though.
 

MascaraSnake

Maybe out of retirement?
It's dark because the viewing distance is limited. You can expand it under Preferences, but larger viewing distances can make 3D mode lag quite a bit.
 

Shadow Hog

Member
What do you mean by "rattling"?

I mean, there is a known bug with DB2 (in general)'s 3D Mode where, if the computer has not had a proper shutdown in a long time (we're talking weeks here - and no, hibernation mode doesn't count as a proper shutdown), moving around in 3D Mode gets incredibly jerky (specifically moving, though, not looking - that's fine). If you're encountering this, the only way to fix it is to restart your computer. (I'd rather CodeImp fix this outright, but...)
 

Sparkz

Advanced FOFing Concepts
HA! OK, maybe my computer hasn't had it's nap in a while and I guess it's just cranky. The jerking is indeed what I'm referring to. With a further field of view however, I'm not getting lost in the darkness anymore. Thanks, Crusher.
 

Sparkz

Advanced FOFing Concepts
Sorry for the double post. I'm happy to report that everything I've been whining about has been alleviated!

More pictures should be added to this topic or a wiki page should be made to make these descriptions clearer

I couldn't agree more! I'm actually considering writing the Wiki for sloped FOFs, cause I totally have 'em licked.

Anyway, I'm more than pleased with how all this came out. The 3D interface is mind boggling. Here's a screenshot of GGZI.

Here we can see 3D mode living up to all it's potential; Slopes, FOFs, sloped FOFs, transparent FOFs, thing sprites and Z height on things.

8HgQC.png


This really breaths new life into map building. Kudos Kalaron!!!
 
Last edited:

VectorC

A.K.A.: Punch the Crocodile
[*]SRB2's FOFs can be edited in 3D mode WITH TRANSPARENCY IN 3D

Does it mean that I am suposed to see the platforms made by FoF(Result) or that it only shows defined lines as Transparent?(Triangles outside map) It's been bugging me. I used to not see the result of FoF in 3D view and on this version of SRB2CB1.1 I still can't see it. So, is it just me that misunderstood that update or is there really a problem?

Beside this MINOR problem of mine, it works just fine to me.

I have an idea of map that I'd like to do with FoF based for almost all characters. (Figure out that it's an "How to play SRB2 with basic character" map if you prefer...)

EDIT:
You need:


  • Version of SRB2: SRB2 Community Build
  • Map editor: SRB2 Doom Builder 2, which can be downloaded in the first post of this thread
  • Config: "SRB2CBDb2.cfg"

Here is another question then. Where can I get this mysterious "SRB2CBDb2.cfg" that you are talking about? All what I have is the "SRB2 Community build 1.1" config... (I'd like to make SRB2 maps and not SRB2CB ones)
 
Last edited:

The means

شادو الم
Sorry for the double post. I'm happy to report that everything I've been whining about has been alleviated!



I couldn't agree more! I'm actually considering writing the Wiki for sloped FOFs, cause I totally have 'em licked.

Anyway, I'm more than pleased with how all this came out. The 3D interface is mind boggling. Here's a screenshot of GGZI.

Here we can see 3D mode living up to all it's potential; Slopes, FOFs, sloped FOFs, transparent FOFs, thing sprites and Z height on things.

8HgQC.png


This really breaths new life into map building. Kudos Kalaron!!!

I remember thise map it's from Sonic 3D blast

Now i'm making a new map and i'll advertise it soon

---------- Post added at 01:51 PM ---------- Previous post was at 12:54 PM ----------

Do we can Use The Program for SRB v2.0.6 ?
 

TehRealSalt

(σᴥσ)
Kart Krew™️
Sorry for the bump, but I've tried this thousands of times on different computers, but it never works. But regular Doom Builder 2 does work. What am I doing wrong? I'd love to see my slopes in 3D mode.
 

Katmint

‫‬‭‮‪‫‬‭‮
What's the error message? "Doesn't work" isn't specific enough to get any useful answer.
 

TehRealSalt

(σᴥσ)
Kart Krew™️
The usual '[Application Name Here] has stopped working.' I checked details on it and it says that these files might describe the problem.

C:\Users\****\AppData\Local\Temp\WERB06A.tmp.version.txt
C:\Users\****\AppData\Local\Temp\WERBD08.tmp.mdmp

Do these mean anything?

EDIT: It might help to mention I'm using Vista.
 

Lippa

BONES creator
Yeah, I have the same error as Sonic100000, the dependent files also wouldn't run so I just grabbed the latest versions from the original sources.
 

MrDonoB

Member
Sorry For Bumping But..

I am sorry for the bump, But i am having a problem with the builder,

Everything works fine except that whenever I change a texture, It goes missing, From SRB2 or not. It shows up right in the builder, But not in game.
 

Metal96

Member
T8YWQ8f.png


Basically all I have to say about this is that I cannot get this to install no matter what I do. It keeps giving this error.

And, although it has been said so many times, I still tried to run the builder without it and it crashed immediately :-P
 

Snu

YEAAHHHHHHHHH
i have incountered a problem when i load the builder...when i open the game configurations
on tools srb2cb does not come up! can someone please help me?!
 

Metal96

Member
i have incountered a problem when i load the builder...when i open the game configurations
on tools srb2cb does not come up! can someone please help me?!

Can you give more details, perhaps a screenshot? We can't help when we don't know what's really wrong.

Oh hey look, I can use this bump to my advantage So anyway, my SRB2DB2 keeps getting itself stuck in 3d mode. I can't use any of the shortcuts to exit to another mode (or do much of anything in general). I also can't close normally or use the toolbar, as clicking anything on the interface just hides the cursor and reenables 3D mode control. It also bugs out when I try to end the task in Task Manager (which is just a glorified close button anyway), forcing me to terminate the process and reload it. It seems to happen after I edit a linedef in 3D mode, but not editing linedefs is kinda not an option as that's the best way to texture well as far as I know. Any ideas?

Also, I should add that ZenNode is botched. Completely. It just returns an error whenever I try to save with it. HOWEVER, ZDBSP seems to be a great alternative, as it's ridiculously fast (huge map with reject = 5 mins on ZenNode, 5 secs with ZDBSP (?!?)) and far more accurate (I used to get huge HOMS, random holes in the geometry that one could see the sky and a bunch of glitched out textures through, and flat spilling all over with ZenNode, but none of this with ZDBSP!).

Speaking of botched nodesbuilds, for some odd reason, if a nodebuild fails on save/test, and then one goes and switches the nodesbuilder, it seems to build fine, but when SRB2 loads it glitches out intensely (with random distorted textures and flats (sometimes flickering) strewn about the screen) and eventually sigsegv's if the view changes too much from the starting position (i.e. movement or turning). Just something to consider.

mfwN4ivl.png


Like this but it typically has more glitchy "stuff" in the scene. It changes every time.

EDIT: To add some perspective, this is what that spot is supposed to look like:

5YG3pmIl.png


Yeah.
 
Last edited:

SteelT

Developer
Sonic Team Junior
Kart Krew™️
All of these problems must be related to your PC, Metal96. I don't have any problems using 3D Mode on SRB2DB2 and ZenNode saves my maps completely fine with out errors. But I do remember ZenNode not saving maps on my old PC with SRB2DB1. I guess a conflict was causing ZenNode to fail building and saving the map, or the antivirus software it had was blocking ZenNode from building and saving the map for some reason.
 
Status
Not open for further replies.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top