Sprites and sound not showing correctly?

Hello. I am SinOrejas293, and i'm new to SRB2 Modding. i've was trying to make an Add-On that replaced Rings by Chili Dogs. I've made a sprite, and read things about SOCs and Objects. Made an .txt file with the information necessary for this sprite replacing Rings with a proper Meme sound. When i've tested the Add-On, the Chili Dog sprite didn't show up and, neither the TF2 Heavy NOM sound too when collecting them. I've tried solving this for an hour or more. And i've didn't have success. I've tried adding edited HUD sprites to see if those work, and yes, but they are in the wrong spot and space. I've used Aseprite to make and edit the sprites showed in the WAD archive. I'll put it here so someone who does know about SRB2 Modding would open it on Slade and see if something is wrong in the files. Bye.
Post automatically merged:

Ok. So if nobody sees or replies to this. I'll try to get a solution for myself, because i'll have to do effort for myself in my Internet life as nobody ceases to view the content that i've do. And it would be the opportunity for me to be popular in this site by making this Add-On.
Edit; Another thing to point out. Is that i've first exported the sprites made in Aseprite in .png format. Which supports transparency. I've readed recently that SRB2 doesn't support this kind of file formats. It may be for that the reason the sprites are missing? I'm also kinda dumb with this SRB2 Modding thing and this kind of technical things on general. I've tried to export with .bmp file format, which doesn't support Alpha Channel (Transparency) and even with the transparency options in SLADE, it doesn't look transparent. I'm kind of getting anxiety of not being succesful with technological matters. Like not being able to export a video in Premiere without mild quality loss...
 

Attachments

  • Chilidog.wad
    25.8 KB · Views: 19
  • srb20006.gif
    srb20006.gif
    7.4 MB · Views: 107
Last edited:

DylanDude

Overeager Raposa
You cannot replace the Ring object or sprites, they are harcoded into the game unlike other objects. Create a custom object instead.

The sprite name you are using is also incorrect, and you have graphics outside of graphics markers. A proper sprite name would be CHILA0, where A is the frame and 0 is the angle sprite for that frame (0 is special, it sets all angles to use that sprite as a default).
 
Yeah, i've realized the A character in the sprite names when doing a bit more deep research in the SRB2 Wiki. Didn't know exactly about the final number character that's for the angle the sprite will be. Didn't know about the not being able to replace pre-existing objects in the game. That would explain why i don't find Add-Ons that replace Rings, that kinda sucks tho because i've thought it would be like S3AIR. Thanks for the information tho. Will begin to work on this and rethink what i would do with this unfinished Add-On later. Also, i've recently come here from watching the newest Spider-Man movie. It was great.
 

DylanDude

Overeager Raposa
Yeah, i've realized the A character in the sprite names when doing a bit more deep research in the SRB2 Wiki. Didn't know exactly about the final number character that's for the angle the sprite will be. Didn't know about the not being able to replace pre-existing objects in the game. That would explain why i don't find Add-Ons that replace Rings, that kinda sucks tho because i've thought it would be like S3AIR. Thanks for the information tho. Will begin to work on this and rethink what i would do with this unfinished Add-On later. Also, i've recently come here from watching the newest Spider-Man movie. It was great.
To clarify, you CAN replace vanilla objects, actually. Just not all objects, like rings. You can create an object which mimics a ring, though.

And no problem.
 
I've put the correct name to the sprite and that. But it shows this. I'm a lazy person who procastinates frequently and is kinda dumb sometimes anyways. Here's the screenshot of the order of the files in SLADE where i've put the markers. I've made only 2 sprites for now, 1 which is unused for now. And was for one of the other angles of the sprite.
 

Attachments

  • srb20015.png
    srb20015.png
    82.8 KB · Views: 40
  • Desktop 21-1-2022 20-45-01-509.png
    Desktop 21-1-2022 20-45-01-509.png
    11.4 KB · Views: 41

Rapidgame7

waiting for avatars to be fixed
Moderator
1642810425904.png


Sprite filenames are strictly 4 character long, with the remaining 4 characters reserved for rotations.
When referencing them in SOC or Lua, you use the first four characters in the file, prepended by SPR_.
Note that your sprite is therefore SPR_CHIL and not SPR_CHILI (note the extra I).

As for the sound, I don't recall if SOC is case sensitive, but you might need to have to write SFX_NOM in full lowercase.
By the way, if you can, avoid using mp3 files for audio. Mostly for file size and audio frequency concerns. Convert them to a 0 quality ogg if you can.
 
I've didn't know that SRB2 couldn't support MP3. Now i've realize that most games use the .ogg audio format. Also the BIG problem i've had is that the SOC didn't save the changes. Then i've discovered the "Save" button in the SLADE interface. Now hopefully my Add-On can work properly after so much confusion. Edit: Also a really BIG problem. Is .png format allowed to import first? Or it is the form i've convert the graphics that makes this wrong? I've export like this:
It should be like that because i've selected to export from "Existing/Global" to "Sonic Robo Blast 2" So, it should be the way to do that. Also, i've only use 1 frame as of now, i've tried to draw the Chili Dog from other angle in Aseprite but i've kinda failed. I'm not* a pro at spriting.
 

Attachments

  • Desktop 22-1-2022 16-37-59-205.png
    Desktop 22-1-2022 16-37-59-205.png
    23.6 KB · Views: 20
Last edited:

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top