Kart bug reports thread


hey, im new to srb2kart and also to the forums, sorry if this is the wrong place to post this but yesterday i told a friend to download the game and play on public servers, and when he loads up the server list, only a few servers appear for him.

Instead of the usual 3 - 4 pages of servers that i get, he only gets 1 page of servers that only show like 5 or 6 servers.

We tried turning off firewall, and even his antivirus and still a few servers come up. He also tried redownloading the game to have it be vanilla srb2kart but not even that worked.

The weirdest thing about it is that when he refreshes the list, different servers appear each time, but its still a very short amount on the list.


on my OSX Catalina late 2019 macbook air, the SRB2Kart OSX build has some problems. it fails to build, and sometimes it gets killed with "SIGILL: Illegal Instruction".

The following patch fixes both issues:

commit 89dee6ee4b0815752d7947fcf906d3ac516cee48
Author: Kimberly Wilber <kimmy@kjwilber.org>
Date:   Sun Aug 9 12:15:29 2020 -0400

    fix building on OSX

diff --git a/src/sdl/CMakeLists.txt b/src/sdl/CMakeLists.txt
index 33c83b8b..5077daaf 100644
--- a/src/sdl/CMakeLists.txt
+++ b/src/sdl/CMakeLists.txt
@@ -146,8 +146,8 @@ if(${SDL2_FOUND})
 		find_library(CORE_LIB CoreFoundation)
 		target_link_libraries(SRB2SDL2 PRIVATE
-			SDL2
-			SDL2_mixer
diff --git a/src/w_wad.c b/src/w_wad.c
index 841d8fd3..4bafda51 100644
--- a/src/w_wad.c
+++ b/src/w_wad.c
@@ -150,7 +150,10 @@ FILE *W_OpenWadFile(const char **filename, boolean useerrors)
 	FILE *handle;
-	strncpy(filenamebuf, *filename, MAX_WADPATH);
+    if (filenamebuf != *filename) {
+        // avoid overlap
+        strncpy(filenamebuf, *filename, MAX_WADPATH);
+    }
 	filenamebuf[MAX_WADPATH - 1] = '\0';
 	*filename = filenamebuf;

You can apply this patch by running
$ git apply the-patch.txt


Local Idiot
The online mode doesn't work anymore. When I use the internet server browser, it just searches for a bit and redirects the glove cursor to the top of the screen, labeled as "LP.L'A.Y.ERS".


fuck not again *lights hand on fire*
The online mode doesn't work anymore. When I use the internet server browser, it just searches for a bit and redirects the glove cursor to the top of the screen, labeled as "LP.L'A.Y.ERS".

that's just the master server not working, that happens more times than there are medals in srb2k.


Gimme more coffee!
SIGSEGV on boot, happens on both the standard and OpenGL versions.

Compiled for SDL version: 2.0.9
Linked with SDL version: 2.0.9
Setting up SRB2Kart...

Sonic Robo Blast 2 Kart
Copyright (C) 1998-2018 by Kart Krew & STJr

This program comes with ABSOLUTELY NO WARRANTY.

This is free software, and you are welcome to redistribute it
and/or modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2 of
the License, or (at your option) any later version.
See the 'LICENSE.txt' file for details.

Sonic the Hedgehog and related characters are trademarks of SEGA.
We do not claim ownership of SEGA's intellectual property used
in this program.

Looking for WADs in: SRB2WADDIR,.
Z_Init(): Init zone memory allocation daemon.
System memory: 2047MB - Free: 2047MB
W_InitMultipleFiles(): Adding IWAD and main PWADs.
Added file C:\Users\hexam\Downloads\srb2kart\srb2.srb (6214 lumps)
Loading main config from C:\Users\hexam\Downloads\srb2kart\srb2.srb
Added file C:\Users\hexam\Downloads\srb2kart\gfx.kart (1804 lumps)
Added file C:\Users\hexam\Downloads\srb2kart\textures.kart (4070 lumps)
Added file C:\Users\hexam\Downloads\srb2kart\chars.kart (526 lumps)
Added file C:\Users\hexam\Downloads\srb2kart\maps.kart (1684 lumps)
Loading SOC from C:\Users\hexam\Downloads\srb2kart\maps.kart|SOC_MAIN
Added file C:\Users\hexam\Downloads\srb2kart\patch.kart (1012 lumps)
Loading main config from C:\Users\hexam\Downloads\srb2kart\patch.kart
Added file C:\Users\hexam\Downloads\srb2kart\sounds.kart (668 lumps)
Added file C:\Users\hexam\Downloads\srb2kart\music.kart (118 lumps)
NOTE: Under SDL2, all modes are supported on all platforms.
Under opengl, fullscreen only supports native desktop resolution.
Under software, the mode is stretched up to desktop resolution.
0: 1920x1200
1: 1920x1080
2: 1680x1050
3: 1600x1200
4: 1600x900
5: 1366x768
6: 1440x900
7: 1280x1024
8: 1280x960
9: 1280x800
10: 1280x720
11: 1152x864
12: 1024x768
13: 800x600
14: 640x480
15: 640x400
16: 320x240
17: 320x200

Process killed by signal: SIGSEGV - segment violation

I_ShutdownSystem(): end of logstream.

There's the RPT file here, too.
View attachment srb2kart.zip

Not sure if this little bit of information can help, but I updated my video card drivers today.


Insert funny hahas here

So I managed to get stuck inside a pipe somehow. (Kart 1.2)
I basically hit the pipe after going off the ramp, and managed to get 100% stuck inside it. A friend tried hitting me with a jet-jaws to try to get me out, and all that did was give me permanent invulnerability.


Ideally Imperfect
Sigsegv error

So i opened kart 1.3 and i just get an error that says:
SIGSEGV - segment violation

This happens continually, so I get the 1.3 install file and extract it.
i open it in a newly "unpacked" game, and it still crashed.

Now this is when I'm trying to open the game in OpenGL, and opening via the EXE yielded the same results.

eventually I find that when I close the command prompt the opens when launching in OGL, before the game fully opens, the game works as normal.

But if I leave it, then I get the error.

EDIT: Oh, and if I'm playing in fullscreen and move the focus to a different window or the desktop I get the same error.

EDIT 2: And if I minimize it when its not in fullscreen I get the same error.
Last edited:
I keep repeatedly getting crashed by Z_Free: wrong id. Happened 4 times in one night, and has happened repeatedly before.
macOS, latest version of Catalina.

It feels like this is happening whenever I'm playing online and someone else joins that server. Usually this happens at higher player counts, something like 12-15.
I restart the game and go to the same server and notice it has 1 or 2 more people.
Last edited:

Mystery Cheese

Mystyc Cheez
I dont know why, but ever since I upgraded to 1.3, loading maps takes way way longer than before. Before, it was instant, now it takes about 1 or more seconds to load a map. This makes time trials excruciating. :(
Last edited:
Still getting hit by wrong id. I now strongly believe it's happening whenever the Master Server updates. I've noticed when I play offline multiplayer, I'll often see a console notice (and a minor hang) indicating the MS updated. But whenever I'm online, I never see such a notice. Instead, the game crashes frequently because of wrong id.


I have the following problem: I have two computers a PC and a Laptop both connected via LAN and I want to host a LAN game. If I open a LAN room on my Laptop, I can join that room on my PC, when I enter the IP address of my Laptop. For some reason when I try to open a room on the PC and then try to join that room on my Laptop, when I enter the IP address of my PC it won't connect. I don't know why when I host the game on my Laptop it works fine, however the other way around doesn't work at all.
Does this have to do with my network settings?

Any help would be appreciated.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)