[Reusable] SRB2Cineblast

This thread contains content that may be reused, modified, or ported by anyone.
Status
Not open for further replies.

Fawfulfan

The Tortured Planet guy
Wait a minute...I just posted a bug report about that for the main SRB2 EXE. Now I think about it, I'm pretty sure I'm using Cinefast's modified SRB2 EXE. So could it be that one of Cinefast's fixes--some fix he made to both vanilla SRB2 and Cineblast--breaks NETSTAT?
 

Cinefast

32 kilowords of core!
That's interesting. I remember netstat being broken since 2.0.5. I certainly wasn't responsible for the issue. If you could post an EIP from the netstat crash I can probably find a solution.

Edit:

Disregard that. EIP is 00000000. I'll step through in GDB soon and see if I can pinpoint the issue
 
Last edited:

Ezer'Arch

ArchPack 2.3 is out. 2.4 is on the way
netstat works all fine in vanilla, but in SRB2C not.

The context:
Code:
"netstat" is "Off" default is "Off"
>netstat 1
I_ShutdownMouse()
I_ShutdownKeyboard()
I_ShutdownTcpDriver: shut down
I_ShutdownMIDIMusic: 
I_ShutdownDigMusic:
 Done
I_ShutdownSound()
I_ShutdownGraphics()
signal_handler() error: segment violation
Error log:
Code:
SRB2v1.0 -ERROR LOG-


srb2cwin caused an Access Violation in module Unknown at 001b:00000000.
Exception handler called in main thread.
Error occurred at 1/3/2011 20:53:50.
C:\Games\SRB2\srb2cwin.exe, run by Laser.
2 processor(s), type 586 6.5898.
Program Memory from 0x00010000 to 0x7FFEFFFF
2048 MBytes physical memory.
Read from location 00000000 caused an access violation.

Registers:
EAX=00000000 CS=001b EIP=00000000 EFLGS=00010246
Sorry, seems EIP won't be of any help.

----- EDIT

O HI CINE!

I heard you need Sonic&Tails char select pic, so I got one from SRB2JTE.

(sent via PM)
 
Last edited:

Cinefast

32 kilowords of core!
Thanks Ezer. This will be included in SRB2C v1.1

For some reason I cannot even run SRB2Cineblast in gdb - gdb crashes. How fun, now I have to mess with my MinGW installation and try to find what's up.

Edit:

After disabling music gdb played nicely for some reason. It appears that I did not make a breaking modification after all. I done a stack trace and the last subroutine that I could find before the instruction pointer changed to 00000000 was dtoa_lock. dtoa is double-to-string, so this is a problem in the C runtime. I have nothing to do with it.
 
Last edited:

Metal-Rawr

Also known as Teravolt now
I'm guessing I always click on the download link when a lot of people are downloading from rapidshare, because the URL won't load :C
 

VØLT

Kamehameha!
Hoooooo plz !! Host the file in mediafire ! I have to wait 30 seconds to test this super project with the speed reduced by rapidshare!
 

Katmint

‫‬‭‮‪‫‬‭‮
Hoooooo plz !! Host the file in mediafire ! I have to wait 30 seconds to test this super project with the speed reduced by rapidshare!

Just download the attachment in the mod details. It's the same version.
 

kiddo192

Member
There's a bug that occurs mostly in Match and CTF (can happen in Coop too):

When you get hit, instead of falling down after a little hit up, you constantly go up and get stuck at the ceiling until you go to spectate or switch to another team (Team Match and CTF).
 

Cinefast

32 kilowords of core!
There's a bug that occurs mostly in Match and CTF (can happen in Coop too):

When you get hit, instead of falling down after a little hit up, you constantly go up and get stuck at the ceiling until you go to spectate or switch to another team (Team Match and CTF).

That's rather odd. It sounds like something that'd be caused by negative or zero gravity, but I can't imagine what would change gravity like that.
 

Lars

Member
There's a bug that occurs mostly in Match and CTF (can happen in Coop too):

When you get hit, instead of falling down after a little hit up, you constantly go up and get stuck at the ceiling until you go to spectate or switch to another team (Team Match and CTF).

Wow, I played a few very long matches (with bots though, no players) on CTF, and never encountered or spectated one of the bots having that problem. Maybe it was a map's fault? In a costumized map of mine everything is fine, it's simple though, but it means it's not the engine's fault, I guess.
 

kiddo192

Member
Wow, I played a few very long matches (with bots though, no players) on CTF, and never encountered or spectated one of the bots having that problem. Maybe it was a map's fault? In a costumized map of mine everything is fine, it's simple though, but it means it's not the engine's fault, I guess.

I just had a feeling it was one of the character WADs I added, and I did the following to test:

1. added bot (one of the basic skins)
2. added wad files one by one, hitting the bot after each wad file

It took me 2 WAD files to see what the problem was: a character WAD called "silver2.wad" was causing the problem.
 
Sorry for any inconvenience, but the link posted earlier in this thread for a lua52.dll file doesn't work. It just sends me to some wierd book sales website. Can someone re-upload the file somewhere else please?
 
Status
Not open for further replies.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top