[Reusable] SRB2 - Community Build! - Full color Edition! (PNG)

This thread contains content that may be reused, modified, or ported by anyone.
Status
Not open for further replies.

Ezer'Arch

ArchPack 2.2 is out
2.0.6 + trunk bug fixes, please

I'm going to do a re-sync to the latest version of SRB2 (2.0.6).
Kalaron, it would be way better if you re-sync CB to both v2.0.6 and trunk fixes. Since the 2.0.6, SRB2 has received a lot of bug fixes, including critical ones, such as: camera , currents, CTF flag stuck in death pits, water FOF rendering, "transparent" pixels rendering and so on.

Let's hope the devs may allow you to access the other fixes that aren't on public trac. :S
 
Last edited:

AlamGBC

WOO! GO ME! YAHOO!
Administrator
Sonic Team Junior
The only other major fixes in SRB2 2.1 would be stuff that breaks netplay for 2.0.X, so do not worry about it.

Sent from my HTC Vision using Tapatalk
 

Katmint

‫‬‭‮‪‫‬‭‮
AlamGBC said:
would be stuff that breaks netplay for 2.0.X

I can't netgame on the latest Trunk or MOB anyway, it always give me an instant "Cannot connect to master server" error. (Vanilla still works fine.)
 

AlamGBC

WOO! GO ME! YAHOO!
Administrator
Sonic Team Junior
then IPv6 code broke.... yea...

Sent from my HTC Vision using Tapatalk
 

Fawfulfan

The Tortured Planet guy
You play in analog mode right fawfulfan? I think the MFE camera works alright for non analog, but in some instances (ERZ1 crushers for sonic) it completely messes up the experience for analog mode players.

I think it should be disabled analog, but enabled for normal chasecam. I don't know if MFE camera works well in normal chasecam though.
I think MFE camera should be optional in all cases, and disabled by default, just like other game features that turned out to be less useful than previously thought (i.e. HOMREMOVAL).

And also IIRC, Inuyasha was also complaining about the MFE camera a while back, and doesn't he use non-analog?
 

Jeck Jims

Oh, THAT guy...
Sonic Team Junior
Kart Krew™️
Are you going to re-fix some of the things when you convert Kalaron?
Such as the ability to have a character not reach it's runframes? Or how Tails can actually run correctly in 2-D mode? Because these are some of the little things that I love about this mod.
 

Ezer'Arch

ArchPack 2.2 is out
SRB2CB Bug Report 18.Jun.11

SRB2CB Bug Report 18.June.2011

1. Fire shield doesn't extinguish under water

nIvBl.png



2. Crawla Commanders skyrocket if trying to go up a slope (similar behavior here)

r2FU6.png



3. Thing shadows can be seen from below

L40bV.png



4. Thing shadow off-set causes character to seem he isn't touching the floor, specially when running or spinning. See 2nd picture above (maybe 1 or 2 pixels toward the center would be better...I'm nitpicking, I know)


5. Opaque water FOF sides are partially rendered in OGL. Translucent ones seem okay. It seems to be a common issue among the new EXE's (interestingly, OGL of SRB2 v2.06 can render them, fairly)

Dhkan.png



5. Some bustable FOFs are rendered "above" the wall textures. Say, open a hole in the wall and fill it with a spin bust block (Linedef Type 255) that is taller/bigger than the hole. The breakable wall will seem to be larger than the hole. Similar effect happens with Shatter Blocks (Linedef Type 252) after its destruction.

4VuaE.png


--------------

I simply loved you fixed the flat rendering when seen from above:

MBYby.jpg
 
Last edited:

Ezer'Arch

ArchPack 2.2 is out
SRB2CB Bug Report 19.Jun.11

SRB2CB Bug Report 19.Jun.11

1. DEVMODE command does not always activate the development mode. For instance, in title screen, I'm forced to enter DEVMODE twice in order to activate it, and if I load a map, I'm forced again to enter DEVMODE.

Code:
*SRB2CB just started up*
>devmode 
>map map01
Sorry, level change disabled in single player.
>map map02
Sorry, level change disabled in single player.
>devmode 
WARNING:Game must be restarted to record statistics.
>map map02
*loading map*
Starting Server....
Press ESC to abort
Contacting the server...
Sending join request...
Join accepted, waiting for next level change...
Player 1 has joined the game (node 0)
Now Loading level...
MAP02: GREENFLOWER ZONE  2
>noclip 
No Clipping On
*tries to turn devmap on*
*failed*
>devmode
*tries to turn devmap on again*
-------------------------------------

EDIT:

This is Z-fighting. Try moving the front of the waterfall farther away from the wall in the back.
I know; and GFZ2 waterfall is horrid (SRB2 x SRB2CB).

bQNn9.png


When this happens with the walls, it's simple to get it fixed by changing the nearby-sector heights, but it's impossible with FOFs. :S

What was wrong with it?

This took this one in the same place.

84kaE.png
 
Last edited:

Fred

Member
This doesn't happen on my end. It could be that SRB2 is using a low precision Z-buffer for some reason. Check your graphics settings, is there a "Force 32-bit Z-buffer" option? Try ticking it.

Okay, this DEFINITELY doesn't happen on my end. It looks like the game is culling stuff it thinks you're not supposed to be able to see, as if it's not taking mouselook into account.
 
Status
Not open for further replies.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top