Resource icon

Sonic Kart VR Mod v1.0.5

chreas

Member
chreas updated Sonic Kart VR Mod with a new update entry:

Sonic Kart VR Mod v1.0.4 Update

v1.0.4 notes:
- New VR menu setting "Track Intros". This lets you either turn off the intro transition, remove the rotation, or leave it as is while in VR mode. Gentle rotation-free mode is the default setting.
- fixed an issue where the FOV cone would rotate the wrong direction when looking around during encore mode.
- opengl render loop can now push steamVR errors to the console and log
- merged latest changes from moe mansion (srb2kart web launch protocol)

Downloads:...

Read the rest of this update entry...
 

Bijman

Ye ol' bugger
It seems that the source code in GitLab repository's Releases page is v1.04 of vanilla SRB2 Kart and not of VR's v1.04 (forked from Moe Mansion). While trying to run my compiled binary, it complains about not correct "patch.kart" (I use assets from v1.3 SRB2 Kart installer):

File is corrupt or has been modified: [path to patch.kart] (found md5: f7b68076f8abc54e1a78963d97f69ab2, wanted: b5f48e1abccfa47a5745199182e2fef4)

If I turn off MD5 hash file checksum in compilation with NOMD5=1 and then run game, I get old vanilla SRB2 Kart version. Because of GPLv2 license, please provide your modified source code VR version of SRB2 Kart Moe Mansion, I can't find it in repository.
 
Last edited:
The VR mod does not work for me, i tried dealing with the common issues, i made sure it ran in OpenGL, and i made sure i didnt have multiple GPU's, but it still shows a black screen while it shows in desktop
 

chreas

Member
It seems that the source code in GitLab repository's Releases page is v1.04 of vanilla SRB2 Kart and not of VR's v1.04 (forked from Moe Mansion). While trying to run my compiled binary, it complains about not correct "patch.kart" (I use assets from v1.3 SRB2 Kart installer):

File is corrupt or has been modified: [path to patch.kart] (found md5: f7b68076f8abc54e1a78963d97f69ab2, wanted: b5f48e1abccfa47a5745199182e2fef4)

If I turn off MD5 hash file checksum in compilation with NOMD5=1 and then run game, I get old vanilla SRB2 Kart version. Because of GPLv2 license, please provide your modified source code VR version of SRB2 Kart Moe Mansion, I can't find it in repository.
I may have made a mistake when creating the gitlab release by not setting the branch tag correctly. Still new to gitlab, sorry. Build from the source on this branch https://gitlab.com/cschoenig/kart-public/-/tree/very-cool-renderer

The VR mod does not work for me, i tried dealing with the common issues, i made sure it ran in OpenGL, and i made sure i didnt have multiple GPU's, but it still shows a black screen while it shows in desktop
When you move your headset around does the UI in the desktop window move around with it? You should at least see the world being moved with your headset if its attaching to steamVR correctly. Does steamVR say that you are now playing srb2kart? Try launching the game with the following commands "-openvr -skipintro -win". I think for some devices launching with -openvr is more reliable than activating it in their ingame video settings.
 
did not work, steam vr does say im am indeed playing srb2 kart, but when i tried "-openvr -skipintro -win" it still happens to be on a black screen. The Ui does move around when i move my headset. it seems to be similar to HAZ's error, but if i need to follow his steps, idk how to launch the command line to launch the game
 

chreas

Member
did not work, steam vr does say im am indeed playing srb2 kart, but when i tried "-openvr -skipintro -win" it still happens to be on a black screen. The Ui does move around when i move my headset. it seems to be similar to HAZ's error, but if i need to follow his steps, idk how to launch the command line to launch the game
What headset and GPU are you using? I believe in windows you can enter "cmd" in the address bar of a folder to open the command line in that directory. Once in the command line you should be able to enter "srb2kart.exe -openvr -skipintro -win". The games log will print in that command window in real time. If there's a lot of VR errors coming into that command window let me know. VR error 108 when changing levels generally should be ignored.
 
im using a Oculus quest 2 with link, the GPU is Radeon RX 580 Series, and right now im busy with chrismas (I know its christmas, but i like mispelling stuff so it look like its on purpose when i do it on accident) so i wont be able to test the cmd rn, but ill try later
Post automatically merged:

Did the cmd and stuff, did not do anything, heres a pic to show
 

Attachments

  • Capture.PNG
    Capture.PNG
    268 KB · Views: 56
Last edited:
Bah, I get a black screen every time I enable VR mode but, at the very edges of the screens I see a sliver of light and colors that looks like whats on the mirror display.

Anybody got any ideas whats going wrong?

Tried on 2 different PC; Win 7 with R9 390 & Win 10 with Vega 56; same headset, HTC Vive.
 
Last edited:

chreas

Member
im using a Oculus quest 2 with link, the GPU is Radeon RX 580 Series, and right now im busy with chrismas (I know its christmas, but i like mispelling stuff so it look like its on purpose when i do it on accident) so i wont be able to test the cmd rn, but ill try later
Post automatically merged:

Did the cmd and stuff, did not do anything, heres a pic to show
Bah, I get a black screen every time I enable VR mode but, at the very edges of the screens I see a sliver of light and colors that looks like whats on the mirror display.

Anybody got any ideas whats going wrong?

Tried on 2 different PC; Win 7 with R9 390 & Win 10 with Vega 56; same headset, HTC Vive.
Steam VR has a setting to output a higher resolution for certain games and also globally. I know on windows the VR mod can run into display issues if steamVR tries to change the scale, check your settings and turn off global scaling, srb2kartVR needs to be at 100% on windows.
 
Hey chreas, thanks for the quick response.
Yea, scaling was at 100%, tried it with global off, still no dice on both computers.
So weird, my other VR games launch just fine.
- Tried the beta branch, no change there either.
- Installed on a different drive, nada.
Guess I'll keep trying other random google suggestions for black screen launches unless someone else knows of any other obscure tweaks to test.
Oh and I forgot to mention, the mirror window shows the game tracking the headset movement.
 
Last edited:
Amazing mod! I tried it out but I couldn't get the VR mode to work.
My GPU is Radeon RX 580 Series Primary/Discrete, My CPU is AMD Ryzen 5 1600 Six-Core Processor 6 Cores. My VR headset I'm using is PlayStation VR. All my Steam VR games work on my headset but not Sonic Kart. The game world moves around on my TV when I move the headset around. I tried the cmd trick but still nothing. Are there anything else that I could try to get the VR to display the game? Thank you for the mod.
 

Attachments

  • Screenshot (191).png
    Screenshot (191).png
    1.5 MB · Views: 35

chreas

Member
Amazing mod! I tried it out but I couldn't get the VR mode to work.
My GPU is Radeon RX 580 Series Primary/Discrete, My CPU is AMD Ryzen 5 1600 Six-Core Processor 6 Cores. My VR headset I'm using is PlayStation VR. All my Steam VR games work on my headset but not Sonic Kart. The game world moves around on my TV when I move the headset around. I tried the cmd trick but still nothing. Are there anything else that I could try to get the VR to display the game? Thank you for the mod.
Thanks for the info, this seems to be a common issue among people who have an AMD 5XX video card. I'm going to look into some code changes regarding how I send data to the headset and see if I can remedy some issues like that which have been popping up lately.
 
Thanks for the info, this seems to be a common issue among people who have an AMD 5XX video card. I'm going to look into some code changes regarding how I send data to the headset and see if I can remedy some issues like that which have been popping up lately.
Awesome! Thank you for the quick reply. I'll keep my eyes peeled for an update.
 
Oh, glad to hear your on top of it chreas.
Just reporting another combination that gives a blackscreen but the mirror still shows headset movement.
Win 10, Ryzen 7 2700X, RX 5700 XT, a different HTC Vive
 

chreas

Member
chreas updated Sonic Kart VR Mod with a new update entry:

Sonic Kart VR Mod v1.0.5

v1.0.5 notes:
  • Fixed track intro comfort settings not applying when launched using -openvr instead of the ingame VR setting.
  • Changed how frames are rendered and submitted to vr headsets. This should improve performance and solve visual glitches for most users. Error 108 should be gone now.
  • Merged latest changes from moe mansion

Read the rest of this update entry...
 
v1.0.5 black screens on the first 2 computer setups from the previous reports. Mirror window shows headset tracking.

*all tests were done on both computers*
- Fresh srb2kart installs
- On 2 different drives and locations
- With and without SteamVR beta build
- cmd prompt -openvr -skipintro -win tried with every variable above
 
v1.0.5 black screens on the first 2 computer setups from the previous reports. Mirror window shows headset tracking.

*all tests were done on both computers*
- Fresh srb2kart installs
- On 2 different drives and locations
- With and without SteamVR beta build
- cmd prompt -openvr -skipintro -win tried with every variable above
Same, I've tried the new update out, and still same issue.
 
Thanks for the info, this seems to be a common issue among people who have an AMD 5XX video card. I'm going to look into some code changes regarding how I send data to the headset and see if I can remedy some issues like that which have been popping up lately.
Having the same issue here. RX 580, Ryzen 5 2400G.
 

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top