Kart bug reports thread

Llitechiel ꙮ

Oh, What a Flopnik!
So this is more of a me-issue maybe but I really hate this happening to me:

Back in v1.0.3 and .4, whenever I was online connected to a server with many people on it, whenever I reached the last turn in the water section in Misty Maze Zone, the turn in the beginning of the 3rd lap in Ancient Tomb Zone, and the section right after you spring-dive into water in Virtual Highway Zone, I would drop frames to the point of it looking like a slideshow and then break the ping limit in those specific places on those maps. WOULD NOT happen when there're only a few other people connected with me on a server.

HOWEVER, I downloaded the v1.0.4 Netreplays EXE because I wanted to try it out, and then the above issue no longer occurred for me.

Now it's v1.1 but unfortunately, I was on a big server just recently and the thing in Ancient Tomb on the 3rd lap happened to me again: my FPS became low and then I pinged out of the server. I never once had that problem for as long as I played using the v1.0.4 Netreplays EXE.

Like is there something someone can suggest for me to do about this besides not using an old geezer Windows 7 laptop?
 

VGBoy

The Only Beat Main on SRB2K
On Downhill Jam (from Fickle Hearts) and Blizzard Peaks (From the Rush Adventure pack), when playing online, if anyone reaches the second lap, the game will start desyncing before ultimately kicking me out.
So far, one other person and I had experience with this issue, and it is showing itself as a constant pattern.
No one else has reported this issue, but this is important to bring up to avoid the game experience being ruined for anyone else that may experience this issue!
I am using the Mac version of SRB2K, so I believe this is a Mac-exclusive bug if this is the case.
 

Tatsuru

2.3 will have menus
Moderator
Sonic Team Junior
Judge
Witnessed the same issue as the previous two in Virtual Highway when I got hit by an SPB and the game slowed down to a crawl before timeout kicking both players who were with me in the server. Yet to see another related occurrence.
 

Pode

Member
Master server constantly delists me

Hello

I run [US-East] Crazy Gadget. my server starts out with a successful connection to the master, but will get an error at random intervals. I am running this dedicated server with windows 10. I don't know what else i can say about this issue. it comes at seemingly random times

a54f39e5bb.png


---------- Post added at 10:51 PM ---------- Previous post was at 10:05 PM ----------

update: i have tried this on the windows 32bit build, and it is still persisting
 

TrailBlazer

Trial: Photoner Assault
Eggbox Up-warp + Slope Physic Explosions

Eggboxes will warp up to an available space if placed too close to a wall in some spots
Bf16pva.gif


I don't really know what I'm talking about with this guess but basically I think it's because since Eggboxes are basically normal boxes but they give the Eggman item, they have the same properties as normal item box things so they'll warp up to higher spaces if placed too close to walls.

Next, if you explode on a slope that has physics (like Daytona Speedway's final turns), you'll be moving in the direction that's downwards from the slope.
NKYSAoW.gif


This behavior was noticed already from SPBs in older versions and didn't seem to work with any other explosive item.
But in v1.1, this now seems to be the case (although the speedometer won't notify you of movement sometimes as opposed to an SPB explosion)
With a mine:
fJUtB34.gif


With an Eggbox:
ZxZr3qA.gif
 

Xkower8181

Member
SIGSERV in Kart

From time to time when I try to save a replay, Kart SIGSERVs which happens to me consistently.



I have decided to include my log of couple races before I had this latest SIGSERV.



https://pastebin.com/Q5uc0gCh


In the attached image are some general system information and also a more specific version string from Kart.


EDIT: I also wanted to say that none of those crashes left a srb2win.RPT file to my knowledge
 

Attachments

  • Zrzut ekranu z 2019-06-02 18:01:02.png
    Zrzut ekranu z 2019-06-02 18:01:02.png
    50.8 KB · Views: 153
  • Zrzut ekranu z 2019-06-02 18:05:21.png
    Zrzut ekranu z 2019-06-02 18:05:21.png
    2.7 KB · Views: 156
Last edited:

SteelT

Developer
Sonic Team Junior
Kart Krew™️
Official v1.1 of Kart.
Code:
eip=004c089f
Was watching a replay then changed the view count to 4.
 

FrostedGeulleisia

*insert Glaceon cry here*
Mismatched textures

While messing around, I've found a few textures which didn't quite fit.
kart0106.png


First is this one in Ancient Tomb Zone's first section (the first part with the crushers), it's only the GFZROCK on this one side, and only on this one crusher. It's quite hard to notice without intentionally looking for it.
kart0107.png


And then, we have this ramp near the end of Blue Mountain Zone, although I have no potential explanation towards why it's this texture specifically.
 

Panda.

Just a remapper.
Paradise Hill Zone, near the end of it, there's an invisible platform with offroad where you can strangely stand on water.

giphy.gif
 
Empty players aren't getting notified as so.

Hello! I'm Pol Marcet Sardà, I'm writing from the doomseeker team. We've noticed lately that the new kind of servers of SRB2Kart are reporting players that are empty and the node (https://wiki.srb2.org/wiki/PT_PLAYERINFO) is not being set to 0xff. These players can be easily identified based on the fact that the rest of their values is 0. Also, what is the intended way in which these servers should be separated? Is there a way to only query the classic servers, or the only differentiator is the kart gametype? Let me know, and feel free to drop by on our tracker (https://zandronum.com/tracker/view.php?id=3656) or point me to your desired tracker if you prefer so :)
 

Xkower8181

Member
I could come from the fact that SRB2Kart adds 4 player splitscreen and with said feature you can go online with 4 local players, but however that is a rarely used feature so I doubt it's the cause of that bug.


(PS. It seems that I have problems using the quote feature)
 

Sryder

'That brit'
Kart Krew™️
Hello! I'm Pol Marcet Sardà, I'm writing from the doomseeker team. We've noticed lately that the new kind of servers of SRB2Kart are reporting players that are empty and the node (https://wiki.srb2.org/wiki/PT_PLAYERINFO) is not being set to 0xff. These players can be easily identified based on the fact that the rest of their values is 0. Also, what is the intended way in which these servers should be separated? Is there a way to only query the classic servers, or the only differentiator is the kart gametype? Let me know, and feel free to drop by on our tracker (https://zandronum.com/tracker/view.php?id=3656) or point me to your desired tracker if you prefer so :)

Hi! It looks like the playerinfo packet is expecting the full 32 players, but we halved MAXPLAYERS in kart. I've just created a fix to send the full 32 as a compatibility measure here. Hopefully we can get a hotfix patch out with this before too long.
 
Hi! It looks like the playerinfo packet is expecting the full 32 players, but we halved MAXPLAYERS in kart. I've just created a fix to send the full 32 as a compatibility measure here. Hopefully we can get a hotfix patch out with this before too long.

Thank you so much for the quick response! Another issue would be the ability to distinguish classic SRB2 servers from the new SRB2Kart ones. Is there a way to identify the engine being used? Whether that is from the MS, or through the server itself. If not, while not ideal, is to distinguish these based on the fact that patch.kart is not present in classic SRB2, but that comes at the expense of assuming that that name won't change and that SRB2 won't ever adopt this name.
 

Sryder

'That brit'
Kart Krew™️
Thank you so much for the quick response! Another issue would be the ability to distinguish classic SRB2 servers from the new SRB2Kart ones. Is there a way to identify the engine being used? Whether that is from the MS, or through the server itself. If not, while not ideal, is to distinguish these based on the fact that patch.kart is not present in classic SRB2, but that comes at the expense of assuming that that name won't change and that SRB2 won't ever adopt this name.

I don't see a simple way currently in the game. Which is frustrating because there is a MODID actually in there, but it's not sent back from the server in anything and is only used to check that the game is on the latest version when starting a server from what I can see. There is, of course, the version and subversion sent back in the PT_SERVERINFO packet, but that's likely to change on both counts, unfortunately. patch.kart is also not 100% likely as it's only included to include patch data when the base game needed something changed or added. I think it'd definitely be worth seeing if MODID can be sent from servers directly eventually, I think it'll need to be the same for classic SRB2 though.
 

Llitechiel ꙮ

Oh, What a Flopnik!
q44YUVY.gif


...though I do hear that checkpoints are getting a rework in R2

ALSO, um... it seems as if my previous sitch fixed itself somehow. No longer am I pinging out of servers because of all the people there on those maps, it seems like. I don't know how it's suddenly fine now but I do remember getting an error message beforehand... it was this:

unknown.png
 
Last edited:
When playing online, I consistently get the synch error on Downhill Jam and Blizzard Peaks. Clearly some other people have this problem as well. I have the OSX version.
 
Last edited:

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top