[Utility] SRB2 Mod Retriever & Manager

FuriousFox

AKA FuriousFox
I think I found out why the "Get More Mods" button doesn't work for some of you. You have to set the location for the SRB2 Executable first before it will allow you to use the Get More Mods button.

Seems kind of weird to me to require that, but whatever. Setting that up fixed it for me.
 

SteelT

Developer
Sonic Team Junior
Kart Krew™️
Huh, interesting, maybe he should update it so the button is grayed out, and attempting to click it will give you a message to set the location first. Though it is weird that it is required.
 

Biielz

Ingame name is Lolour
I think I found out why the "Get More Mods" button doesn't work for some of you. You have to set the location for the SRB2 Executable first before it will allow you to use the Get More Mods button.

Seems kind of weird to me to require that, but whatever. Setting that up fixed it for me.
i can say it ''works'' but it doenst show the mods and the hud after the button is super lagged, i dont know if the answer is because i use windows 7
 

dmille

Member
Huh, interesting, maybe he should update it so the button is grayed out, and attempting to click it will give you a message to set the location first. Though it is weird that it is required.

This is actually what is supposed to be happening right now, here's a video example of me opening the application (downloaded from the attachment in the original post) with no previous settings saved. If that's not the case, could anyone in this circumstance confirm that their version is version 1.24.3, shown in the bottom right corner when you click the settings button?

As for the mods not showing and the button being super lagged, well, I couldn't exactly say what might cause that. I don't many external dependencies outside of the installed .NET framework version on your computer being >= 4.5.2, I have a link for it here and in the OP if you haven't tried that already. Regardless, the program shouldn't be too resource demanding but I'll look into it.

Wew don't mean to make this thread just a troubleshooting thread, lol. I hope atleast some of you are able to use my software without having issues, no updates on any future releases but I do have a few ideas I could start implementing soon.
 

dmille

Member
I've noticed the same and have been looking into it, and I think I can make a few guesses from it. What I've been able to deduce so far is at some point within the year, a change was made that if Comcast is your network provider you'll get a cloudflare javascript captcha challenge irregardless of user agent/cookies/activity/patterns of abuse/page traffic/etc., every single time, but not many (any?) other providers have the same blanket ban as far as I've seen. This extends to all subdomains of srb2.org (main page, forums, screenshots and attachments hosted on the forums, etc), though I couldn't really say why.



There are workarounds for this but it is a little annoying to "bypass", and most of my initial attempts to make it workable are pretty kludgy. I'll try and figure out something.
 

AlamGBC

WOO! GO ME! YAHOO!
Administrator
Sonic Team Junior
I've noticed the same and have been looking into it, and I think I can make a few guesses from it. What I've been able to deduce so far is at some point within the year, a change was made that if Comcast is your network provider you'll get a cloudflare javascript captcha challenge irregardless of user agent/cookies/activity/patterns of abuse/page traffic/etc., every single time, but not many (any?) other providers have the same blanket ban as far as I've seen. This extends to all subdomains of srb2.org (main page, forums, screenshots and attachments hosted on the forums, etc), though I couldn't really say why.



There are workarounds for this but it is a little annoying to "bypass", and most of my initial attempts to make it workable are pretty kludgy. I'll try and figure out something.
Oh, this is my doing, I have a hate boner for Comcast

Sent from my Pixel 2 XL using ********
 

dbzkaifan

Member
Does the mod manager break if the path it takes to get to the Sonic Robo Blast 2 executable goes through any "Hidden" folders? (The folder is given the Hidden attribute by Windows)
I keep getting Network errors despite setting the path to the srb2win.exe and having my Firewall grant access to the mod manager.
 

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top