Source code compiling problem.

Status
Not open for further replies.

Cinefast

32 kilowords of core!
For some reason r_draw16.c and r_draw8.c are #include-ed from r_draw.c. When they are mistakenly set to compile by Code::Blocks they don't #include any required headers and therefor won't work (and even if they did, they depend on things only defined in r_draw.c and not exported in headers).

If you could upload the Code::Blocks project file I'll fix this for you.
 

Chimera

Your best friend
Everyone, compile off of the Trunk in the SVN. The current release bundled with SRB2 is broken
 

Mystery Cheese

Mystyc Cheez
It still doesn't work, but this is what happens.

c>mingw32-make mingw=1
"Creating dependency file, depend.dep"
'cc' is not recognized as an internal or external command,
operable program or batch file.
process_begin: CreateProcess(NULL, sh -e C:\Documents and Settings\David\My Docu
ments\Stuff\Sonic stuff\Games\srb2\src\comptime.sh ., ...) failed.
make (e=2): The system cannot find the file specified.
mingw32-make: [pre-build] Error 2 (ignored)
process_begin: CreateProcess(NULL, cc -g -fno-exceptions -DPC_DOS -DNOHW -DNOHS
-DCOMPVERSION -DUSEASM -DHAVE_PNG -march=pentium -Os -DNDEBUG -Wall -Wformat-y2k
-Wformat-security -Wno-cast-qual -c djgppdos/i_main.c -o ../objs/djgppdos/Relea
se/i_main.o, ...) failed.
make (e=2): The system cannot find the file specified.
mingw32-make: *** [../objs/djgppdos/Release/i_main.o] Error 2
 
Last edited:

AlamGBC

WOO! GO ME! YAHOO!
Administrator
Sonic Team Junior
It still doesn't work, but this is what happens.

c>mingw32-make mingw=1

mingw=1 and MINGW=1 are two difference things and

Code:
'cc' is not recognized as an internal or external command,

are you sure you have GCC installed?

if you do, then overwrite the default CC=cc with CC=gcc like so:

Code:
CC=gcc mingw32-make MINGW=1
 

Mystery Cheese

Mystyc Cheez
C:\Documents and Settings\David\My Documents\Stuff\Sonic stuff\Games\srb2\src\sr
c>CC=gcc mingw32-make MINGW=1
'CC' is not recognized as an internal or external command,
operable program or batch file.
 

AlamGBC

WOO! GO ME! YAHOO!
Administrator
Sonic Team Junior
C:\Documents and Settings\David\My Documents\Stuff\Sonic stuff\Games\srb2\src\sr
c>CC=gcc mingw32-make MINGW=1
'CC' is not recognized as an internal or external command,
operable program or batch file.

oh, you are using cmd.exe.......
it been a LONG time since I tested SRB2's Makfile with Windows's cmd.exe/mingw-make.exe combo, do this:
Code:
make MINGW=1 CC=gcc
but this will flood your console window with a lot of commands of gcc.exe
 

Mystery Cheese

Mystyc Cheez
Actually, I'm using Visual Studio Command Prompt (2010), So make doesn't work. This command prompt I'm using is mingled with MinGW. Also, the normal command prompt doesn't recognize make either.
 

AlamGBC

WOO! GO ME! YAHOO!
Administrator
Sonic Team Junior
Actually, I'm using Visual Studio Command Prompt (2010), So make doesn't work. This command prompt I'm using is mingled with MinGW.

sorry, about that, I just have GNU Make set as my default make on my systems, not MSVC's
 
Status
Not open for further replies.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top