Unable to use Custom Colors for some mods

kel

Still don't have a PC...
The skincolors in themselves are working completely fine, I can use them if I select them. I'm on 2.2.8 if you're wondering. So onto the problem; I load Sticky's skincolors and then Modern Sonic, and load into a stage. I typed "rushglow mystic void" into the command bar since Mod Sonic supports custom colors for rushglow. The command didn't change it so I loaded up Shadow and the same thing happens with his skatecolor. I tried putting the order I load the mods and nothing changes.

I'm pretty much stumped beyond thought at this point, could anybody provide a reason why?
 
The skincolors in themselves are working completely fine, I can use them if I select them. I'm on 2.2.8 if you're wondering. So onto the problem; I load Sticky's skincolors and then Modern Sonic, and load into a stage. I typed "rushglow mystic void" into the command bar s-- <...>
Aha! Here's the problem. You put a space in the color's name!
Usually color names with spaces don't work so well in the console (e.g. with the vanilla "color" command). Idk how to fix that, maybe try putting the color name in quotes?
Or alternatively you can replace the space in the color's name with an underscore using a lump editor. Underscores work just fine with the console.
 

kel

Still don't have a PC...
Aha! Here's the problem. You put a space in the color's name!
Usually color names with spaces don't work so well in the console (e.g. with the vanilla "color" command). Idk how to fix that, maybe try putting the color name in quotes?
Or alternatively you can replace the space in the color's name with an underscore using a lump editor. Underscores work just fine with the console.

Sucks, but I can't. Would a text editor and ZArchiver work fine?
 

Icezer

That one dude.
Sucks, but I can't. Would a text editor and ZArchiver work fine?
There's also another option for setting skin color related commands. you can put the name of the color in quotes, and it'll work even if there's a space in there. For example, 'skincolor "Candy Apple"' would technically work provided there's a color with that name.
 

kel

Still don't have a PC...
There's also another option for setting skin color related commands. you can put the name of the color in quotes, and it'll work even if there's a space in there. For example, 'skincolor "Candy Apple"' would technically work provided there's a color with that name.

Thanks buddy! It's working and the color is nice with rushglow!
 
There's also another option for setting skin color related commands. you can put the name of the color in quotes, and it'll work even if there's a space in there. For example, 'skincolor "Candy Apple"' would technically work provided there's a color with that name.
I already mentioned that...
<...> Idk how to fix that, maybe try putting the color name in quotes? <...>
...but ok
 
Top