Confirmed Server vulnerability that enables people to generate intense lag

Status
Not open for further replies.

Wumbo

edited
Well, to start off, I've been getting into running Dedicated Servers recently, and I've been noticing that there were some times that my server would be attacked by a single player (most likely a bot, due to acting so quickly) that would join the server and leave due to a connection timeout. He would do this constantly, over and over, generating unbearable lag, until I was finally able to temporarily disable player joining and put an end to the lag. This has happened to my server at least four times so far, and I've seen it at least once on another server.

Though it's easy to disable player joining whenever this happens, it poses as a threat to Dedicated Servers that basically run themselves. You don't know how long they'll keep doing this; If it really is a bot, they could just leave it running until either the server itself crashes, or people become so fed up with the lag that they quit the game.

This could probably be fixed with a Lua file, but I don't really know. But what I'm trying to say is that this is kinda dangerous, especially when it comes to unmoderated Dedicated Servers.

If there's no way to fix this issue, I could log the IPs of the players/bots that are doing this in the future, if that helps any.
 
Last edited by a moderator:

MK.exe

The one and only!
Kart Krew™️
This does happen to me to. But i feel like they want to generate Synch if anything
 

Rumia1

Backseat Developer
This happens to me from time to time too and it generally stops after 10 seconds or so. It doesn't impact gameplay too much for my server, it just spams the message sound for a while until it resolves itself due to me having a MotD set.
 

Sapheros

Member
This is a bug I get quite often on my servers, and I can confirm it's not a bot at all. This is more or less a major synching bug that the server host will receive. As for the player causing it, they're synching bricks and don't get disconnected until they actually leave the server themselves.
 

Wumbo

edited
This is a bug I get quite often on my servers, and I can confirm it's not a bot at all. This is more or less a major synching bug that the server host will receive. As for the player causing it, they're synching bricks and don't get disconnected until they actually leave the server themselves.
I see. Well, this (and both other posts) have answered my problem, I guess. Looks like I was pretty wrong, but seeing that it's still most likely a bug, I hope it gets fixed soon.
 
Status
Not open for further replies.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top