Netcode Issue Reports (Report netplay issues HERE!!)


Formerly Inuyasha, Retired Staff
Okay, keep any and all netcode issues in this topic. We know there's a fundamental flaw in it somewhere, but without a lot of info we can't do a damn thing about it.

Try to include as much information as you can about what was going on. Also, please include your system's locale information (you can find that out here in Windows 7, for example) - 2.1.0's issues were because of locale differences, and we want to make sure it's not a locale dependent thing. Additionally, please include info on what build you were using; whether it was the official SRB2 Executable, or if it's a separate build; what platform you're running on, et cetera.

Having said that, if the issue happens in local multiplayer (splitscreen), then it is not a netcode bug and should be reported normally.
Last edited:
The game "Crashed" Several times when i was Trying to play Online
Crash Repport (from "SRB2WIN.RPT")
OS : Windows 7 Ultimate Service Pack 1 32bit

Error occured on Tuesday, April 8, 2014 at 21:48:36.

D:\Farouk\SRB2 2.1.X\srb2win.exe caused an Access Violation at location 00498497 in module D:\Farouk\SRB2 2.1.X\srb2win.exe Reading from location 02e3f7ff.

eax=02e34150 ebx=02bfee24 ecx=00000000 edx=0000b6af esi=02bfee24 edi=0023f990
eip=00498497 esp=0023f8e0 ebp=0023f968 iopl=0 nv up ei pl nz ac po nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00210216

Call stack:
00498497 D:\Farouk\SRB2 2.1.X\srb2win.exe:00498497
0047960C D:\Farouk\SRB2 2.1.X\srb2win.exe:0047960C
004B39A0 D:\Farouk\SRB2 2.1.X\srb2win.exe:004B39A0
004B6D3C D:\Farouk\SRB2 2.1.X\srb2win.exe:004B6D3C
004A4BAB D:\Farouk\SRB2 2.1.X\srb2win.exe:004A4BAB
0042CFD9 D:\Farouk\SRB2 2.1.X\srb2win.exe:0042CFD9
0040B209 D:\Farouk\SRB2 2.1.X\srb2win.exe:0040B209
00403460 D:\Farouk\SRB2 2.1.X\srb2win.exe:00403460
00402A53 D:\Farouk\SRB2 2.1.X\srb2win.exe:00402A53
0051AA87 D:\Farouk\SRB2 2.1.X\srb2win.exe:0051AA87
004011D9 D:\Farouk\SRB2 2.1.X\srb2win.exe:004011D9
00401243 D:\Farouk\SRB2 2.1.X\srb2win.exe:00401243
7C817067 C:\WINDOWS\system32\kernel32.dll:7C817067 RegisterWaitForInputIdle


Error occured on Wednesday, April 16, 2014 at 10:33:22.

D:\Farouk\SRB2 2.1.X\srb2win.exe caused an Access Violation at location 004ef78a in module D:\Farouk\SRB2 2.1.X\srb2win.exe Reading from location 0ecce031.

eax=07a917c9 ebx=0474f200 ecx=000000d1 edx=000007a9 esi=0eccd888 edi=056f040c
eip=004ef78a esp=0022c07c ebp=ffffffff iopl=0 nv up ei pl nz na po nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010206

Call stack:
004EF78A D:\Farouk\SRB2 2.1.X\srb2win.exe:004EF78A
004C932F D:\Farouk\SRB2 2.1.X\srb2win.exe:004C932F
004C0809 D:\Farouk\SRB2 2.1.X\srb2win.exe:004C0809
0040322B D:\Farouk\SRB2 2.1.X\srb2win.exe:0040322B
004033C0 D:\Farouk\SRB2 2.1.X\srb2win.exe:004033C0
00402A53 D:\Farouk\SRB2 2.1.X\srb2win.exe:00402A53
0051B107 D:\Farouk\SRB2 2.1.X\srb2win.exe:0051B107
004011D9 D:\Farouk\SRB2 2.1.X\srb2win.exe:004011D9
00401243 D:\Farouk\SRB2 2.1.X\srb2win.exe:00401243
762CED6C C:\Windows\system32\kernel32.dll:762CED6C BaseThreadInitThunk
77BF377B C:\Windows\SYSTEM32\ntdll.dll:77BF377B RtlInitializeExceptionChain
77BF374E C:\Windows\SYSTEM32\ntdll.dll:77BF374E RtlInitializeExceptionChain


Error occured on Wednesday, April 16, 2014 at 15:04:01.

D:\Farouk\SRB2 2.1.X\srb2win.exe caused an Access Violation at location 004b3a6a in module D:\Farouk\SRB2 2.1.X\srb2win.exe Reading from location 00000060.

eax=00000000 ebx=00000001 ecx=00008e20 edx=00000000 esi=00000000 edi=00008e20
eip=004b3a6a esp=0022fd50 ebp=0022fdf8 iopl=0 nv up ei pl zr na po nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010246

Call stack:
004B3A6A D:\Farouk\SRB2 2.1.X\srb2win.exe:004B3A6A
004034FA D:\Farouk\SRB2 2.1.X\srb2win.exe:004034FA
00402A53 D:\Farouk\SRB2 2.1.X\srb2win.exe:00402A53
0051B107 D:\Farouk\SRB2 2.1.X\srb2win.exe:0051B107
004011D9 D:\Farouk\SRB2 2.1.X\srb2win.exe:004011D9
00401243 D:\Farouk\SRB2 2.1.X\srb2win.exe:00401243
7680ED6C C:\Windows\system32\kernel32.dll:7680ED6C BaseThreadInitThunk
7717377B C:\Windows\SYSTEM32\ntdll.dll:7717377B RtlInitializeExceptionChain
7717374E C:\Windows\SYSTEM32\ntdll.dll:7717374E RtlInitializeExceptionChain
System's Locale : Arabe (Algeria)
Build : Srb2win.exe "The Official"
Last edited:
I Actually can't play SRB2 Online, and i wasn't able to play it since 2.1 was Released .. (Common Reason) will it be fixed on the next Release ... ?
Woah,i just joint a Multiplayer server While the server was Playing a NIGHTS Level,then Here's what Happened :
Started by Spectating another Player , But the Player isn't in the Super form,just a Brown sonic Falls and Disappears Continiously, and the "Resynching" Lags Everything,I ... I was shocked to the point of forgetting the image capture , but here's what i Captured :
Last edited:
(Build: 2.1.7 installer with the 2.1.8 patch, regular executable from the website; also happened back in older 2.1.x versions)
tobefree@tobefree-linux:~$ locale
About the flag bug (have the original topics simply been deleted? :-/), that's quite easy to reproduce for me:

1. Start SRB2, join a CTF netgame.
2. In the background, start a huge download now or do something else which uses your full bandwidth and thus causes packet loss for SRB2. Using a bad Wi-Fi might already be enough, I don't know.
3. Play CTF normally. You will probably see some "Resynching..." messages. However, this resynching apparently isn't done correctly. Weird things might happen with the flag of your enemy team, for example. Try capturing it, try throwing it, try hitting the enemy team's flag carrier and see what happens.

I think that the bug is not Wine-specific; it also happened to me on servers which I assume to have been run on Windows, and it clearly also happens to regular Windows clients. Also, the bug happens really frequently; all that is needed to trigger the weirdness for me is a simple resynchronization process.

I don't know any details about SRB2's code, but I would assume that the major flaw has to be searched whereever synching of the CTF flag states happens.

-------------------- update, 2014-04-29: --------------------

This bug happens with other player-modifiable objects too, like crumbling walls and even crawlas:




Last edited:
2.1.X Chat Bug

Whenever I play on any server, and I use the chat whilst on the server, sometimes it will not show up, but only other people on the server can see it. It has also happened to many other players. This bug needs to be fixed so the chat can become what it once was in 2.0.X
Last edited by a moderator:
This happens to me quite often, too. It's confusing because there is no way to know that the message has already been sent, and I have been sending messages multiple times until I realized that the first message was already delivered. :/
^ maybe it has something to do with this. :)
Last edited:
I think part of the issue with netcode just locking up might be related to some clients not receiving the "okay, we're resyncing now" signal, or leaving during a resync attempt. (I had two separate server freezes in private netgames last night; one time the only guy responding to server ping said he flat-out didn't see anything about a resync, and the other time he had left entirely.) I know nothing about how the netcode works, but does it have any mechanisms in place against those?
Messages not going through to other players

Like the title says, when I host srb2 sometimes when one player types something into the chat, the other players wont get it. And when I say sometimes,i mean like 1/3 or 1/2 messages get lost this way. The worst part is that this comes in two flavors. One kind has it so that you type the message, hear the message sound, see it in the console AND the log, but the other player just doesn't get it. The other flavor has it so that when you type the message out, YOU dont actually see it in the console or the log. But at least then, the other person DOES get it. I havent has the second kind happen to me much, but the first kind does happen, and frequently too.

Now, I don't know MUCH about networking and things,but i do understand the idea of packets. This is a very simplified version of how it goes.

You see,when one person messages the other,a message packet is sent to the other person. Now if that packet gets corrupted along the way, the other person's internet automatically sends a packet back saying that the message wasnt sent correctly. And if it gets sent correctly,the other internet sends a packet back saying it went correctly. However,if the first internet doesn't get a packet back,or gets a packet saying the text was corrupted... It just sends the packet again untill it gets successful.

My guess is that something changed in 2.1 to cause something to mess up there.

Anyhow, if you could fix this, it would go a LONG way to making netplay more bearable.
When I join a server that has 5 or more people it says "downloading game state" and never ends up joining the server.
These are two things that has persisted since 2.1's initial release. In NiGHTS mode nodes higher than others can push lower nodes out of the ideya capsule (obviously very annoying for the host) and if someone joins after someone has the emerald and touches the NiGHTS activator, the level ends and you don't get the emerald.

EDIT: Also, new glitch: Seemingly by random, you can join a server and the game will soft lock (you can still turn and use the console, but the game world will be entirely frozen, but you can't be kicked) and hold the server up until you leave. Once this happens once it keeps on happening until you restart SRB2. I don't know what causes it for sure, but it might be from repeated sfails and joining.
Last edited:
When I join a Server(any Server),while the Host pauses when joining,people are getting named by Player(X) names.
So, as this was bumped some minutes ago:
If you try to download files from a server and then abort (Often because the file stops downloading for X reasons), the server will try to download srb2.srb for no reasons.
Not sure what's going on but at this very moment there seems to be an issue with the master server; I've got a pretty old computer with XP pre-installed, only 512 mb of ram but the thing is I tried joining a game and the computer locked up forcing me to restart it, twice:once by simply clicking join game and waiting about 30 minutes, coming back and restarting the system, it locked up again after using the listserv command. Went and checked out a few times and it seems all servers, including 24 hour dedicated servers are offline. Don't know what's going on, but just thought I'd raise awareness. I don't think it really applies here but for future reference:
Locale: English (United States)
SRB2 Build: 2.1.8 (aka official, up to date)
The flag bug is still present


I just wanted to point this out, as I first thought that this was also fixed in 2.1.10.* So if it was supposed to be fixed, something went wrong. :/

Again, I have absolutely no idea of the underlying code, but this looks like resynchs do not contain correct information about the current flag status. I can hardly make suggestions, but to me, it seems like the game would incorrectly determine what information the client already has and thus has not to be sent to the client again. If this is the case, sending the flag status (position, current holder etc.) regardless of resyncs, maybe every 30 seconds or so, would at least make this bug disappear after at most 30 seconds.

*This might look weird, but I have not been playing since 2.1.7 and was mainly referring to the netcode changes in 2.1.9. :)
Last edited:
Zandronum's netcode is actually the best netcode,and SRB2's netcode is very buggy (more then Doom Legacy's first netcode),whenever a new player joins the game he affects the server by somehow and Resynchronization starts ... While in other DOOM Source Ports players can freely join without affecting others.
Okay, most people on the IRC have seen me rage and complain about this, and it's time this gets sent to its place.

Resynch is supposed to pause the game and synch in the state that the player out-of-synch is not in. Most joining players hate waiting forever, or for synch to fail them, and leave to rejoin again. However, when resynch starts to occur, and the person leaves as resynch is going on, The server freezes. Apparently, this is synch's fault, as the server tries to synch in A STATE THAT DOESN'T EXIST. This result is all the more bullshit, due to the server's frozen state of synch, trying to shut down the server by returning to the title screen crashes the game. A popup message during the crash says: "Tried to transmit to another node" and closes the game. This is a serious problem I wish i could find a solution to, but it's so unavoidable, because the 2.1 feature to make c-fails a living thing of the past, has created 100 more problems for SRB2 Players everywhere. If anything about this netcode should be fixed, it's this fucking problem.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)