• Due to the dramatic number of changes to the game in 2.2, the old Bug Reports subforum has been archived and we are starting with a clean slate.

    If you feel you have found a problem with the game, please create a new thread with a summary of the bug as the thread name. Try to include as much information as you can in the initial post, including a description of what the expected behavior is and ways to reproduce the bug (if possible). Do not hesitate to upload any screenshots, logs, or WAD files that may aid in identifying and solving the issue. You do not need to enable DEVMODE for any screenshots you take; important information such as location, info, map name, and map number is automatically stored inside every screenshot.

    Please make one thread for each bug you find. Grouping multiple bugs together in a single thread makes it much harder for us to track what bugs have been fixed. To that end, any thread that does group unrelated bugs together will immediately be marked "Invalid" and locked.

    A member of our crack development team will come around and see what they can do about your reported issue. Additionally, if you have any useful information to add to a bug report thread (even if you aren't the original poster), you are welcome to post in the thread to add your input.

    A quick definition of each resolution:

    (none)
    The bug has yet to be confirmed by a member of the development team.

    Confirmed
    The bug has verified to exist in the game, but nobody is currently working on fixing it at the moment.

    Assigned
    The bug has verified to exist in the game, and a developer is currently fixing it (or planning to fix it shortly). Smaller bugs that take a short amount of time to fix may skip this step.

    Fixed
    The bug has been fixed for the next version of SRB2. These threads will always be locked afterwards.

    Invalid
    The submitted report is not valid. Reasons for this include reports of intentional behavior, or reports that have been confirmed to not occur in the original game. These threads may be locked at a developer's discretion.

    Duplicate
    This bug has already been reported. These threads will always be locked with a link to the original bug report given.

    Isolated Case
    The development team has not been able to reproduce the bug. These threads will remain open so that others may provide additional information or clarification.

    Won't Fix
    The bug will not be fixed. This typically means that the bug is too trivial to worry about or has been decided to be kept as an intentional feature. These threads may be locked at a developer's discretion.


    Thanks for helping improve SRB2!

    Note, bug reports for SRB2Kart should be submitted to their bug reports thread: https://mb.srb2.org/showthread.php?t=43795

Mobile Port Control Bug

SirIncompetent

The unfunny terrible person!
So a few days ago, I loaded up SRB2 on my phone.
Now normally, my phone runs SRB2 amazingly,
with the exception of netgames. I went to the menu,
and tried to press Singleplayer, but somehow, the game wouldn't
allow it. I then tried Settings, but it was the same story.
Nothing worked, except for the Multiplayer option,
which when I selected it, the back and forward buttons didn't work.
I then restarted the app, but nothing changed.
I just reinstalled the app after that, and then everything worked.
I do not know how it happened and have not been able to replicate it,
but I have a small theory. I believe it happened
when I restarted SRB2 a few days after joining a netgame and having
to close SRB2 when I was messing around with the video settings
and making the screen resolution larger than my phone screen
actually has, making the game unplayable. However, when I restarted
SRB2 which is when the glitch happened, the screen size was
restored. I hope you will take note of this, and have a wonderful day or night!
 

GOTTAGOFAST!

When the imposter SUS
200 posts woaw I did not expect 100 posts together so my new record and I cannot move I keep holding the joystick button and jump and spin button don't work I have to press higher to set my options the use and back buttons do not work only movement in options smoe help?

---------- Post added at 08:17 PM ---------- Previous post was at 08:17 PM ----------

I mean 100
 

salmxn

Member
it happened to me too,but after a few times it happened the game works fine for weeks.but when i install some mods and put them in the addons folder it happened again
 

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top