Fixed [2.1.18] Minor but Annoying Issue...

Status
Not open for further replies.

Chaotic Chao

horns Horns HORNS
Put simply, ever since the 2.1.17 update, whenever I try to test a map in Single Player via launching with Zone Builder, I'm forced to play as Sonic every time no matter what skin I choose in testing options. While not technically a massive issue, this wastes a LOT of time if I have to test with a character besides him, especially if I have to do it outside of coop, and *especially* since I save my work to a folder other than the one SRB2 is in for cloud storage purposes...
 
Last edited by a moderator:

Mystic

Member
While there's probably a bug involved somewhere, I recommend setting up some binds in autoexec.cfg to enable devmode and switch skins. While devmode is enabled, you can switch skins in single player, which is a very useful feature to have in general while testing.
 

toaster

トースタちゃん
Kart Krew™️
Woops! This is an issue with my fix for being able to switch skins during the credits. It turns out that the singleplayer server is started before the skin change command is recieved, but before the level actually starts. There should be a whitelist for that one particular gamestate, although startup is so quick that it's not quite clear what that gamestate would report as.

EDIT: Here's a fix-fix. Would someone mind moving this topic to bug reports so I can mark it appropriately?

DOUBLE EDIT: Thanks!
 
Last edited:
Status
Not open for further replies.

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top