SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing > Editing Help

Reply
 
Thread Tools Search this Thread
Old 2 Weeks Ago   #1
IttaBitta
Default Cannot find a map remotely named 'whatever'

Well that's the error message. I'm trying to test my map but I'm a beginner you see.
IttaBitta is offline   Reply With Quote
Old 2 Weeks Ago   #2
Rumia1
Backseat Developer
 
Rumia1's Avatar
Default

When typing out the map command, you need to type in map mapaz or whatever the 2 character map number is. Or you can substitute the mapaz for some part of your level name. If you're testing your map it might be easier to rename the map lump to map01 in SLADE and rename it to another slot later though.
__________________
Quote:
Originally Posted by Cirno
Egguman-senpai...
Rumia1 is offline   Reply With Quote
Old 2 Weeks Ago   #3
IttaBitta
Default

I should probably specify that I mean in zone builder, when I press the test button.
IttaBitta is offline   Reply With Quote
Old 2 Weeks Ago   #4
Kaysakado
Default

In Zone Builder, go to Tools->Game Configurations->SRB2 2.2->Testing. What are the options set to there?
Kaysakado is offline   Reply With Quote
Old 2 Weeks Ago   #5
IttaBitta
Default

Code:
C:\Users\ittan\Downloads\Sonic Robo Blast 2\srb2win.exe
single player.
That is all :V

Last edited by IttaBitta; 2 Weeks Ago at 06:01 AM.
IttaBitta is offline   Reply With Quote
Old 2 Weeks Ago   #6
Kaysakado
Default

Check Customize parameters, and see if it has something like this:
Code:
file "%AP" "%F" -warp %L
Your error message sounds like something's causing srb2 to try to -warp whatever, which uh, won't work. Also, go to Edit->Map Options, and make sure the Game Configuration is set correctly.
Kaysakado is offline   Reply With Quote
Old 2 Weeks Ago   #7
IttaBitta
Default

It was set to that, but changing it causes it to just start the game but not load the level.

---------- Post added at 02:19 AM ---------- Previous post was at 01:43 AM ----------

if this matters it says the result is this:
Code:
-file "C:\Users\ittan\Downloads\Sonic Robo Blast 2\Builder\MAPER01.wad" "C:\Users\ittan\AppData\Local\Temp\jjcue9wn\e3jrqs37.wad" -warp MAPER01 +skin sonic
IttaBitta is offline   Reply With Quote
Old 2 Weeks Ago   #8
glaber
Emblem Radar Ready
 
glaber's Avatar
Default

May I suggest you move SRB2 outside of the downloads folder?
__________________
Welcome to my Dimension
glaber is offline   Reply With Quote
Old 2 Weeks Ago   #9
PencilVoid
Circuit Enthusiast
 
PencilVoid's Avatar
Default

Quote:
Originally Posted by IttaBitta View Post
It was set to that, but changing it causes it to just start the game but not load the level.

---------- Post added at 02:19 AM ---------- Previous post was at 01:43 AM ----------

if this matters it says the result is this:
Code:
-file "C:\Users\ittan\Downloads\Sonic Robo Blast 2\Builder\MAPER01.wad" "C:\Users\ittan\AppData\Local\Temp\jjcue9wn\e3jrqs37.wad" -warp MAPER01 +skin sonic
MAPER01 is not a valid map code, so you may want to fix that.
__________________
Discord: PencilVoid#4223
Twitter: @pencilvoid / @pencilvoid_art
PSO2 ID: 14909977; Username: PencilVoid

May I interest you in the Church of Audie?

Last edited by PencilVoid; 2 Weeks Ago at 03:35 PM. Reason: grammar
PencilVoid is offline   Reply With Quote
Old 2 Weeks Ago   #10
Kaysakado
Default

-warp MAPER01 is wrong, I don't know what's causing that.

...did you set the level name to "WHATEVER"? you can't do that, go to Map Options and set the Level name to something sensible like MAP01. It's labelled "Level name" but it's not actually the name of your level - it's the name of the lump Zone Builder will save your level to. Should be in this format:
Quote:
The map numbers are ordered first from MAP01–MAP99, then MAPA0–MAPA9, MAPAA–MAPAZ, then MAPB0–MAPB9, MAPBA–MAPBZ, and so on, all the way up to MAPZZ.
Kaysakado is offline   Reply With Quote
Old 2 Weeks Ago   #11
IttaBitta
Default

Quote:
Originally Posted by Kaysakado View Post
-warp MAPER01 is wrong, I don't know what's causing that.

...did you set the level name to "WHATEVER"? you can't do that, go to Map Options and set the Level name to something sensible like MAP01. It's labelled "Level name" but it's not actually the name of your level - it's the name of the lump Zone Builder will save your level to. Should be in this format:
I did not. I was illustrating that I've tried several names, from MAPER to BIGBCH to everything in between.

---------- Post added at 05:19 PM ---------- Previous post was at 05:17 PM ----------

well, that seems to of fixed it
hmm
IttaBitta is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.