SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > SRB2 Discussion

Reply
 
Thread Tools Search this Thread
Old 02-13-2014   #1
Shardvexz
Cosmophile on IRC/Discord
 
Shardvexz's Avatar
Default Super-easy, Fast, Port Forwarding!

No more Hamachi! :P

If you're like me, you're too lazy to go through the hastle of port forwarding. Or you might be at a friend's house, and not know the password to your friend's router. Or maybe your parents don't want you messing with the network. Well, I have a solution for you!

After a lot of googling, I have found a way to quickly port forward without the username and password to your router, in just a few seconds! It's a program called "PortMapper." All you have to do is enter in the port you want to forward, which is port 5029 UDP for SRB2.

Download: http://upnp-portmapper.sourceforge.net/#download
Tutorial: http://www.howtogeek.com/122227/how-...p-application/

This program is much better than a similar program called Hamachi. Hamachi requires you to register an account. It also requires other people to be running Hamachi to join your server. But PortMapper does not require any of this, it simply forwards your ports.

It's a java program so you will need the Java runtime. I've tested it on Windows 7, and it works great! Try it out and let me know if it works. :)
__________________
I want a signature that is huge, animated, distracting, and obnoxious that draws attention to me.
Shardvexz is offline   Reply With Quote
Old 02-13-2014   #2
Maximus123458
Default

Either i'm doing something wrong, or this does not work..

http://i.imgur.com/rWW7rFd.png
Is this how it's supposed to be configured?
Maximus123458 is offline   Reply With Quote
Old 02-13-2014   #3
SteelT
Developer
 
SteelT's Avatar
Default

This still requires you to know your router username and password. There is no way of port forwarding without accessing your router, so these programs just automate the port forwarding part for you. But you still have to input your router username and password.
SteelT is offline   Reply With Quote
Old 02-13-2014   #4
Shardvexz
Cosmophile on IRC/Discord
 
Shardvexz's Avatar
Default

Not sure what is wrong Maximus, your configuration looks fine. Did you make sure "use local host" in the edit window is enabled?

Steel the fox: When I tried it I didn't have to input any username or password.
__________________
I want a signature that is huge, animated, distracting, and obnoxious that draws attention to me.
Shardvexz is offline   Reply With Quote
Old 02-14-2014   #5
u4704
Default

That's why it probably works without entering a password, and that's also why it won't work if somebody took the time to properly secure the network by changing the router's weird default settings. ;)
u4704 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.