Starter's problem

MacroPoli13

Member
OK. SO.
I wanted to make a mod for this game, so I thought of starting with something basic - making a 2.1 character playable in 2.2.
Now, the mod I went for (Cream) obviously didn't work due to how 2.1 sprites have different names compared to 2.2 sprites
(for example, Cream's idle was called CREMA1 instead of the usual STNDA1)
Now, after a bit of tinkering, I managed to get both her idle and waiting animations to work in game (even though they looked off due to legacy colours)

HOWEVER.

Once I started to do her walk animations, the error below began to pop up.
I can't seem to fix it, even though I'm using the structure of a 2.2 character to mod her back in.
Any advice to fix this? Would be much appreciated.
 

Attachments

  • the problem.png
    the problem.png
    15.8 KB · Views: 70
Try looking at the error message. Did you add all the rotations? Did you correctly add the WALK animation, name and all? Does the character use 5 rotation sprites instead of 8, mirroring some of them to fit all 8 directions?
 
Last edited:
Try looking at the error message. Did you add all the rotations? Did you correctly add the WALK animation, name and all? Does the character use 5 rotation sprites instead of 8, mirroring some of them to fit all 8 directions?
YES, it does use 5 sprites instead of 8.
ALTHOUGH the character I was using as code base used the same amount, so IDK really.
 
YES, it does use 5 sprites instead of 8.
ALTHOUGH the character I was using as code base used the same amount, so IDK really.
Maybe just copy the ones that are usually flipped and flip them so you can get all 8 rotations? I don't know much about how characters work, but it should work this way.
 
OK. SO.
I wanted to make a mod for this game, so I thought of starting with something basic - making a 2.1 character playable in 2.2.
Now, the mod I went for (Cream) obviously didn't work due to how 2.1 sprites have different names compared to 2.2 sprites
(for example, Cream's idle was called CREMA1 instead of the usual STNDA1)
Now, after a bit of tinkering, I managed to get both her idle and waiting animations to work in game (even though they looked off due to legacy colours)

HOWEVER.

Once I started to do her walk animations, the error below began to pop up.
I can't seem to fix it, even though I'm using the structure of a 2.2 character to mod her back in.
Any advice to fix this? Would be much appreciated.
You are almost definitely missing placeholder sprites in the WALK animation. You must have frames for all rotations, regardless of whether they are unique or shared between rotations.
 

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Back
Top