Hey how to fix my character error called "R_LoadSkinSprites: no frames found for sprite SPR2_STND"

El-fire

i am a toaster
open slade and open the player.dta file from SRB2 and go look to see what you need to do i cannot explain it very well.
Screenshot (105).png

Post automatically merged:

your character needs the standing sprites and have the proper names to work.
 

Rapidgame7

waiting for avatars to be fixed
Moderator
A character must have ALL the sprites it needs, or the game will crash when trying to load them.
This is not entirely true since 2.2.

While it is preferable that a character has all its sprites so every ability used has some flair, the game falls back to a different sprite set if one particular set is not found, all the way back to STND if applicable.

STND does not have a fallback sprite set, so if there are no STND sprites, the game refuses to load the character and throws an error.
As such, you need at least one sprite in this set.

Again, it is preferable you have sprites for everything your character does. You can just give it a single stand sprite, but that means the game will display it for everything, from jumping to getting hit lol

It only would work on pc, not mobile that's so weird.
Yeah, WAD modding programs are only available on desktop.
You can sort of circumvent it with zip explorers in Android but it's a horrible mess to wade through things.
 

sonic cool

do you know the way?
I think that make a mod in mobile is a little bit hard but is still posible,like the sprites part
Post automatically merged:

But it only gives me that crash, if i make a lua script in mobile.
Try to review the script and open a another mod file that have something like what you are doing or something(or if you are doing a lua that looks like a lua of a old version like 2.1 i think that inst too hard to remake it
 
Last edited:

HMSREBORN

kauagameszaoasda · From Ohio
I think that make a mod in mobile is a little bit hard but is still posible,like the sprites part
Post automatically merged:


Try to review the script and open a another mod file that have something like what you are doing or something(or if you are doing a lua that looks like a lua of a old version like 2.1 i think that inst too hard to remake it
iam from brazil too lol
 

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)

Top