SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing > Editing Help

Reply
 
Thread Tools Search this Thread
Old 2 Weeks Ago   #1
Nicolas618
Default Help With Skin Colors.

Hi! well the error is, that when i put my skincolor lua that i make yesterday, it says this :



(that = near char(1) Thing)

Also, if you want to see the code :



Nicolas618 is offline   Reply With Quote
Old 2 Weeks Ago   #2
Kaysakado
Default

Not 100% sure this is all accurate, but this is what I think:

You have a file with the extension .lua, and you included a lua script as a lump *within* that file as if it were a WAD. When SRB2 adds a file with the extension .lua, it assumes it's reading a plaintext file (as if you saved it from a text editor, not SLADE), so it gets confused when it starts reading WAD header data that SLADE saved.

If you originally created this file as a "Wad Archive" in SLADE, try just changing the file extension to .wad and see if it works.

If you originally created this file as a "ZIP Archive" in SLADE, try making a folder called "Lua" in the archive, put your script in there, and then save it with the extension .pk3.

If you don't intend to package anything else with these skincolors, though, you really should just make a proper .lua file! Copy your script into a plain text editor (like notepad.exe), and save it with the extension .lua.
Kaysakado is offline   Reply With Quote
Old 1 Week Ago   #3
Nicolas618
Default

It worked, thank you! I can throw it to Submissions now!!
Nicolas618 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.