SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 12-08-2019   #1
Goldenhog
Wandering Protagonist
 
Goldenhog's Avatar
Default How to improve performance

I can't believe I'm asking this for SRB2 of all games.

So basically, the new CEZ2 is so awesome that my computer has to absolutely kill itself to render it all. I've tried messing with the video options, but the only one that did anything was changing the resolution to 320x200. It didn't even help that much - I had to play the whole thing with pixels the size of my eyes and a silky-smooth framerate of 11 FPS. The only other places where it gets this bad are HHZ and a couple areas in ARZ2. The latter isn't a big issue and the former I can just cheese with Tails, but I can't do that with CEZ2 without starting a new savefile.

It's possible that it's my computer but again, this only happens in a few places. I was hoping there was some graphic option I didn't notice or a console command I don't know about that could help. Or maybe an ETA on the 64-bit executable, since those were supposed to help performance, assuming those exes are still a thing that's happening (the download page specifies the file is 32-bit).
__________________
Quote:
Originally Posted by Asagi Asagiri
I need power over the people! The stupid, STUPID people!
Goldenhog is offline   Reply With Quote
Old 12-08-2019   #2
RomioTheBadass
PK3 Fetishist
Default

Runs fine here, what are your PC specs? also I hear switching to OpenGL helps make the game run smoother for some people.
__________________
Also known as "RTB" on Discord
Quote:
I don't need sex because Azure Temple fucks me everyday

Last edited by RomioTheBadass; 12-08-2019 at 03:55 PM.
RomioTheBadass is offline   Reply With Quote
Old 12-08-2019   #3
Goldenhog
Wandering Protagonist
 
Goldenhog's Avatar
Default

OpenGL SIGSEGVs on startup. I can believe that one is due to my computer, I remember having other issues with OpenGL back in 2.1.

Intel Celeron 1.80 GHz 64-bit CPU, 4GB RAM, running Windows 8.1. It's amazing, I know, but it was running SRB2 fine before! It's still running it fine now, outside of CEZ2 and HHZ! I'm reading some other threads about the new release and apparently other people are having issues with CEZ2 too so maybe there's something in the map that's causing it. I hope not because it'd mean there's nothing I can do without a different computer.
__________________
Quote:
Originally Posted by Asagi Asagiri
I need power over the people! The stupid, STUPID people!
Goldenhog is offline   Reply With Quote
Old 12-08-2019   #4
Llitechiel ꙮ
Oh, What a Flopnik!
 
Llitechiel ꙮ's Avatar
Default

So I am gonna reply here to share a similar experience with framerate I've had with CEZ2 using software mode, but... it's kinda weird (Pentium(R) Dual-Core CPU, T4300 @ 2.10 GHz, 4 GB RAM, 64-bit Windows 7)

Strangely, about some of the times when I start CEZ2, it immediately drops frames to about 8 - 12 FPS, and most other times it starts at a full 35/35. However, even still when it's those times that start with full frames, it will eventually begin to lag at some point and drop to 8 - 12 FPS... which I've noticed could happen when playing after about 30 seconds in, to 2 minutes in. Closing other memory-using programs like desktop Discord which I usually run, and lowering my resolution to the smallest possible, is to no avail. HowEVER, when I minimize SRB2 in the middle of playing on CEZ2 like this, and then when I open it back up after about a few minutes, it doesn't lag any longer... until about a minute or two... cycle repeating. So I'm pretty much getting lag spikes independent of where in the level I am and what resolution's being used. I'm at a loss of what I can do about this situation to try and up my framerate, outside of... not playing on a laptop that's a decade old. Maybe I too can wait for a 64-bit EXE? I'm unsure, though, that that will be able to fix... this.
__________________
New Multiplayer Music (sonic: emerald quest + 2)
Llitechiel ꙮ is online now   Reply With Quote
Old 12-08-2019   #5
Prime 2.0
Grape flavored
Administrator
 
Prime 2.0's Avatar
Default

Quote:
Originally Posted by Llitechiel ꙮ View Post
So I am gonna reply here to share a similar experience with framerate I've had with CEZ2 using software mode, but... it's kinda weird (Pentium(R) Dual-Core CPU, T4300 @ 2.10 GHz, 4 GB RAM, 64-bit Windows 7)

Strangely, about some of the times when I start CEZ2, it immediately drops frames to about 8 - 12 FPS, and most other times it starts at a full 35/35. However, even still when it's those times that start with full frames, it will eventually begin to lag at some point and drop to 8 - 12 FPS... which I've noticed could happen when playing after about 30 seconds in, to 2 minutes in. Closing other memory-using programs like desktop Discord which I usually run, and lowering my resolution to the smallest possible, is to no avail. HowEVER, when I minimize SRB2 in the middle of playing on CEZ2 like this, and then when I open it back up after about a few minutes, it doesn't lag any longer... until about a minute or two... cycle repeating. So I'm pretty much getting lag spikes independent of where in the level I am and what resolution's being used. I'm at a loss of what I can do about this situation to try and up my framerate, outside of... not playing on a laptop that's a decade old. Maybe I too can wait for a 64-bit EXE? I'm unsure, though, that that will be able to fix... this.
Oh god, my old laptop had this problem, except it ran on a 6 second cycle instead of every few minutes, even did it on the title screen if lua was loaded. I never figured out why.
__________________
Science tells us that nothing can be proven, only rendered more likely to be true. If we do not question what we already know, how can we know, much less admit, when we're wrong? Such things are vital to progress.
Prime 2.0 is offline   Reply With Quote
Old 12-09-2019   #6
Yoshirocks90
 
Yoshirocks90's Avatar
Default

Mine was doing this too, but I just figured my laptop was just struggling to process the new look, considering it's a bit low-end.
Yoshirocks90 is offline   Reply With Quote
Old 12-09-2019   #7
tabu
Default

if you want my opinion, we just need to integrate (steal) gzdoom's occlusion culling code
tabu is offline   Reply With Quote
Old 12-11-2019   #8
Hyperknux
The board's UK Ecologist
 
Hyperknux's Avatar
Default

Quote:
Originally Posted by Llitechiel ꙮ View Post
So I am gonna reply here to share a similar experience with framerate I've had with CEZ2 using software mode, but... it's kinda weird (Pentium(R) Dual-Core CPU, T4300 @ 2.10 GHz, 4 GB RAM, 64-bit Windows 7)

Strangely, about some of the times when I start CEZ2, it immediately drops frames to about 8 - 12 FPS, and most other times it starts at a full 35/35. However, even still when it's those times that start with full frames, it will eventually begin to lag at some point and drop to 8 - 12 FPS... which I've noticed could happen when playing after about 30 seconds in, to 2 minutes in. Closing other memory-using programs like desktop Discord which I usually run, and lowering my resolution to the smallest possible, is to no avail. HowEVER, when I minimize SRB2 in the middle of playing on CEZ2 like this, and then when I open it back up after about a few minutes, it doesn't lag any longer... until about a minute or two... cycle repeating. So I'm pretty much getting lag spikes independent of where in the level I am and what resolution's being used. I'm at a loss of what I can do about this situation to try and up my framerate, outside of... not playing on a laptop that's a decade old. Maybe I too can wait for a 64-bit EXE? I'm unsure, though, that that will be able to fix... this.
Iím also in the same position. Especially in CEZ Act 2, when the frame rate just staggers so much that itís very difficult to progress. Iíve changed video options, closed down programs, minimised the window, and it only makes very minimal difference.
__________________
Everyone is entitled to their own truthful opinion on this planet...
Hyperknux is offline   Reply With Quote
Old 12-14-2019   #9
XleederTH
°Reremy
 
XleederTH's Avatar
Default

I am also encountering this issues regarding performance and CEZ# (I do not want to specify which of the stages are causing performance dropping issues.), so I might say it's related to both the game and our computers; as all we know, we shouldn't need a i7 to run SRB2, it means that this issue might get fixed in the next updates that I hope are coming.
__________________
Nothing for nothing, is the key :v
Visit my youtube channel!
XleederTH is offline   Reply With Quote
Old 12-14-2019   #10
Blur
Default

Getaslightlybetterlaptoplikea8gbram;4ghzlaptop.
Blur is offline   Reply With Quote
Old 12-14-2019   #11
MK.exe
The one and only!
 
MK.exe's Avatar
Default

Im in the same boat with Golden and Lit spec-wise

Its practically unplayable Online for me even with 100ms. In SP its playable (average 18fps - lowest 10fps)

I do plan on upgrading my hardware soon so this shouldn't be a problem later. Any optimisation (if any are possible) are welcome.
__________________
Average
MK.exe is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.