SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 06-09-2012   #1
StarmakerJasper
Hey, that's my pudding!
 
StarmakerJasper's Avatar
Default Can no longer join games after a port forwarding

Hello SRB2 community. I've recently forwarded my ports to host servers, and it seems I can no longer join any online games whatsoever. Whenever I go to the join game menu, no servers appear at all. I still have my master server set to ms.srb2.org:28900. I've figured out that there is possibly something wrong with my port forwarding, because if I try joining servers in a completely different SRB2 executable, I still won't get any results. I'm still able to host a server perfectly fine, but I must have done something incorrect to cause me to lose the ability to join games. What's even stranger is that if I use listserv in the console, it shows the servers perfectly fine. I've tried unforwarding the ports but it didn't seem to have an effect on the problem.



My router is a D-Link DIR-628, if that can help.
StarmakerJasper is offline   Reply With Quote
Old 06-09-2012   #2
Torgo
 
Torgo's Avatar
Default

Sounds more like a problem with a firewall (or possibly an antivirus) blocking SRB2.
__________________
If you see any people named "Torgo" outside of SRB2, it isn't me. I also go by "TorgoRandomNumbers"
Torgo is offline   Reply With Quote
Old 06-09-2012   #3
StarmakerJasper
Hey, that's my pudding!
 
StarmakerJasper's Avatar
Default

SRB2 is already allowed through Windows Firewall (The only other firewall/antivirus I have is an expired trial of Norton 360) along with port 5029... If it was a firewall problem, why would it happen when I forwarded ports? Before I forwarded, I could join fine and dandy.
StarmakerJasper is offline   Reply With Quote
Old 06-09-2012   #4
Azure
Default

Then try restoring your router to your original settings, when you could actually join netgames. Torgo is right though, there is probably some firewall or some other thing blocking you from joining games.

Also, how long do you wait for servers to appear? I now sometimes I have to wait quite a while for any servers to appear on the MS. Various times I find that most servers have quite a high ping which either means I have bad internet connection or they have bad internet connection. I'm still betting that there is something blocking you from joining netgames.

If all fails restore your router to it's factory settings. If all fails after that and you are really desperate to join a netgame then restore your computer to its factory settings, but I high recommend you don't do that(no seriously don't do it). That is, of course, if you really want to join netgames. Otherwise just bring your laptop to some computer store and see if they can help you with your problem.

Last edited by Azure; 06-09-2012 at 11:10 PM.
Azure is offline   Reply With Quote
Old 06-10-2012   #5
StarmakerJasper
Hey, that's my pudding!
 
StarmakerJasper's Avatar
Default

Setting the router settings to it's original state fixed it. I might have to toy with forwarding ports to let myself host and join without having to go back and change it later. Thanks for the help.
StarmakerJasper is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.