SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 3 Weeks Ago   #1
Takashika
 
Takashika's Avatar
Default Unable to join private game?

Hi there,

Not sure if this has already been solved but I've been trying to set up a private/offline mode game and players are unable to join.

I've forwarded my ports (5029 according to the wiki). However my ports are apparently still closed? I've checked other games (25565/Minecraft) and checked that that's open and working.

I've reset both the router and the host PC. I use the IP that's being shown from whatsmyip.org to join. I do notice that this address doesn't show up in command prompt if I enter ipconfig, if this information is helpful at all.

Am I missing a step? Do I even need to port forward? I've also allowed SRB2win.exe to go through the firewall on both PC's. Nothing I've googled seems to be working.

Thanks!
Takashika is offline   Reply With Quote
Old 3 Weeks Ago   #2
MK.exe
The one and only!
 
MK.exe's Avatar
Default

When you host check the MS to see if your server appears without question marks. If you see question marks that means you have missed something whilst trying to Port forward.

I would recommend reapeat the steps again just in case
__________________
Considered Milestones:
Hit a 180 Rail shot
1st person to have a map in releases with Slopes
MK.exe is offline   Reply With Quote
Old 3 Weeks Ago   #3
Takashika
 
Takashika's Avatar
Default

Checked the Master Server, server name appears normal/no question marks. Should I set up a static IP?

I'm trying to join another PC in the same house so we'd have the same IP but again I'm not sure if that's helpful to know.
Takashika is offline   Reply With Quote
Old 2 Weeks Ago   #4
Lach
hop
 
Lach's Avatar
Default

If you're hosting servers within the same house you likely will not even need to portforward—devices are assigned a local IP address that is unique to that device within the network, which you can see by following the steps here (you want the joining player to type in the IPv4 address of the host).

If that somehow doesn't work or you'd rather stick with your current method, you can still access your own portforwarded game with another PC by changing the joining player's client port. All instances of SRB2 run with the 5029 port by default, which means that a second player with the same IP address technically can't join since a player with the 5029 port is already connected. Open up Command Prompt on the joining device and run SRB2 with the parameter "-clientport 5030" or a similar number (works just like running SRB2 in OpenGL, if you've ever done that—see here for more details on SRB2's command line parameters), and then try joining the host device's with your public IP address.

Hope that helps!
Lach is offline   Reply With Quote
Old 2 Weeks Ago   #5
Monster Iestyn
Friendly Neighbour-Hood
Moderator
 
Monster Iestyn's Avatar
Default

SF94's SRB2 Launcher (and probably others) also allows you to set clientport without needing you to use command line, if that helps.
__________________
My page stuffed full of MIDI goodness!
The Hitchhiker's Guide to the Robo-Hoodiverse
Timeline of Sonic Robo Blast History!

That's an uppercase i, not a lowercase L, for the record. Also, it's pronounced "Yes-tin".
Monster Iestyn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.