SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Releases > Software

Reply
 
Thread Tools
SRB2 Doom Builder Details »»
SRB2 Doom Builder
Version: 0, by Oogaland Oogaland is offline
Developer Last Online: Aug 2014

Category: Version: SRB2 Rating: (2 votes - 2.60 average)
Released: 01-18-2006 Last Update: Never Installs: 0

EDIT half a year later:
The most recent version of SRB2 Doom Builder can always be obtained from http://workbench.srb2.org/srb2db/.


If you're using Windows Vista or 7, please read this thread at Doomworld.
---

I've spent some idle moments messing about with the Doom Builder source, with a view to implementing some stuff useful to SRB2 mappers. Mostly bug fixes so far -- like the crash in the texture browser -- but some SRB2-specific stuff should follow soon. I'd appreciate any suggestions you have.

Thanks.

Show Your Support

  • This addon may not be copied, reproduced or published elsewhere without the author's permission.

Comments
Old 11-05-2006   #402
Oogaland
Developer
 
Oogaland's Avatar
Default

Quote:
Originally Posted by Flame_the_hedgehog
Crap... And after I just uninstalled doombuilder too... and it got rid of the folder with the Builder.cfg too....
Here's my one: http://homepages.inf.ed.ac.uk/s0569864/Builder.cfg. Sorry about this mess-up.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 11-05-2006   #403
BlazingPhoenix
AAAAAAAAAAAAA
 
BlazingPhoenix's Avatar
Default

Is yours updated with all of the current things in there?
BlazingPhoenix is offline   Reply With Quote
Old 11-05-2006   #404
Oogaland
Developer
 
Oogaland's Avatar
Default

Quote:
Originally Posted by KingofFlames
Is yours updated with all of the current things in there?
Builder.cfg is where your preferences are stored. I think you might be thinking of Srb2ex.cfg, which is included in the installer.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 11-05-2006   #405
Flame
"It's ok, I like you too!"
 
Flame's Avatar
Default

Is there a way to reset everything to its default configuration?
__________________
   |\    _,,,--,,_ _ 
  / , `.-'`'     ._  \-;;, _
  | ,4-  ) )_    .;. \  `'-'
 '---" -(_ /._)--'(_\_)
Flame is offline   Reply With Quote
Old 11-06-2006   #406
Oogaland
Developer
 
Oogaland's Avatar
Default

Quote:
Originally Posted by Flame_the_hedgehog
Is there a way to reset everything to its default configuration?
Yes: wait for me to fix the installer so that it includes a default config file. ;) I should be able to do that tonight at some point.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 11-06-2006   #407
Oogaland
Developer
 
Oogaland's Avatar
Default

*sigh* Placeholder.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 12-03-2006   #408
JJames19119
Why did they remove Grey
 
JJames19119's Avatar
Default

Bumpity.

Anyways, I have a weird problem; it seems DB is no longer reading any resource pictures. I'll load it up, select a wad and map as always and when I go to the texture browser...nothing's there. Sure I can see the textures NAMES but there's absolutely no texture previews anymore. I'll even load up an external wad for resources and still, nothing. Any idea what's wrong?

To make things worse, it's treating F_SKY1 and colormap textures as invalid textures.
__________________
~JJ
JJames19119 is offline   Reply With Quote
Old 12-03-2006   #409
hyper sonic
 
hyper sonic's Avatar
Default changes to doom builder for srb2

i did download the srb2 doom builder but i having a hard time figuring out
how to make the level
hyper sonic is offline   Reply With Quote
Old 12-04-2006   #410
Oogaland
Developer
 
Oogaland's Avatar
Default

Quote:
Originally Posted by JJames19119
Bumpity.

Anyways, I have a weird problem; it seems DB is no longer reading any resource pictures. I'll load it up, select a wad and map as always and when I go to the texture browser...nothing's there. Sure I can see the textures NAMES but there's absolutely no texture previews anymore. I'll even load up an external wad for resources and still, nothing. Any idea what's wrong?

To make things worse, it's treating F_SKY1 and colormap textures as invalid textures.
Nothing springs to mind immediately, I'm afraid, but I'll have a think about it. In the meantime, the following would be helpful:

1. Does the same happen in a clean install in a different directory?
2. Are the previews missing only in the browser, or in the info-bar too?

As for the second problem, I've just observed that I also get that in the compiled version, but not when I run it from VB. Which is bizarre.

Thanks for reporting those. I'll give the matter some thought.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 12-04-2006   #411
JJames19119
Why did they remove Grey
 
JJames19119's Avatar
Default

Upon installing another in a different directory the problem was fixed for BOTH DBs...weird.
__________________
~JJ
JJames19119 is offline   Reply With Quote
Old 12-04-2006   #412
JJames19119
Why did they remove Grey
 
JJames19119's Avatar
Default

Ergh. I can no longer edit any MAINCFG as DB constantly complains about a 414 error: Object Required.
__________________
~JJ
JJames19119 is offline   Reply With Quote
Old 12-07-2006   #413
JJames19119
Why did they remove Grey
 
JJames19119's Avatar
Default

SRB2DB has a weird way of screwing up...

After creating a new map adding a resources WAD, I go into map options after creating a blank sector through Ctrl+Right Click and change the default textures like I always do...but I saw that there were no texture previews. So I exited out and tried to reproduce something I had did earlier...I placed a new Thing and pressed the Test button. After exiting out of SRB2, I found I could no longer select the thing I had placed...it showed it's info when I hovered over it but I couldn't select it, nor could I do anything else with it. Upon trying to zoom in ith the mouse wheel, it crashed.

That's not the end of it though...upon hitting the glitch and testing, it crashes when you right click a thing, it crashes when you go into the texture browser (through Map Options), it crashes when you try to test again, it crashes when you go into any other mode....basically ANYTHING you do after that test, will crash DB. It's to the point to where I can't use DB anymore, especially since this is doing it with EVERY map I create and open. :\ Please fix?

EIP:
Code:
Faulting application buildersrb2.exe, version 1.68.0.399, faulting module kernel32.dll, version 5.1.2600.2945, fault address 0x00012a5b.
__________________
~JJ
JJames19119 is offline   Reply With Quote
Old 12-07-2006   #414
Oogaland
Developer
 
Oogaland's Avatar
Default

I can't reproduce that at my end, unfortunately. Something very strange is afoot. Since the crash is in kernel32, that fault address isn't something I can work with directly; if, when you've got a moment, you could please send me the relevant section of drwtsn32.log (run drwtsn32 at the command line to find out where this lives), then I should have enough information to work out at least where it's crashing. Thanks.

User.dmp from the same place would be useful, too, but that gets overwritten with every crash, so it might not be around any more. Oh, and it's probably 50 megs. :P So if you can't be bothered with that, it's no problem; the log file should be sufficient.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 12-07-2006   #415
JJames19119
Why did they remove Grey
 
JJames19119's Avatar
Default

The user.dmp file is actually less than 50 KB, so that should be no problem, especially since I haven't had another app crash since then. I'll upload it to you and send it when I have time.
__________________
~JJ
JJames19119 is offline   Reply With Quote
Old 12-07-2006   #416
Ritz
cornstar
 
Ritz's Avatar
Default

So long as this topic is alive, would a 'WadAuthor mode' be feasible? That is, an option of some sort that makes DB mimick WadAuthor's interface and functionality, right down to the texture browser and the sector creation.
Ritz is offline   Reply With Quote
Old 12-07-2006   #417
Oogaland
Developer
 
Oogaland's Avatar
Default

Quote:
Originally Posted by Ritz
So long as this topic is alive, would a 'WadAuthor mode' be feasible? That is, an option of some sort that makes DB mimick WadAuthor's interface and functionality, right down to the texture browser and the sector creation.
I'm working on a complete rewrite at the moment, and one of the things I do plan is to give the user a bit more control over the interface. Most notably, in the selection method: a 'select any type of object' mode is conspicuously absent at the moment, and would be tricky to tack onto DB as it is.

As far as texture browsing goes, I can't see much scope for variation here: it's really just a list, after all. Although I do have vague memories of WadAuthor's texture browser being somewhat broken; this is convenient, since I usually manage to implement that without any special effort. :P

WA-style sector-creation, if I understand you correctly, is possible already in SRB2DB: Ctrl+Right-click. It was there in vanilla DB too, but didn't work if you were in sectors mode (!) and wanted to create a new sector inside an existing one.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 12-08-2006   #418
Ritz
cornstar
 
Ritz's Avatar
Default

Quote:
Originally Posted by Oogaland
As far as texture browsing goes, I can't see much scope for variation here: it's really just a list, after all.
I should've been more specific; In WA, if you select a texture name box (In the window that pops up after double-clicking a sector) and enter a few letters, it'll automatically bring up the texture that's the closest match to what you typed (e.g, FL gives you FLAT10, FLO gives you FLOOR0_2, etc.). I find having to use the TAB key to find a texture I haven't commited to memory, especially seeing as it's prone to cause crashes for some reason I can't recall.

Also, WA allows you to set a sector's wall textures all in one go without having to switch to linedef mode to select each individual linedef to do so, something I find especially cumbersome.

Quote:
Originally Posted by Oogaland
WA-style sector-creation, if I understand you correctly, is possible already in SRB2DB: Ctrl+Right-click.
This is very useful info.
Ritz is offline   Reply With Quote
Old 12-08-2006   #419
JJames19119
Why did they remove Grey
 
JJames19119's Avatar
Default

I seem to be having another problem; I'm having great trouble trying to scroll using the mouse when I'm drawing lines. I'll to the edge of the area while I'm drawing and it will not scroll unless I'm, like, in one single pixel where it will scroll. This only works on some edges, like the top one. My info bar still rests on the left side if you need to know.

Quote:
Originally Posted by Ritz
I should've been more specific; In WA, if you select a texture name box (In the window that pops up after double-clicking a sector) and enter a few letters, it'll automatically bring up the texture that's the closest match to what you typed (e.g, FL gives you FLAT10, FLO gives you FLOOR0_2, etc.). I find having to use the TAB key to find a texture I haven't commited to memory, especially seeing as it's prone to cause crashes for some reason I can't recall.
DB already does that. In the Configuration box, go to the Interface tab and it'll have two options: Autocomplete texture names while typing and Autocomplete texture names after typing.
__________________
~JJ
JJames19119 is offline   Reply With Quote
Old 12-08-2006   #420
Blitzzo
It's Mr. Computer!
 
Blitzzo's Avatar
Default

DB only crashes when you try to press Tab while the box contains the name of a non-existent texture.
Blitzzo is offline   Reply With Quote
Old 12-08-2006   #421
JJames19119
Why did they remove Grey
 
JJames19119's Avatar
Default

And from what I heard, that was fixed.

Anyway, bug report or enhancement, your call: The translucency vaule in colormaps for FOFs, which is often J for water, can't edited within the create FOF dialog.
__________________
~JJ
JJames19119 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.