SRB2 Message Board  

Go Back   SRB2 Message Board > Archived > SRB2 Forum Archives > Bug Reports (2.0.X)

 
 
Thread Tools Search this Thread
Old 08-22-2013   #1
Larztard
Yeah...
 
Larztard's Avatar
Default Segment Violation When Playing a Song

While implementing music for my wad, I was going to test out this new song I had just put in to see if the loop is okay. And all the sudden when I enter in the tunes number, SRB2 crashes with the error message: signal_handler(): segment violation.

I have no idea what to do. I did everything correctly and Audacity exported the music as an .ogg file without any errors. Also, I'm not in a level trying to enter in the tune number. I am on the title screen.

EDIT: I have at least 23 other music files on the wad that actually work all in .ogg files that all loop.
__________________
YouTube

Last edited by 犬夜叉; 09-10-2013 at 01:02 AM. Reason: Added a little extra information.
Larztard is offline  
Old 08-22-2013   #2
rocky
Just being himself
 
rocky's Avatar
Default

Check all of them in XWE and try and compare them and see if all of them are exactly the same as that one that caused the segment violation. I'm sure there is another solution, but that is the only one I could think of right now.
__________________
Outer space = People's Ignorance.
rocky is offline  
Old 08-22-2013   #3
Shadow Hog
Administrator
 
Shadow Hog's Avatar
Default

I sincerely doubt he inserted the same song multiple times.

I'm moving this to Bug Reports. Not sure if it's a duplicate, although it reminds me of a bug I encountered just prior to 2.0 going live, that never got fixed.

An EIP from errorlog.txt would be nice, btw. Better yet, if you could upload a WAD with the offending music file in it so I could test it against 2.1...
Shadow Hog is offline  
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.