SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing > Editing Help

Reply
 
Thread Tools Search this Thread
Old 08-25-2016   #1
-CG7244-
Sometimes I sprite "things"
 
-CG7244-'s Avatar
Default Enemy dissapears when that sees me

Hello guys, i have a problem, im making sonic corp. : The Terror Backs to 2.1 , and i have a problem making an enemy (its a doom enemy), that dissapears when sees me, hereŽs the code:

PD: The Obj. Behaviors its not finished yet.

Code:
#Mutant 1

State S_MUTANT_E1_0
SpriteName = F002
SpriteFrame = A
Duration = 1
Next = S_MUTANT_E1_0
Action = A_Look
Var1 = 0
Var2 = 0

State S_MUTANT_E1_1
SpriteName = F002
SpriteFrame = A
Duration = 1
Next = S_MUTANT_E1_2
Action = A_PlaySound
Var1 = sfx_FRE011
Var2 = 0

State S_MUTANT_E1_2
SpriteName = F002
SpriteFrame = A
Duration = 5
Next = S_MUTANT_E1_3
Action = A_Chase
Var1 = 0
Var2 = 0

State S_MUTANT_E1_3
SpriteName = F002
SpriteFrame = B
Duration = 1
Next = S_MUTANT_E1_4
Action = A_PlaySound
Var1 = sfx_FRE011
Var2 = 0

State S_MUTANT_E1_4
SpriteName = F002
SpriteFrame = B
Duration = 5
Next = S_MUTANT_E1_5
Action = A_Chase
Var1 = 0
Var2 = 0

State S_MUTANT_E1_5
SpriteName = F002
SpriteFrame = C
Duration = 1
Next = S_MUTANT_E1_6
Action = A_PlaySound
Var1 = sfx_FRE011
Var2 = 0

State S_MUTANT_E1_6
SpriteName = F002
SpriteFrame = C
Duration = 5
Next = S_MUTANT_E1_7
Action = A_Chase
Var1 = 0
Var2 = 0

State S_MUTANT_E1_7
SpriteName = F002
SpriteFrame = D
Duration = 1
Next = S_MUTANT_E1_8
Action = A_PlaySound
Var1 = sfx_FRE011
Var2 = 0

State S_MUTANT_E1_8
SpriteName = F002
SpriteFrame = D
Duration = 5
Next = S_MUTANT_E1_1
Action = A_Chase
Var1 = 0
Var2 = 0

Object MT_MUTANT_ENEMY1_1
MapThingNum = 2359
SpawnState = S_MUTANT_E1_0
SpawnHealth = 1
SeeState = S_MUTANT_E1_1
SeeSound = sfx_FRE014
ReactionTime = 32
AttackSound = sfx_none
PainState = S_NULL
PainChance = 200
PainSound = sfx_FRE013
MeleeState = S_NULL
MissileState = S_NULL
DeathState = S_XPLD1
XDeathState = S_NULL
DeathSound = sfx_FRE015
Speed = 6
Radius = 24*FRACUNIT
Height = 90*FRACUNIT
DispOffset = 0
Mass = 100
Damage = 0
ActiveSound = sfx_None
Flags = MF_ENEMY|MF_SPECIAL|MF_SHOOTABLE
RaiseState = S_NULL
And hereŽs the gif:

__________________
"The more detail that I put in the sprite, means the effort that I put into it."
-CG7244- is offline   Reply With Quote
Old 08-25-2016   #2
Monster Iestyn
Friendly Neighbour-Hood
Moderator
 
Monster Iestyn's Avatar
Default

First few questions:

1) did you make sure all your new custom state and object type names were listed under the "Freeslot" block? I'm assuming you made one of course, otherwise nothing here would work lol. (unless they were defined using Lua's freeslot() function instead)

2) why do you use Fxxx sprites and frexxx sounds still? 2.1 allows you to make your own custom sprite and sound names with the "Freeslot" block I mentioned earlier. I dunno if this is any way related to your issue, that said.

3) if you addfile your WAD to the console in-game, do you get any warning messages that may be related to your custom enemy?
__________________
My page stuffed full of MIDI goodness!
The Hitchhiker's Guide to the Robo-Hoodiverse
Timeline of Sonic Robo Blast History!

That's an uppercase i, not a lowercase L, for the record. Also, it's pronounced "Yes-tin".

Last edited by Monster Iestyn; 08-25-2016 at 05:43 PM.
Monster Iestyn is offline   Reply With Quote
Old 08-25-2016   #3
Prime 2.0
Grape flavored
Administrator
 
Prime 2.0's Avatar
Default

A note about MI's number 2 there, you cannot release a wad on the MB that uses Fxxx sprite slots, as those are not dynamically allocated. You'd have sprite conflicts with the first other wad you added to it.
__________________
Science tells us that nothing can be proven, only rendered more likely to be true. If we do not question what we already know, how can we know, much less admit, when we're wrong? Such things are vital to progress.
Prime 2.0 is offline   Reply With Quote
Old 08-26-2016   #4
-CG7244-
Sometimes I sprite "things"
 
-CG7244-'s Avatar
Default

Quote:
Originally Posted by Monster Iestyn View Post
First few questions:

1) did you make sure all your new custom state and object type names were listed under the "Freeslot" block? I'm assuming you made one of course, otherwise nothing here would work lol. (unless they were defined using Lua's freeslot() function instead)

2) why do you use Fxxx sprites and frexxx sounds still? 2.1 allows you to make your own custom sprite and sound names with the "Freeslot" block I mentioned earlier. I dunno if this is any way related to your issue, that said.

3) if you addfile your WAD to the console in-game, do you get any warning messages that may be related to your custom enemy?
1) Yes.

2) Because i take it from soniccorp.wad mod for 1.09.4, and sorry for not changing the name. (i will get perms to submit the mod from SkorneDemon)

3) No, theres no errors appearing on my console. (because im testing the map with zone builder)

EDIT: I tested it without zone builder and the error is the frame S_MUTANT_E1_8 frame, i think i dint added it to freeslots.

---------- Post added at 10:34 PM ---------- Previous post was at 10:33 PM ----------

Quote:
Originally Posted by Prime 2.0 View Post
A note about MI's number 2 there, you cannot release a wad on the MB that uses Fxxx sprite slots, as those are not dynamically allocated. You'd have sprite conflicts with the first other wad you added to it.
IŽll fix that.

---------- Post added at 10:45 PM ---------- Previous post was at 10:34 PM ----------

Oh damn i know whats the problem rlly im a dumb, this is what happened.

Freeslot
Code:
S_MUTANT_E1_0
S_MUTANT_E1_1
S_MUTANT_E1_2
S_MUTANT_E1_3
S_MUTANT_E1_4
S_MUTANT_E1_5
S_MUTANT_E1_6
S_MUTANT_E1_7
S_MUTANT_E1_9
._.

(-CG7244- received an infraction for this post: Use correct grammar and spelling.)
__________________
"The more detail that I put in the sprite, means the effort that I put into it."

Last edited by -CG7244-; 08-26-2016 at 01:54 AM.
-CG7244- is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.