SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 06-29-2011   #1
*BlueSpeed9*
is eternally offline.
 
*BlueSpeed9*'s Avatar
Default A Error Loading Srb2 I can't seem to fix.

I'm seeing this strange error on Srb2 when I started loading it up.My game somehow stopped responding after I put a long message in the console,and when I tried to start up the game again,I saw this:

*SetCooperativeLevel FAILED:An attempt was made to set the cooperative level when it was already set to exclusive.*

This is the same error I get when i open two Srb2s at once.I tried reinstalling the game from the site,but once I tried again,it still had the same error.I even used that Srb2Src.exe inside the folder,No luck.Not even the launcher worked.

If ANYONE knows the solution to this error,please tell me.I am afraid I may not be able to even open the exe again.

Thank you for reading this.
-BS9-
*BlueSpeed9* is offline   Reply With Quote
Old 06-29-2011   #2
Azure
 
Azure's Avatar
Default

I usually get that error when I open up 2 Srb2's. Then I close the second srb2 and the problem is solved, but this, I have no idea what to do for this.
Azure is offline   Reply With Quote
Old 06-30-2011   #3
FireBat257
The Burning Bat of Flames.
 
FireBat257's Avatar
Default

Quote:
Originally Posted by *BlueSpeed9* View Post
EDIT: For some reason it works now.I guess for some reason it stopped working. Now it works again. I used the launcher this time,the thing that I did this time was turn OpenGL on.That apparently worked.

Anyways,I'm going to see what mode I used that it doesn't work in. If it doesn't work unless in OpenGL,that's fine with me,because i like OpenGL mode. :P

So I guess we can call this case closed. Annoying start, happy ending!
This SAME thing happened to me a lot. But it was the error when my srb2.srb got corrupted. Happened on my old CPU I really hated it. It was really annoying to me. It doesn't happen anymore because I'm using another one for now on. Way more faster too. But, it just might be the reason that SRB2 needs a break sometimes. =/
__________________
Quote:
<~HyperWindJr> Firebat lost his admin
-FireBat* fell into a bottomless pit.
And died after that. I cfailed which made me lose it.

~BAD LUCK FOR MOI!~
FireBat257 is offline   Reply With Quote
Old 06-30-2011   #4
*BlueSpeed9*
is eternally offline.
 
*BlueSpeed9*'s Avatar
Default

Ok,So I guess i'm not the only one who encountered this..
Apparently,i AM forced to use OpenGL. Because that crash happens when i open the game in non-OpenGL (Software mode) even with the launcher.

In short,the only way I am able to open and play the game is if I open the launcher and checkmark the OpenGL checkmarker then run the game.

Now one more thing to solve.... how will I be able to open it in software mode again?
*BlueSpeed9* is offline   Reply With Quote
Old 06-30-2011   #5
FireBat257
The Burning Bat of Flames.
 
FireBat257's Avatar
Default

Quote:
Originally Posted by *BlueSpeed9* View Post
Ok,So I guess i'm not the only one who encountered this..
Apparently,i AM forced to use OpenGL. Because that crash happens when i open the game in non-OpenGL (Software mode) even with the launcher.

In short,the only way I am able to open and play the game is if I open the launcher and checkmark the OpenGL checkmarker then run the game.

Now one more thing to solve.... how will I be able to open it in software mode again?
Have you replaced any important files with new ones? Or old, (A.K.A SRB2 Demo Files)
__________________
Quote:
<~HyperWindJr> Firebat lost his admin
-FireBat* fell into a bottomless pit.
And died after that. I cfailed which made me lose it.

~BAD LUCK FOR MOI!~
FireBat257 is offline   Reply With Quote
Old 06-30-2011   #6
*BlueSpeed9*
is eternally offline.
 
*BlueSpeed9*'s Avatar
Default

I redownloaded the game from the Main Mirror on the website.When i DLed it it came with these files (Try to see if anything is missing).
A: All the .plr files. sonic.plr,tails.plr,and knux.plr
B:music.dta,zones.dta,soar.dta and drill.dta
C:the srb2.srb,and the srb2win.exe itself,plus the Srb2Src extracter (which i used and the files are in the srb2 folder).
D:fmod.dll,r_opengl.dll, and rings.wpn
and finally E: SOCEdit.exe and config.cfg.

This is all that came with it,right? If so,then either one of the files is corrupted, or something weird is going on that I don't know.
*BlueSpeed9* is offline   Reply With Quote
Old 06-30-2011   #7
FireBat257
The Burning Bat of Flames.
 
FireBat257's Avatar
Default

Was there a time you downloaded a new file, like a wad, you opened SRB2win.exe then it did that error?

---------- Post added at 12:39 AM ---------- Previous post was at 12:38 AM ----------

Another problem is that you might have to reset the computer if you didn't. This sometimes helps. A LOT.

---------- Post added at 12:40 AM ---------- Previous post was at 12:39 AM ----------

Another question. Which message did you use in the console that was very big?
__________________
Quote:
<~HyperWindJr> Firebat lost his admin
-FireBat* fell into a bottomless pit.
And died after that. I cfailed which made me lose it.

~BAD LUCK FOR MOI!~
FireBat257 is offline   Reply With Quote
Old 06-30-2011   #8
FireBat257
The Burning Bat of Flames.
 
FireBat257's Avatar
Default

That means you were SIGSERVED. So just try to reset your computer, and it might work.
|BTW. This happened to me once. Here's a little thing for SRB2 that you should know. 'Don't make your csays too big. You WILL crash.'|

---------- Post added at 12:56 AM ---------- Previous post was at 12:53 AM ----------

And you should divide your csays so that it doesn't crash. Even for a big one like that. o_0
__________________
Quote:
<~HyperWindJr> Firebat lost his admin
-FireBat* fell into a bottomless pit.
And died after that. I cfailed which made me lose it.

~BAD LUCK FOR MOI!~
FireBat257 is offline   Reply With Quote
Old 06-30-2011   #9
EternallyAries
That Aries Title
 
EternallyAries's Avatar
Default

Ah the old [SetCooperativeLevel FAILED] problem.

My old friend name mario use to play this all the time had this problem to.

I found out what made the problem.

If you added new ram into your PC at anytime you get this problem at random times.

Just restart your PC and hope it will start up.

The next thing is to set your PC resolution to 1024/768 then it will fix your problem.

That what I had to do to fix my very same problem ones.

Oh and do [Ctrl-Alt-Delete] and look in processes.

And look for SRB2win.exe and click End Process.

That will remove the one that wont show up on your PC and then restart SRB2 and it will load up again.

I hope that will fix your problems guys.
__________________
There is nothing much to read here.
EternallyAries is offline   Reply With Quote
Old 06-30-2011   #10
*BlueSpeed9*
is eternally offline.
 
*BlueSpeed9*'s Avatar
Default

Ok then,I will try that out and hope it works.

Thanks for the help Aries.

---------- Post added at 09:14 PM ---------- Previous post was at 08:59 PM ----------

Yay! It worked! *cheers in delight*
Thanks for the help, FireBat and Aries.

Last edited by *BlueSpeed9*; 07-30-2012 at 09:52 PM.
*BlueSpeed9* is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.