SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing > Editing Help

Reply
 
Thread Tools Search this Thread
Old 06-21-2007   #1
Rob
Administrator
 
Rob's Avatar
Default Common errors & issues with wads, and how to fix them.

Alright, many topics are being created about how their wads have problems, or something about their wad editor not working, or some such similar problem. Well, here's a list of Wiki articles/Forum topics for assistance in such matters.

#1) The chief problem most people seem to have is character editing, whether it's something not working, or something unknown. There is an easy way to answer all these questions.
http://srb2wiki.sepwich.com/index.ph...=Character_WAD
That is the SRB2Wiki character design article. If followed, there should be no problem with your character.
Note that a major common issue is lowercase lump letters. Read this:
http://srb2wiki.sepwich.com/index.ph...ase_lump_names
for fixes on that.

#2) XWE issues. Basically, people being unable to figure out how to get it to work/can't find a feature with it. Well, here's some stuff for you there, too.
http://srb2wiki.sepwich.com/index.php?title=XWE
Contains a download link to the latest XWE version with SRB2-specific special features.
http://srb2wiki.sepwich.com/index.ph...e=XWE/Tutorial
A tutorial explaining XWE's menus, how to install, etc. This should be used in conjunction with a tutorial about what kind of wad you're making.

#3) Textures. They can be a bit difficult, but when you know what you're doing, they're easy. But where to learn how?
http://ssntails.sepwich.com/mb/viewtopic.php?t=1001
Right there.

#4) Audio. Music, sounds, etc. Yes, people have some problems with these. Well, a link for you, too.
http://srb2wiki.sepwich.com/index.php?title=Music_Wad
This tells what kinds of music SRB2 uses. It also links to a music tutorial, and a music slots list.

Any other <emphasis>common</emphasis> errors/issues? Please bring them up!
Rob is offline   Reply With Quote
Old 06-21-2007   #2
Digiku
Developer
Default

If you have an error or issue yet you didn't find answers in the Wiki even though you wanted to look, please make use of our Requests list. That way, we all know what we need to cover on the Wiki. :)
Digiku is offline   Reply With Quote
Old 07-12-2007   #3
MEGA1234411
 
MEGA1234411's Avatar
Default

can somebody help me to create a charater.plz :( its to hard to find a website
__________________
i love skating my fav skater is rodney mullen
MEGA1234411 is offline   Reply With Quote
Old 07-12-2007   #4
Segmint
Permanently Banned
Default

...

You're kidding, right?
Segmint is offline   Reply With Quote
Old 07-12-2007   #5
Ryan
Velocity
Default

Quote:
Originally Posted by MEGA1234411
its to hard to find a website
Quote:
Originally Posted by Dark Warrior on the first post of this topic
Ryan is offline   Reply With Quote
Old 07-24-2007   #6
Kaysakado
Default

#5) If you're making a charector WAD, it may give you an error saying "Bad lump in Frame EMETA0" or something similar. To fix this, instead of making a charector WAD from scratch, copy one, and the replace all the sprites, and edit the S_SKIN and OBJCTCFG.
__________________
Join the Crashed Cafe!
Kaysakado is offline   Reply With Quote
Old 07-25-2007   #7
Rob
Administrator
 
Rob's Avatar
Default

It's spelled "Character", and that is dealt with in question #1.
Rob is offline   Reply With Quote
Old 07-25-2007   #8
Kaysakado
Default

No, it just talks about the lowercase lumps in #1.
__________________
Join the Crashed Cafe!
Kaysakado is offline   Reply With Quote
Old 07-25-2007   #9
Rob
Administrator
 
Rob's Avatar
Default

It mentions a common issue. Because it's something people can easily miss, because they don't have a wad editor with correct support. However, that error is caused by not following the Wiki's tutorial.
Rob is offline   Reply With Quote
Old 07-25-2007   #10
Segmint
Permanently Banned
Default

Dark Warrior, since you are one of the chief contributors of the Wiki, I figured you should add this to the XWE issues.

If you put in a patch (as a wall texture), and then (in the same file) have a flat with the same name, and save it as a doom flat, the patch turns into a doom flat as well (inside of the TEXTURE1 lump as well), causing a SigSev. To the point, a flat and patch apparently cannot have the same name to work correctly.

Sonict
Segmint is offline   Reply With Quote
Old 07-30-2007   #11
Dreamcaster
 
Dreamcaster's Avatar
Default

Quote:
Originally Posted by Kaysakado
#5) If you're making a character WAD, it may give you an error saying "Bad lump in Frame EMETA0" or something similar. To fix this, instead of making a character WAD from scratch, copy one, and the replace all the sprites, and edit the S_SKIN and OBJCTCFG.
That's actually how I got that message =/.
__________________
There is no pain so great as the memory of joy in present grief.
----------------------------------------------------------
My mIRC channel is #Dreamcast. Make sure to stop by!
Dreamcaster is offline   Reply With Quote
Old 08-12-2007   #12
Mike_The_Hedgehog
 
Mike_The_Hedgehog's Avatar
Default

I'm trying to make a map but it won't stop saying
Quote:
singal_handler(): segment violation
when i try to test it. (I made it with srb2 doom builder)
Mike_The_Hedgehog is offline   Reply With Quote
Old 08-12-2007   #13
on Edge
 
on Edge's Avatar
Default

Code:
singal_handler(): segment violation
It means you built your map wrong.
on Edge is offline   Reply With Quote
Old 09-18-2007   #14
witeds.exe
Default

the thing that I lurned about

Code:
singal_handler(): segment violation
is that if you go into tools on the doom builder and check errors
and fix the main ones it will work.

The errors sector not closed and missing image
are ok the game will still read it with them.
__________________
http://www.geocities.com/sonic.scape...8444910361.png

www.geocities.com/sonic.scape
sorry ther isn't much there but I need your help to fill it up.
witeds.exe is offline   Reply With Quote
Old 09-18-2007   #15
on Edge
 
on Edge's Avatar
Default

Sigsevs are old news, not to mention the error with the most number of causes.
on Edge is offline   Reply With Quote
Old 11-12-2007   #16
Kaysakado
Default

This is the 1000th view of the topic. Yayz?
__________________
Join the Crashed Cafe!
Kaysakado is offline   Reply With Quote
Old 11-12-2007   #17
on Edge
 
on Edge's Avatar
Default

1212th yayz?
on Edge is offline   Reply With Quote
Old 12-23-2007   #18
Guitarplaya
 
Guitarplaya's Avatar
Default FOFOF's

I'm trying to make a floating block on water, but the water dissapears when I go underneath the FOF. Compare the Sonic colours:


__________________
I made a post? What? Wait...
Guitarplaya is offline   Reply With Quote
Old 12-23-2007   #19
on Edge
 
on Edge's Avatar
Default

You need to segment the Water linder with a vertex, and then tag the new part with the tag of your FOFs.
on Edge is offline   Reply With Quote
Old 12-23-2007   #20
Callum
Don't bug me about ports
Developer
 
Callum's Avatar
Default Re: FOFOF's

Quote:
Originally Posted by Guitarplaya
I'm trying to make a floating block on water, but the water dissapears when I go underneath the FOF. Compare the Sonic colours:

[img]
Tag the sector with the FOF in it with the water.

For example:

The sector tag where the FOF appears is 3. Make a water linedef in the control sector of the water and tag it 3. It should work.
__________________
Wii Number: 6332-6670-3012-6583
Super Smash Bros. Brawl: 0990-2469-0325
Pokémon SoulSilver (Japanese): 4297-2659-8884

Nintendo 3DS: 4725-7969-6387
Callum is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Polyobject Errors Metal96 Editing Help 4 03-30-2010 12:56 AM
More errors! GAH! Fish hook Editing Help 5 03-23-2007 09:20 AM
I hate errors. Jurai_Madman Editing 7 11-12-2006 12:30 AM
srb2.srb errors BlazingPhoenix Help 9 06-13-2006 12:37 AM
Denouncing a common myth Draykon SRB2 Discussion 6 04-13-2006 09:48 PM


All times are GMT. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.