SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing > Editing Help

Reply
 
Thread Tools Search this Thread
Old 05-25-2008   #1
Sasa
 
Sasa's Avatar
Default Oh, good. Bug in texture1...

Yes, I downloaded it, extracted it, and added it to the wad. When I add it, the textures are empty. On the left side shows the patch name, and it shows " ". And whenever I add that wad, error comes: missing patch for texture "texture name" It worked before, but now the patch changes. And I can't do the names for them all...
I re-extracted it, deleted it from a wad, and added it again. Not working. Then, I re-downloaded and did all I have to do, and still not working. I read about TEXTURE2 but there is NO texture2. And in other mods, I saw them using all those custom patches in TEXTURE1. Nevermind that, but how do I fix this?!
__________________
My new site. There are my wads and projects for SRB2 and Skulltag.
Sasa is offline   Reply With Quote
Old 05-25-2008   #2
Ash
Permanently Banned
Default

Well, which lump editor are you using? For both, it's as easy as just right clicking the patch you want to add and clicking "add to PNAMES" and "add to TEXTURE1". You do need to make P_START and P_END markers first.

Alternatively, I could do it for you if you'd like. Just post the image you want to be inserted as a texture, and I can do it in a matter of minutes, if not seconds.
Ash is offline   Reply With Quote
Old 05-25-2008   #3
Sasa
 
Sasa's Avatar
Default

Quote:
Originally Posted by Ash
Well, which lump editor are you using? For both, it's as easy as just right clicking the patch you want to add and clicking "add to PNAMES" and "add to TEXTURE1". You do need to make P_START and P_END markers first.

Alternatively, I could do it for you if you'd like. Just post the image you want to be inserted as a texture, and I can do it in a matter of minutes, if not seconds.
Oh, I alredy did, and animated lump. P_START and P_END markers...
Hmm, I need to check this out. All the patches were removed since the last edit. Last edit is:
Quote:
LEVEL99
NEXTLEVEL = 11
Oh, sorry, I forgot about P_START and P_END. Well, there was something wrong with the wad, I fixed it, and P_START and P_END where shown as maps in SRB2 Doom BUILDER, because there were nodes, floors, and those things for the map under them. I need thaT MARKERS.
__________________
My new site. There are my wads and projects for SRB2 and Skulltag.
Sasa is offline   Reply With Quote
Old 05-26-2008   #4
Oogaland
Developer
 
Oogaland's Avatar
Default

Curiously, P_START and P_END are ignored. I think they're only used by Boom. Patches can be anywhere in the wad.
__________________
SRB2 Doom Builder | Workbench is still development...
Oogaland is offline   Reply With Quote
Old 05-27-2008   #5
Sasa
 
Sasa's Avatar
Default

Ok, used in Boom...
Well, how do I fix this?

EDIT:
I have been waiting for 2 days and no help? I wanna make some levels, but I can't without TEXTURE1, because I add new patches. And if that doesn't work, I won't be able to finish my wad because of this stupid glitch. And I was planing of creating a new gametype too. Well?

EDIT2:
Hey, I think I got it! To copy TEXTURE1 from other wads, and delete the custom once, and add mine. Maybe it will fix it too. Because texture1 is changinig to it's folder since the last edit and it stays. I'll tell you if it works or not.

EDIT3:
It didn't work. In other wads it can be shown, but in mine not. I'll see if something is wrong. If I can't fighure it out, then I'll upload the wad and see if you can find what's wrong.

EDIT4:
I can't belive it that I was so stupid! Somehow pnames lump changed all it's names to "'. No wonder it works when I re-add the patch.
__________________
My new site. There are my wads and projects for SRB2 and Skulltag.
Sasa is offline   Reply With Quote
Old 05-30-2008   #6
Hetor
 
Hetor's Avatar
Default

Quote:
Originally Posted by Sasa
LEVEL99
NEXTLEVEL = 11
What?
__________________
Please don't call me HECTOR! I'm HETOR! Or just Het, ok?
_________________________________________
I need admins for my servers and beta testers for my mod. PM me if you wanna be tester or admin!
Hetor is offline   Reply With Quote
Old 05-30-2008   #7
Sniperific
 
Sniperific's Avatar
Default

Quote:
Originally Posted by Hetor
Quote:
Originally Posted by Sasa
LEVEL99
NEXTLEVEL = 11
What?
In other words he is redirecting the last match level to his level.
Sniperific is offline   Reply With Quote
Old 05-30-2008   #8
Hetor
 
Hetor's Avatar
Default

Quote:
Originally Posted by Silent_Snipe
Quote:
Originally Posted by Hetor
Quote:
Originally Posted by Sasa
LEVEL99
NEXTLEVEL = 11
What?
In other words he is redirecting the last match level to his level.
So why it here? It must be in his level header!
__________________
Please don't call me HECTOR! I'm HETOR! Or just Het, ok?
_________________________________________
I need admins for my servers and beta testers for my mod. PM me if you wanna be tester or admin!
Hetor is offline   Reply With Quote
Old 05-30-2008   #9
Sniperific
 
Sniperific's Avatar
Default

Quote:
Originally Posted by Hetor
So why it here? It must be in his level header!
I'm not that sure, it makes no sense why he quoted it but lets get back on topic now.
Sniperific is offline   Reply With Quote
Old 05-30-2008   #10
Sasa
 
Sasa's Avatar
Default

Quote:
Originally Posted by Sasa
All the patches were removed since the last edit. Last edit is:
Quote:
LEVEL99
NEXTLEVEL = 11
Did you even read? That happen since the last edit. Read the quote.
Now, back to the topic, problem sloved.
__________________
My new site. There are my wads and projects for SRB2 and Skulltag.
Sasa is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SRB2 2.0 PNAMES and TEXTURE1 Senku Niola SRB2 Forum Archives 29 04-06-2012 06:54 PM
Texture1 / Texture2 DooMAD Editing Help 12 12-09-2009 11:32 PM
Is Wii good? Shu General Discussion 21 11-19-2006 09:55 PM
TEXTURE1 question BlazingPhoenix Editing 1 04-02-2006 08:03 PM
Good wad? misssweet135 Help 7 03-08-2006 05:08 PM


All times are GMT. The time now is 12:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.