SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 10-24-2017   #1
Robichu
 
Robichu's Avatar
Default The MIDI music's volume is too high

I know that there's a volume bar to change the volume but it don't works and i have a music so loud that i must get of my headphones.

So... Help please !
Robichu is offline   Reply With Quote
Old 10-24-2017   #2
Monster Iestyn
Friendly Neighbour-Hood
Moderator
 
Monster Iestyn's Avatar
Default

As I explained on Discord, the MIDI volume is intentionally disabled in SRB2 due to problems with MIDI volume control in Windows 7 IIRC. I think it was like MIDI volume also affects sound volume for some reason, I forget what was wrong.
__________________
My page stuffed full of MIDI goodness!
The Hitchhiker's Guide to the Robo-Hoodiverse
Timeline of Sonic Robo Blast History!

That's an uppercase i, not a lowercase L, for the record.
Monster Iestyn is offline   Reply With Quote
Old 10-24-2017   #3
Robichu
 
Robichu's Avatar
Default

Yeah but i like the midi musics there's nothing to solve this problem ?
Robichu is offline   Reply With Quote
Old 10-25-2017   #4
Lach
Latch? Lock?? Lack???
 
Lach's Avatar
Default

Quote:
Originally Posted by Robichu View Post
Yeah but i like the midi musics there's nothing to solve this problem ?
I mean, the easiest fix is to just not use MIDI music, but if you really must—you can export the MIDI files from music.dta, use a MIDI editing program like Audacity to decrease the note velocity of each note, export them from there and make the necessary replacements in music.dta, or simply add them to a new wad and addfile that at startup.
Lach is offline   Reply With Quote
Old 10-29-2017   #5
Sylvegamer3
Also known as Sylve
 
Sylvegamer3's Avatar
Default

Unless what you mean is that it plays so loud that not even volume 2 or 1 lowers it enough, I would just change every other setting to be as loud as the midis and then lower the main volume.
__________________
What? You act like you've never seen an ice cream talk before.
Sylvegamer3 is offline   Reply With Quote
Old 10-29-2017   #6
toaster
トースタちゃん
Developer
 
toaster's Avatar
Default

The issue with the midis isn't that they're too loud. It's that if you fiddle with the volume, Windows' midi player can and will end up permanently muting the executable forever (even when playing with midis off later), for some ungodly reason.

This has happened to enough people that it may be worth straight up considering going to digital music only in future versions.
__________________
Quote:
<MonsterIestyn> surely it's good ass though
Quote:
<MonsterIestyn> watch porm to keep warm
toaster is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.