SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing > Editing Help

Reply
 
Thread Tools Search this Thread
Old 12-07-2009   #1
DooMAD
 
DooMAD's Avatar
Default Texture1 / Texture2

I've already successfully added a texture to my WAD and everything works fine. But when I try adding another new texture it screws up and I get a P_InitiPicAnims: bad cycle from GFALL1 to GFALL4 error.

I notice XWE adds a new TEXTURE1 lump when I add new entries. Is there not supposed to be a TEXTURE1 lump in there? Do I have to rename it to TEXTURE2 every time I add a new resource? If so, why can't it be more simple? I don't get any crap like this with Doom.
DooMAD is offline   Reply With Quote
Old 12-07-2009   #2
SSNTails
What part of 'RETIRED' don't you understand?
 
SSNTails's Avatar
Default

XWE's a moron and adds Doom's TEXTURE1 instead of SRB2's IIRC.
__________________
Roly Poly Putt & TraceRace - Now out for Android, iPhone, iPad, and iPod Touch - http://www.spaddlewit.com
Follow me on twitter: http://www.twitter.com/SSNTails
SSNTails is offline   Reply With Quote
Old 12-07-2009   #3
DooMAD
 
DooMAD's Avatar
Default

I've never been a fan of XWE (that's putting it mildly) and much prefer WinTex, but that also seems to break it.
DooMAD is offline   Reply With Quote
Old 12-07-2009   #4
darkbob1713
I hate this username :(
 
darkbob1713's Avatar
Default

Rename the TEXTURE2 lump to TEXTURE1 every time you wanna add new textures. (I think)
__________________
Quote:
<SirCoat> ...report me for what?
<Jester the lucky 7> for hurassing a server shouting out hangout and for being in a hangout
<SirCoat> what does that have to do with you hangouting
<SirCoat> ...
<Streakster The Fox> um this is a hangout
darkbob1713 is offline   Reply With Quote
Old 12-07-2009   #5
DooMAD
 
DooMAD's Avatar
Default

Thanks for that, got it working now. It's kind of a pain in the arse, but I guess I'll get used to it after a while.
DooMAD is offline   Reply With Quote
Old 12-07-2009   #6
SSNTails
What part of 'RETIRED' don't you understand?
 
SSNTails's Avatar
Default

You could e-mail the author of XWE and ask him to add official support for SRB2.
__________________
Roly Poly Putt & TraceRace - Now out for Android, iPhone, iPad, and iPod Touch - http://www.spaddlewit.com
Follow me on twitter: http://www.twitter.com/SSNTails
SSNTails is offline   Reply With Quote
Old 12-08-2009   #7
Latius
Previously known as "ah2190"
 
Latius's Avatar
Default

That's the best idea I've heard, SSN!

Either that, or you could use somthing like Slumped...
__________________
You're giving me a little MANIA.

Originally known as Ah2190
Latius is offline   Reply With Quote
Old 12-08-2009   #8
Fred
Retired
 
Fred's Avatar
Default

You shouldn't be using TEXTURE1, anyway. TEXTURE1 replaces all the texture entries in the game, TEXTURE2 is the one where you should stick additional ones. PNAMES is the lump you need to copy over from srb2.srb, then add stuff to.
Fred is offline   Reply With Quote
Old 12-09-2009   #9
SML
I fail at programming.
 
SML's Avatar
Default

Answer me this before I go offline; Does WinTex require installation. If it does, I'm screwed for WAD editing.

EDIT: Don't answer. You'll figure out what I found out with the next two words: I'm ****ed.
(Yes, that was intentional sensoring. Since it's sensored ANYWAY, what the heck, I'll do it for the site)
__________________
Quit the shoop da whoop jokes!
STATUS:
Leeon the Fledge - ON HOLD
Searching for a good map editor, if you can find a no-installation one that's comparable to SRB2 Doom Builder, please send me teh link!

Last edited by SML; 12-09-2009 at 03:10 AM.
SML is offline   Reply With Quote
Old 12-09-2009   #10
DooMAD
 
DooMAD's Avatar
Default

Quote:
Originally Posted by Neo Chaotikal View Post
You shouldn't be using TEXTURE1, anyway. TEXTURE1 replaces all the texture entries in the game, TEXTURE2 is the one where you should stick additional ones. PNAMES is the lump you need to copy over from srb2.srb, then add stuff to.
Yes, I did that when importing the first texture and all was well. But it started going wrong when I went back to add a second new texture and didn't realise I'd have to rename the TEXTURE2 lump or XWE would overwrite TEXTURE1 without asking.

Asking to add full support on the XWE forum now.


Quote:
Originally Posted by srb23658 View Post
Answer me this before I go offline; Does WinTex require installation. If it does, I'm screwed for WAD editing.
It doesn't need installation as such, you can just unzip it to a folder. WinTex 4.3 is here. I would have a later version, but I'm not sure what features they added other than an annoying "Are you sure you want to quit?" dialog, so I kept the old one, heh. You may run into palette issues though, it's a bit rigid in that department.

Last edited by DooMAD; 12-09-2009 at 11:11 PM.
DooMAD is offline   Reply With Quote
Old 12-09-2009   #11
SML
I fail at programming.
 
SML's Avatar
Default

And ask for support for Vista. PLEASE.
__________________
Quit the shoop da whoop jokes!
STATUS:
Leeon the Fledge - ON HOLD
Searching for a good map editor, if you can find a no-installation one that's comparable to SRB2 Doom Builder, please send me teh link!
SML is offline   Reply With Quote
Old 12-09-2009   #12
DooMAD
 
DooMAD's Avatar
Default

There's a thread here where someone managed to get it working in Vista. Hope that helps.
DooMAD is offline   Reply With Quote
Old 12-09-2009   #13
SML
I fail at programming.
 
SML's Avatar
Default

YOU ROCK. XWE now is working correctly! YAY!!!
__________________
Quit the shoop da whoop jokes!
STATUS:
Leeon the Fledge - ON HOLD
Searching for a good map editor, if you can find a no-installation one that's comparable to SRB2 Doom Builder, please send me teh link!

Last edited by SML; 12-10-2009 at 12:36 AM.
SML is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SRB2 2.0 PNAMES and TEXTURE1 Senku Niola SRB2 Forum Archives 29 04-06-2012 06:54 PM
ANIMATED lump creation & TEXTURE2 errors darkbob1713 Editing Help 5 01-18-2010 01:28 AM
Oh, good. Bug in texture1... Sasa Editing Help 9 05-30-2008 06:57 PM
TEXTURE1 question BlazingPhoenix Editing 1 04-02-2006 08:03 PM


All times are GMT. The time now is 07:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.