SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > SRB2 Discussion > Bug Reports

Reply
 
Thread Tools Search this Thread
Old 06-14-2016   #1
LJ Sonik
Default Translucent sprites are displayed behind lower-unpegged textures in OpenGL mode



I guess the picture and the title say all: I spawned a MT_FLAME object in OpenGL mode, and I was able to see any mid-textures IN FRONT of the flame.
Also, don't mind the wooden thing under the flame, I tried without it and it didn't change anything.

Last edited by Monster Iestyn; 09-13-2018 at 03:45 PM.
LJ Sonik is offline   Reply With Quote
Old 06-15-2016   #2
Zwip-Zwap Zapony
Please just call me Zappy.
 
Zwip-Zwap Zapony's Avatar
Default

I don't think you mean "lower-unpegged textures", I think you mean "mid-textures". Regardless, this has probably been the case forever or something. The easiest way to observe it is with any shield in GFZ.
Zwip-Zwap Zapony is offline   Reply With Quote
Old 06-15-2016   #3
LJ Sonik
Default

Yeah, I meant mid-texture, I just forgot the name, and yes it's not a bug from 2.1.15 as it happens with 2.1.14 too.
But that's a bug and it looks really ugly.
LJ Sonik is offline   Reply With Quote
Old 05-26-2018   #4
Sryder13
'That brit'
Judge
 
Sryder13's Avatar
Default

Partially fixed in master. Opaque Midtextures are now treated as opaque and won't have this happen. There's still sorting issues with most translucent things, however.
__________________
Quote:
<MonsterIestyn> try ctrl+f masturbation and get to the point
Sryder13 is offline   Reply With Quote
Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.