SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 05-26-2011   #41
Charile
Char[i]le Brown
 
Charile's Avatar
Default

Quote:
Originally Posted by VěLT View Post
I think SRB2 works on Windows 7 64bits and not 32bits.
we talk a lot here but who will solve this problem?
I also have Windows 7 64bits and I'm having the same problem as you do. It's werid that I had Windows XP and it worked perfectly!



-My Spec-
Windows 7 64bit Home Premium
AMD Athlon(tm) II X2 220 Processor 2.80GHz
Ram 4.00GB

-My Old Spec-
Windows XP 2001 32bit
Nivida TNT/TNT2
Ram 253MB

Maybe it's because I turn-off my Internet Protocol Version 6 (IPv6)
__________________
Yes, It's 2 years and I finally post something.
Charile is offline   Reply With Quote
Old 05-27-2011   #42
VěLT
Kamehameha!
 
VěLT's Avatar
Default

Quote:
Originally Posted by Charile View Post
I also have Windows 7 64bits and I'm having the same problem as you do. It's werid that I had Windows XP and it worked perfectly!


WHY ?!!! WHY !!!
It's so hard to make this game compatible with Windows 7?! : (
all new computers for sale now come with this system.
__________________
Player since 2004 and professional complainer about the netcode

Last edited by VěLT; 05-27-2011 at 08:31 PM.
VěLT is offline   Reply With Quote
Old 05-27-2011   #43
Agent Hack
Known as Wind on SRB2
 
Agent Hack's Avatar
Default

Quote:
Originally Posted by VěLT View Post
Thank you for this. :3
__________________
My server: Wind's Server (Now has slower internet, yay)

Last edited by Agent Hack; 05-27-2011 at 08:32 PM.
Agent Hack is offline   Reply With Quote
Old 05-27-2011   #44
VěLT
Kamehameha!
 
VěLT's Avatar
Default RageMakeXD

Quote:
Originally Posted by Agent Hack View Post
Thank you for this. :3
I will make more until this problem is solved!
__________________
Player since 2004 and professional complainer about the netcode
VěLT is offline   Reply With Quote
Old 05-28-2011   #45
Cue
ALAM STOP BREAKING THE S
 
Cue's Avatar
Default

I would like to make an official statement here.

Official Statement from Association of the Protection of Cue's Sanity

Windows 7 has no known issues with SRB2 directly, neither 32-bit or 64-bit has any problems, many of the developers run SRB2 on Windows 7 and I personally use 64-bit Windows 7 Ultimate in a domain environment (think corporate) which is about as problematic as it gets with games and programs, and experience no issues with SRB2.

Any issues you have with SRB2 are due to drivers and such, if your computer is quite old, chances are your drivers aren't even Win7 compatible. Also, it may be that your PC is just sucky. And please check your network device drivers mostly, but also all your other drivers. To reiterate, Windows 7 does not have any issues with running on any version of Windows except for those issues which span all versions, it is an isolated problem down to your hardware/configuration, most likely a configuration error.

/end statement.
__________________
Quote:
<+Jev3> btw guys, now that Cue is gone, the Master Server is going to be awesome http://tvtropes.org/pmwiki/pmwiki.ph...tistsAreBetter
Quote:
<@Mystic> That's a good idea, Cue.

Last edited by Cue; 05-28-2011 at 09:41 AM.
Cue is offline   Reply With Quote
Old 05-28-2011   #46
VěLT
Kamehameha!
 
VěLT's Avatar
Default hum

Quote:
Originally Posted by Cue View Post

Any issues you have with SRB2 are due to drivers and such, if your computer is quite old, chances are your drivers aren't even Win7 compatible. Also, it may be that your PC is just sucky.
All my drivers are installed correctly. And my packard bell BG48 isn't old.





And my computer is 100% compatible with Windows7
__________________
Player since 2004 and professional complainer about the netcode

Last edited by VěLT; 05-28-2011 at 11:37 AM.
VěLT is offline   Reply With Quote
Old 05-28-2011   #47
Cue
ALAM STOP BREAKING THE S
 
Cue's Avatar
Default

I can't understand a word of that.
__________________
Quote:
<+Jev3> btw guys, now that Cue is gone, the Master Server is going to be awesome http://tvtropes.org/pmwiki/pmwiki.ph...tistsAreBetter
Quote:
<@Mystic> That's a good idea, Cue.
Cue is offline   Reply With Quote
Old 05-28-2011   #48
VěLT
Kamehameha!
 
VěLT's Avatar
Default o.O

Quote:
Originally Posted by Cue View Post
I can't understand a word of that.
Humm ... XD
Sorry my computer is french .
__________________
Player since 2004 and professional complainer about the netcode

Last edited by VěLT; 05-28-2011 at 11:38 AM.
VěLT is offline   Reply With Quote
Old 06-01-2011   #49
VěLT
Kamehameha!
 
VěLT's Avatar
Default Back >.>

Quote:
Originally Posted by Cue View Post
it is an isolated problem down to your hardware/configuration,
Hum ......

So , 90% of people in the world who uses windows 7 have problems with their hardware ...?

Dont BELIVE ME ?!
Here are the names of all the people I saw on SRB2 who have the same problem.!

Geronimo Stilton
****
ALLEN
Me
Bbop800
Agent Hack
Wolfy
DarkFireTheHedgeHo
Zer0
Charybdizs
---- To Be Continued!!

I know it's boring for you, but you did not know how much it is boring for us , FRAME LAG ALL THE TIME !



I could not resist XD
__________________
Player since 2004 and professional complainer about the netcode

Last edited by VěLT; 06-05-2011 at 07:26 PM.
VěLT is offline   Reply With Quote
Old 06-01-2011   #50
Cue
ALAM STOP BREAKING THE S
 
Cue's Avatar
Default

I'd say more like 5% maximum actually, a lot of people here run it fine, it's just most people won't bother coming to this thread because they don't need to.
__________________
Quote:
<+Jev3> btw guys, now that Cue is gone, the Master Server is going to be awesome http://tvtropes.org/pmwiki/pmwiki.ph...tistsAreBetter
Quote:
<@Mystic> That's a good idea, Cue.
Cue is offline   Reply With Quote
Old 06-01-2011   #51
Wolfy
wolfs
Developer
 
Wolfy's Avatar
Default

I possibly have the BEST hardware in this entire thread yet SRB2 still can't run nicely. Everything works, it's just that joining netgames results in tons of c-lag. My internet's fine so don't say it's that. Those people who you say run it fine Cue? They don't netgame. There's your problem. For me, I don't join anymore cause of this. I just host.
__________________
Quote:
[23:56:36] <SM-MaxX> prisma illya is a gift to this impure earth and a shining beacon for all anime
Wolfy is offline   Reply With Quote
Old 06-01-2011   #52
Agent Hack
Known as Wind on SRB2
 
Agent Hack's Avatar
Default

Quote:
Originally Posted by Wolfy View Post
Those people who you say run it fine Cue? They don't netgame. There's your problem. For me, I don't join anymore cause of this. I just host.
That reminds me. If you host, your joiners get the lag instead of you. I tried hosting on Windows 7, and everyone who joined received that horrible lag.
__________________
My server: Wind's Server (Now has slower internet, yay)
Agent Hack is offline   Reply With Quote
Old 06-01-2011   #53
Bbop800
hey
 
Bbop800's Avatar
Default

I have pretty much the same issue. C-lag kills, even through my now-wired connection.
__________________
Not sure what to put here.

Add me on Steam!
Bbop800 is offline   Reply With Quote
Old 06-01-2011   #54
Cue
ALAM STOP BREAKING THE S
 
Cue's Avatar
Default

The question works both ways, why is it plenty of people can play fine then? (Yes, including netgaming).

SRB2 naturally has c-lag because it's a shitty engine.
__________________
Quote:
<+Jev3> btw guys, now that Cue is gone, the Master Server is going to be awesome http://tvtropes.org/pmwiki/pmwiki.ph...tistsAreBetter
Quote:
<@Mystic> That's a good idea, Cue.
Cue is offline   Reply With Quote
Old 06-02-2011   #55
Blade
ANNIHILATE.
Developer
 
Blade's Avatar
Default

I use Windows 7, and I can play SRB2 and join netgames just fine.
__________________
MERRY EGGS-MAS 2012 EVERYONE!

Quote:
Originally Posted by Fawfulfan
Linedef Type 451 - Linedef Executor: Make Level 20% Cooler!
Quote:
Blade was hit by Inuyasha.
<Blade> osuwari
Inuyasha is no longer super.
Blade is offline   Reply With Quote
Old 06-02-2011   #56
VěLT
Kamehameha!
 
VěLT's Avatar
Default hahaha

Quote:
Originally Posted by Cue View Post
I'd say more like 5% maximum actually,
Now it's 15%
-------------------------------

Quote:
Originally Posted by Blade View Post
I use Windows 7, and I can play SRB2 and join netgames just fine.
Lucky >.>
---------------------------------

Quote:
Originally Posted by Cue View Post
it's a shitty engine.
They have no way to change it?

ps: I don't know what are you talking about XD
__________________
Player since 2004 and professional complainer about the netcode

Last edited by VěLT; 06-02-2011 at 04:34 PM. Reason: Because Its a HIGH VOLTAGE REPLY !
VěLT is offline   Reply With Quote
Old 06-05-2011   #57
Zer0
 
Zer0's Avatar
Default

Quote:
Originally Posted by Cue View Post
I would like to make an official statement here.

Official Statement from Association of the Protection of Cue's Sanity

Windows 7 has no known issues with SRB2 directly, neither 32-bit or 64-bit has any problems, many of the developers run SRB2 on Windows 7 and I personally use 64-bit Windows 7 Ultimate in a domain environment (think corporate) which is about as problematic as it gets with games and programs, and experience no issues with SRB2.

Any issues you have with SRB2 are due to drivers and such, if your computer is quite old, chances are your drivers aren't even Win7 compatible. Also, it may be that your PC is just sucky. And please check your network device drivers mostly, but also all your other drivers. To reiterate, Windows 7 does not have any issues with running on any version of Windows except for those issues which span all versions, it is an isolated problem down to your hardware/configuration, most likely a configuration error.

/end statement.
I know a couple people who have the framerate lag problem when I played online with them and I was the only Windows 7 user. So perhaps this is not just a Windows 7 thing.

But isn't there a possible solution to my, and my friends' problem, ( and possibly a couple of names in this topic )? Considering me and my friends experience no framerate lag whatsoeverwhen playing on SRB2 1.09.4?

I don't know if any of you posters here with the framerate lag have tried playing on the old version to see if the result is still there. But I know for sure that in switching to SRB2 2.0, me and my friends begin experiencing the framerate lag, and in switching to the old version it's all magically gone.

I've been through 2 computers (Windows XP and Windows 7) and changed internet connections.

(X)Windows XP + SRB2 1.09.4 = Framerate lag free (multiplayer of course)
( )Windows XP + SRB2 2.0.6 = Framerate lag

(X)Windows 7 + SRB2 1.09.4 = Framerate lag free

( )Windows 7 + SRB2 2.0.6 = Framerate lag


These are just my results and it really looks like to me like the new version is causing what me, my friends, and maybe some posters here are experiencing.

I'm really interested in seeing if V0lt or some others have tried the old version on multiplayer to see if they still have frame rate lag.

If the lag is caused by something that had been added into the new version, maybe we could find out what it is?
Zer0 is offline   Reply With Quote
Old 06-05-2011   #58
sonicfreak94
 
sonicfreak94's Avatar
Default

Quote:
Originally Posted by Wolfy View Post
I possibly have the BEST hardware in this entire thread yet SRB2 still can't run nicely. Everything works, it's just that joining netgames results in tons of c-lag. My internet's fine so don't say it's that. Those people who you say run it fine Cue? They don't netgame. There's your problem. For me, I don't join anymore cause of this. I just host.
I have relatively good hardware. I run Win7 x64, and can join netgames just fine. I don't do it often, but when I do, I don't have any issues (Internet connection permitting of course. 156KB/sec download 40KB/sec upload yay).
sonicfreak94 is offline   Reply With Quote
Old 06-05-2011   #59
DarkFireTheHedgeHo
The Uncontrollable Flame
 
DarkFireTheHedgeHo's Avatar
Default

I Have a Windows 7 Ultimate, with a Verizon cable internet connection.
I get lag on netgames,but it wasn't always HORRIBLE enough to make me stop playing...
Boredom already did that once.
__________________
~Im Slashin' Right Through The Fire!~

DarkFireTheHedgeHo is offline   Reply With Quote
Old 06-05-2011   #60
VěLT
Kamehameha!
 
VěLT's Avatar
Default

2 More! Keep posting guys! CUE will not say that we are less than 5% !


Quote:
Originally Posted by Zer0 View Post

I'm really interested in seeing if V0lt or some others have tried the old version on multiplayer to see if they still have frame rate lag.
I don't , I've never saw a 1.09.4 serv in 2011 , But if you have not had lag Why will I have? Now , we can play without frame lag :D
psx2 = Love that infinity ring.


And the Picture of the post !!!


LET'S PARTY !!!!
__________________
Player since 2004 and professional complainer about the netcode

Last edited by VěLT; 06-05-2011 at 07:50 PM.
VěLT is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.