SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 06-17-2011   #1
Jeck Jims
Oh, THAT guy...
 
Jeck Jims's Avatar
Default SRB2 Only inputs Numbers

Alright, making a help thread for this was the LAST thing I wanted to do, but I have tried everything I can think of.
I came home today, with the determination to forward my port because I read up on how to do it. After a long process due to not knowing my router password, I got it!, I forwarded my port.
Then I went to play SRB2 and now whenever I type any letter, a number takes it's place. I know what you're thinking, "NUM-LOCK you idiot!" But sadly no. Its not type "t" and you get "7", its type a letter and get "9", type another get "0", then "1', "2", "3", etc. Even typing the same letter gets the same result. This happens with all the letters, numbers not on the keypad on the right, {.}.:.'.,... and /. Holding shift will give me "!,@,#,$,%,^,&,*,(, or )." Although, the Enter key, directional keys, tab, etc., work as they always do.
I told you about my port forwarding because it happened once when I was in my command prompt, at first I though nothing of it, just closed it, re-opend it, and it worked fine.
This problem occurs with every type of srb2 I have. Including; SRB2CB, OpenGL by Cinefast, the ones on my thumb drive, and v1.09.4. It does not occur on any other typing program.
I have tried the following
a. Logging off my PC
b. Restarting
c. Powering off
d. Re downloading SRB2
e. Un-forwarding my SRB2 port
f. Google
If you know my problem and think you can help, I would appreciated it very much.
__________________
Easy MD2 set-up

Last edited by Jeck Jims; 06-17-2011 at 05:53 AM.
Jeck Jims is offline   Reply With Quote
Old 06-17-2011   #2
Torgo
Developer
 
Torgo's Avatar
Default

Does this occur in other games or programs? What is your operating system? The only thing I can think of right now is updating your keyboard drivers or deleting the config.cfg from the srb2 folder (which means you have to reconfigure your controls again). You can also scan for viruses, but that probably isn't the problem.
__________________
If you see any people named "Torgo" outside of SRB2, it isn't me. I also go by "TorgoRandomNumbers"
Torgo is offline   Reply With Quote
Old 06-17-2011   #3
Jeck Jims
Oh, THAT guy...
 
Jeck Jims's Avatar
Default

My operating system is Windows XP media pro, I far as I know this doesn't occur on any other program, although SRB2 is my only game installed. I am scanning for viruses currently and I am unsure how to update the drivers, I know where and how to do so, but it ask for a disk or file location, of which I do not have. This problem also happens when using my iPod touch App Jumi, which let's you use your iPod as a keyboard.

---------- Post added at 05:16 PM ---------- Previous post was at 03:49 PM ----------

Ok, after some less specific query in Google, I was able to figure out the problem. It was a program force-installed by Microsoft by the latest update. The program was called "Constant Guard" and replaced letters with numbers in applications thinking they were key loggers. Even though I never set-up or configured the program, it still ran in the background. Simply uninstalling it solved the problem. Thanks for the suggestions anyway Torgo. For anyone who has this problem and finds this form trying to solve it, the program "GID Desktop Application" also causes this problem.
You can lock this topic.
__________________
Easy MD2 set-up
Jeck Jims is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.