SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing

Reply
 
Thread Tools Search this Thread
Old 11-12-2014   #1
Furyhunter
Exclamation Requirements for custom sound and music in SRB2 2.1.12 and forward

SRB2 has only officially supported 44.1kHz audio for both music and sound for a long time. However, the sound backend used in the win32 interface (old srb2win, srb2dd) would resample sound automatically if it did not fit the requirements, as that was a feature of fmod.

Unfortunately, the SDL2 interface is not capable of resampling audio as before. In order for your sounds to play back correctly, it must be sampled at 44.1kHz. If you have staticy or otherwise broken sounds, it is not sampled at 44100 or 22050. Please use your audio encoding tools to encode your sound effects at that sampling rate.

For custom music, which does not have the same restraints as sound effects, looping with LOOPPOINT will not work unless the song is at 44.1kHz. Looping with LOOPMS works as before. This is a caveat of SDL_mixer that does not allow us to detect the sampling frequency of the music being used.

In srb2dd, sound and music work the same as they did before, however we are starting to phase out support for the old win32 code as it is not holding up well in recent versions of Windows.

Last edited by Furyhunter; 11-12-2014 at 04:26 AM.
Furyhunter is offline   Reply With Quote
Old 11-12-2014   #2
Rob
Administrator
 
Rob's Avatar
Default

I am going to go ahead and note that any submissions for mods going forward are required to adhere to these constraints. We will not accept any mod that requires the direct draw version of the game.
Rob is offline   Reply With Quote
Old 11-13-2014   #3
glaber
Emblem Radar Ready
 
glaber's Avatar
Default

Is there a tutorial for how to resample music to the correct bitrate?
glaber is offline   Reply With Quote
Old 11-13-2014   #4
Zipper
Soulja boy I tell 'em
Judge
 
Zipper's Avatar
Default



feel free to make me look like a jackass if this is incorrect
__________________
Quote:
<MonsterIestyn> surely it's good ass though
Zipper is offline   Reply With Quote
Old 11-13-2014   #5
glaber
Emblem Radar Ready
 
glaber's Avatar
Default

when I imported the file (says it has a bitrate of 161 on the file's info) Audacity though it was at the correct rate already apparently. But after exporting it and then bringing it back into my project, it was still too fast. As if nothing was changed (most likely nothing was.)
glaber is offline   Reply With Quote
Old 11-13-2014   #6
Zipper
Soulja boy I tell 'em
Judge
 
Zipper's Avatar
Default

You could try changing the bitrate manually from the track window itself (there's a tiny arrow near its name), and then re-adjusting its speed by multiplying it with (old rate)/44100 with the Change Speed option.
__________________
Quote:
<MonsterIestyn> surely it's good ass though
Zipper is offline   Reply With Quote
Old 11-13-2014   #7
Fred
Retired
 
Fred's Avatar
Default

Use Track > Resample... to resample your track to a different rate. Note that you may or may not want to use dithering; you can check this under Preferences > Quality > High-quality Conversion.
Fred is offline   Reply With Quote
Old 12-30-2015   #8
xXNeonGamingXx
Currently off making WADS
Permanently Banned
Default

Convert the file to OGG.
xXNeonGamingXx is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.