SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > SRB2 Discussion > Bug Reports

Reply
 
Thread Tools Search this Thread
Old 03-18-2014   #1
ForgiveThisNewb
Default [OpenGL] CEZ1 has Invisible Floor, flickering wall


This problem only appears on OpenGL; software is perfect. The floor in this particular sector is consistently invisible, and the wall flickers depending on camera angle.

Using 2.1.2, built from source on GitHub for Linux 64-bit.

System Specs if they matter:
Code:
$ inxi -F
System:    Host: ********** Kernel: 3.8.0-35-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Four
Machine:   Mobo: ASUSTeK model: M5A78L-M LX PLUS version: Rev X.0x Bios: American Megatrends version: 1302 date: 11/14/2012
CPU:       Quad core AMD Phenom II X4 965 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card: NVIDIA G92 [GeForce 9800 GT] X.Org: 1.13.3 driver: nvidia Resolution: 1920x1080@60.0hz 
           GLX Renderer: GeForce 9800 GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 331.38
Audio:     Card-1: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Card-2: Fry's driver: USB Audio
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-35-generic
Network:   Card-1: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver: r8169 
           IF: eth1 state: down mac: *********
           Card-2: Ralink RT2800 802.11n PCI driver: rt2800pci 
           IF: wlan0 state: up mac: **********
Drives:    HDD Total Size: 250.1GB (66.7% used) 1: id: /dev/sda model: ST3250410AS size: 250.1GB 
Partition: ID: / size: 214G used: 156G (77%) fs: ext4 ID: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 41.0C mobo: 35.0C gpu: 39C 
           Fan Speeds (in rpm): cpu: 778 sys-1: 1520 
Info:      Processes: 186 Uptime: 1:20 Memory: 1393.8/7984.8MB Client: Shell inxi: 1.8.4

Last edited by Monster Iestyn; 09-13-2018 at 03:49 PM.
ForgiveThisNewb is offline   Reply With Quote
Old 03-18-2014   #2
AlamGBC
WOO! GO ME! YAHOO!
Administrator
 
AlamGBC's Avatar
Default

Quote:
Originally Posted by ForgiveThisNewb View Post

This problem only appears on OpenGL; software is perfect. The floor in this particular sector is consistently invisible, and the wall flickers depending on camera angle.

Using 2.1.2, built from source on GitHub for Linux 64-bit.

System Specs if they matter:
Code:
$ inxi -F
System:    Host: ********** Kernel: 3.8.0-35-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Four
Machine:   Mobo: ASUSTeK model: M5A78L-M LX PLUS version: Rev X.0x Bios: American Megatrends version: 1302 date: 11/14/2012
CPU:       Quad core AMD Phenom II X4 965 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card: NVIDIA G92 [GeForce 9800 GT] X.Org: 1.13.3 driver: nvidia Resolution: 1920x1080@60.0hz 
           GLX Renderer: GeForce 9800 GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 331.38
Audio:     Card-1: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Card-2: Fry's driver: USB Audio
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-35-generic
Network:   Card-1: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver: r8169 
           IF: eth1 state: down mac: *********
           Card-2: Ralink RT2800 802.11n PCI driver: rt2800pci 
           IF: wlan0 state: up mac: **********
Drives:    HDD Total Size: 250.1GB (66.7% used) 1: id: /dev/sda model: ST3250410AS size: 250.1GB 
Partition: ID: / size: 214G used: 156G (77%) fs: ext4 ID: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 41.0C mobo: 35.0C gpu: 39C 
           Fan Speeds (in rpm): cpu: 778 sys-1: 1520 
Info:      Processes: 186 Uptime: 1:20 Memory: 1393.8/7984.8MB Client: Shell inxi: 1.8.4
I wished you used the in-game screenshot, it would include the pos in the map...
__________________
"remember, hacking SRB2 is a good thing, cracking it's save games is not" - Alam and Logan Arias

3DS FC: 0473-7778-0919
AlamGBC is offline   Reply With Quote
Old 03-18-2014   #3
ForgiveThisNewb
Default

Quote:
Originally Posted by AlamGBC View Post
I wished you used the in-game screenshot, it would include the pos in the map...
Sorry. This is the first turn after the spawn. Coordinates while standing on the invisible floor are X: 1415, Y: -22001, Z: 1136

EDIT:
Can not reproduce using srb2win in Wine.
Can not reproduce using official Linux 32-bit client.
Can reproduce in official Linux 64-bit client.

This problem seems to be specific to 64-bit Linux.

Last edited by ForgiveThisNewb; 03-18-2014 at 05:56 AM.
ForgiveThisNewb is offline   Reply With Quote
Old 09-28-2016   #4
Monster Iestyn
Friendly Neighbour-Hood
Moderator
 
Monster Iestyn's Avatar
Default

I know it's been two years now, but does this bug still occur for Linux 64-bit? I do wonder if any changes to the OpenGL renderer's code since 2.1.2 may have fixed this or not (especially since we had to add support for slopes to it), but it's hard to tell since I haven't got Linux of any sort to test with. =P
__________________
My page stuffed full of MIDI goodness!
The Hitchhiker's Guide to the Robo-Hoodiverse
Timeline of Sonic Robo Blast History!

That's an uppercase i, not a lowercase L, for the record. Also, it's pronounced "Yes-tin".
Monster Iestyn is offline   Reply With Quote
Old 09-29-2016   #5
-CG7244-
Sometimes I sprite "things"
 
-CG7244-'s Avatar
Default 2.1.2 version?

Quote:
Originally Posted by ForgiveThisNewb View Post

This problem only appears on OpenGL; software is perfect. The floor in this particular sector is consistently invisible, and the wall flickers depending on camera angle.

Using 2.1.2, built from source on GitHub for Linux 64-bit.

System Specs if they matter:
Code:
$ inxi -F
System:    Host: ********** Kernel: 3.8.0-35-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Four
Machine:   Mobo: ASUSTeK model: M5A78L-M LX PLUS version: Rev X.0x Bios: American Megatrends version: 1302 date: 11/14/2012
CPU:       Quad core AMD Phenom II X4 965 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card: NVIDIA G92 [GeForce 9800 GT] X.Org: 1.13.3 driver: nvidia Resolution: 1920x1080@60.0hz 
           GLX Renderer: GeForce 9800 GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 331.38
Audio:     Card-1: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Card-2: Fry's driver: USB Audio
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-35-generic
Network:   Card-1: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver: r8169 
           IF: eth1 state: down mac: *********
           Card-2: Ralink RT2800 802.11n PCI driver: rt2800pci 
           IF: wlan0 state: up mac: **********
Drives:    HDD Total Size: 250.1GB (66.7% used) 1: id: /dev/sda model: ST3250410AS size: 250.1GB 
Partition: ID: / size: 214G used: 156G (77%) fs: ext4 ID: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 41.0C mobo: 35.0C gpu: 39C 
           Fan Speeds (in rpm): cpu: 778 sys-1: 1520 
Info:      Processes: 186 Uptime: 1:20 Memory: 1393.8/7984.8MB Client: Shell inxi: 1.8.4
Where did you get srb2 2.1.2?

Edit: Noticed that are writed on the thread.
__________________
"The more detail that I put in the sprite, means the effort that I put into it."
-CG7244- is offline   Reply With Quote
Old 05-27-2018   #6
Sryder13
'That brit'
Judge
 
Sryder13's Avatar
Default

I know it's been almost another 2 years now, but just letting you know this issue is still a thing and I haven't been able to figure it out. Also effects the cave after the spring chain in GFZ2.
__________________
Quote:
<MonsterIestyn> try ctrl+f masturbation and get to the point
Sryder13 is offline   Reply With Quote
Old 12-15-2018   #7
Monster Iestyn
Friendly Neighbour-Hood
Moderator
 
Monster Iestyn's Avatar
Default

A fix has been made for the 64-bit OpenGL holes here: https://git.magicalgirl.moe/STJr/SRB...e_requests/382
__________________
My page stuffed full of MIDI goodness!
The Hitchhiker's Guide to the Robo-Hoodiverse
Timeline of Sonic Robo Blast History!

That's an uppercase i, not a lowercase L, for the record. Also, it's pronounced "Yes-tin".
Monster Iestyn is offline   Reply With Quote
Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.