SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Help

Reply
 
Thread Tools Search this Thread
Old 02-09-2017   #1
jameds
James
Default Compiling on Fedora 25

Sorry if this is another dumb problem like before.

Code:
$ CC="gcc -m32" make -C src/ LINUX=1 

make: Entering directory '/home/james/build/SRB2-SRB2_release_2.1.17/src'
Makefile:582: recipe for target 'pre-build' failed
make: [pre-build] Error 1 (ignored)
Linking lsdl2srb2...
/usr/bin/ld: skipping incompatible /usr/local/lib/libSDL2.so when searching for -lSDL2
/usr/bin/ld: skipping incompatible /usr/local/lib/libSDL2.a when searching for -lSDL2
/usr/bin/ld: skipping incompatible /usr/lib64/libSDL2.so when searching for -lSDL2
/usr/bin/ld: skipping incompatible /usr/lib64/libSDL2_mixer.so when searching for -lSDL2_mixer
/usr/bin/ld: skipping incompatible /usr/lib64/libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /usr/lib64/librt.so when searching for -lrt
/usr/bin/ld: skipping incompatible /usr/lib64/libpng16.so when searching for -lpng16
/usr/bin/ld: skipping incompatible /usr/lib64/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /usr/lib64/libgme.so when searching for -lgme
/usr/bin/ld: cannot find -lgme
/usr/bin/ld: skipping incompatible /usr/lib64/libc.so when searching for -lc
collect2: error: ld returned 1 exit status
Makefile:607: recipe for target '../bin/Linux/Release/lsdl2srb2' failed
make: *** [../bin/Linux/Release/lsdl2srb2] Error 1
make: Leaving directory '/home/james/build/SRB2-SRB2_release_2.1.17/src'
jameds is offline   Reply With Quote
Old 02-10-2017   #2
AlamGBC
WOO! GO ME! YAHOO!
Administrator
 
AlamGBC's Avatar
Default

You are compiling SRB2 as a 32-bit program BUT

you did not tell the build system where the 32-bit libGME

So, go get the 32-bit devel packages or compile them yourself
__________________
"remember, hacking SRB2 is a good thing, cracking it's save games is not" - Alam and Logan Arias

3DS FC: 0473-7778-0919
AlamGBC is offline   Reply With Quote
Old 02-10-2017   #3
jameds
James
Default

The problem was with my PKG_CONFIG_PATH.

Thanks for hinting me in the right direction.
jameds is offline   Reply With Quote
Old 07-19-2017   #4
schotty
Default

Quote:
Originally Posted by jameds View Post
The problem was with my PKG_CONFIG_PATH.

Thanks for hinting me in the right direction.
I am also having an issue, would you care to share how you fixed it?

Thanks much!
schotty is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.