SRB2 Message Board  

Go Back   SRB2 Message Board > Sonic Robo Blast 2 > Editing > Editing Help

Reply
 
Thread Tools Search this Thread
Old 05-10-2014   #1
"Lat'"
Stop it
 
"Lat'"'s Avatar
Default Ugly unfixable slime trail?!

So, all is in the title and in the screenshot:



How am I supposed to get rid of that... thing? I tried to move many vertices and spam make sector, but that doesn't change anything :/
__________________
Quote:
Originally Posted by Bronydude2k5 View Post
If you make me a Sash Lilac wad, I'll make you a sonic sprite hack of any choice.
"Lat'" is offline   Reply With Quote
Old 05-10-2014   #2
Tyrannic
 
Tyrannic's Avatar
Default

I've gotten many of these recently too....
It would be useful to know which nodebuilder you're using and on which settings (quick build or advanced).
Sometimes, the slimetrails just disappear when letting the level build nodes again.
Alternatively, try redrawing/joining/merging some sectors in the area.
If all that doesn't work, you'll probably need to limit the player's view by having a large column or something similar at the place the slime trail occurs. That worked for me sometimes.

Hope that helps (and is correct, I don't want to give bullshit advice).
Tyrannic is offline   Reply With Quote
Old 05-10-2014   #3
"Lat'"
Stop it
 
"Lat'"'s Avatar
Default

I use ZenNode fastbuild, to save faster, should I change it to normal or something...?
__________________
Quote:
Originally Posted by Bronydude2k5 View Post
If you make me a Sash Lilac wad, I'll make you a sonic sprite hack of any choice.
"Lat'" is offline   Reply With Quote
Old 05-10-2014   #4
Tyrannic
 
Tyrannic's Avatar
Default

That could help, I think. I use Normal for saving and fastbuild for map testing.
Tyrannic is offline   Reply With Quote
Old 05-10-2014   #5
glaber
Emblem Radar Ready
 
glaber's Avatar
Default

Don't use the fast builders, they cause more problems than the solve.
__________________
SRB2TP (The Past) 1.08 Now Avaiable
Why wouldn't you glide and climb as Super Knuckles?
glaber is offline   Reply With Quote
Old 05-10-2014   #6
Mystic
チェン!
Administrator
 
Mystic's Avatar
Default

No, use the fast builders for your sanity while working, because otherwise it'll start taking absolutely forever to test your stage, and personally I think regular testing of your work in progress is a key to making good stages. A full nodesbuild of CEZ2, ERZ2, or AGZ takes about 5 minutes on my box, for example. However, you should definitely do a full nodesbuild when you encounter a renderer error like this, as a proper nodesbuild may fix it. You should also do a full nodesbuild before releasing, as a proper reject can improve framerate.
Mystic is offline   Reply With Quote
Old 05-11-2014   #7
speed2411
*Speed-Roid*
 
speed2411's Avatar
Default

How big is your thok barrier...? A similar thing has happened to me once and it was fixed by simply getting rid of unused thok barrier space.
__________________
Listen. I'm *Speed-Roid* Not you. Me! So I really don't want you using my name.

Spoiler:
Clearly, I controlled your mind to make you open this spoiler box. You cant resist my power!! I shall control your mind. ^_^
speed2411 is offline   Reply With Quote
Old 05-11-2014   #8
CobaltBW
I do things sometimes
 
CobaltBW's Avatar
Default

Quote:
Originally Posted by Mystic View Post
No, use the fast builders for your sanity while working, because otherwise it'll start taking absolutely forever to test your stage, and personally I think regular testing of your work in progress is a key to making good stages. A full nodesbuild of CEZ2, ERZ2, or AGZ takes about 5 minutes on my box, for example. However, you should definitely do a full nodesbuild when you encounter a renderer error like this, as a proper nodesbuild may fix it. You should also do a full nodesbuild before releasing, as a proper reject can improve framerate.
I always get pretty nasty slimetrails on AGZ, speaking of. Was that constructed with a full nodesbuild or no?
__________________
~CobaltBW

Check out my soundcloud profile for music stuff
CobaltBW is offline   Reply With Quote
Old 05-11-2014   #9
Mystic
チェン!
Administrator
 
Mystic's Avatar
Default

It was a classic example of me assuming the renderer errors were caused by the quick nodesbuild when they in fact weren't, but I figured none of those were blocking a view that would kill you so I let it release that way anyways.
Mystic is offline   Reply With Quote
Old 05-11-2014   #10
"Lat'"
Stop it
 
"Lat'"'s Avatar
Default

So, I took for you a screenshot of the map,
The circle represent where the error happens, and the cross represent where you do have to stand to see it.



If the thok barrer is too big, spliting it into multiple sector could fix the problem?
__________________
Quote:
Originally Posted by Bronydude2k5 View Post
If you make me a Sash Lilac wad, I'll make you a sonic sprite hack of any choice.
"Lat'" is offline   Reply With Quote
Old 05-11-2014   #11
Kuba11
^Avatar made by VOLT!^
 
Kuba11's Avatar
Default

The way I deal with slime trails is moving the WHOLE MAP a little bit in randnom direction, and then move ALL things in their proper spots (make sure that you disable stitch vertices when moving the map, just in case).
__________________
Kuba11's pack for 2.1: http://mb.srb2.org/showthread.php?t=38589
Kuba11 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.