SRB2 Message Board

SRB2 Message Board (https://mb.srb2.org/index.php)
-   SRB2 Forum Archives (https://mb.srb2.org/forumdisplay.php?f=57)
-   -   SRB2 2.0.5 Bug Reports (Old Topic) (https://mb.srb2.org/showthread.php?t=33524)

K.S. 05-21-2010 03:03 AM

SRB2 2.0.5 Bug Reports (Old Topic)
 
Yeah, yeah, you know what to do here.

If you are getting an error message, write down exactly what it says. Otherwise our crack team of coders will not be able to find it and where it's coming from. Also, if the game SIGSEGVs, not only tell us what you were doing, but check the bottom listing of errorlog.txt and post the 8-digit value after "EIP"; this is invaluable for fixing such errors.

Here is an example of where you will see the EIP which Sonict has bolded for you (thanks, Sonict!):

Quote:

Originally Posted by Example Crash
Registers:
EAX=00001fb4 CS=001b EIP=1002d121 EFLGS=00210206
EBX=00000000 SS=0023 ESP=0012fe50 EBP=005ca1b0
ECX=10047aa0 DS=0023 ESI=05fb5418 FS=003b
EDX=00001000 ES=0023 EDI=004453c0 GS=0000

If an entire bug report has been bolded, it means that the bug has been fixed. Italicized text after a bug report should be a note left by a developer. Thus, you should not be using bold nor italics in your bug reports.

If your bug report was deleted, then either it is a duplicated bug report or one that we cannot reproduce.

Like in the suggestions topic, Jazz, Spazzo and I will be going through and culling invalid bug reports and spam posts. If you have any questions, feel free to PM one of us. Also, keep in mind that with each release EIPs from the previous release are no longer valid. Be sure that the EIPs you find from errorlog.txt are from the most recent version of SRB2.

Lastly, if you're posting screenshots of an error in a SP stage, it would greatly help if you enabled DEVMODE before taking the screenshot, so that we have the exact coordinates of your location.

Moderator Notice:
Spazzo note: We are not accepting any bug reports that occurred while using OpenGL. This includes sigsegv's.

Autosaver 05-21-2010 08:30 PM

When I died as Knuckle's in ERZ3, his sprite started to leave a trail.

I didn't manage to fix it outright, but I fiddled with the light blocks to mask it. -Jazz

It's not really a trail, it's just the way both high-resolution and scaled sprites are drawn leads to oddities like this sometimes. Not much we can do about it, IIRC. ~Inuyasha

akirahedgehog 05-21-2010 08:56 PM

http://akira.sepwich.com/srb20283.png
The ability to take screenshots is broken, with or without HOMREMOVAL

Couldn't recreate on my end, with or without HOMREMOVAL. Is anyone else having this problem? -Jazz

It's - as I've said before - the game taking a screenshot in the middle of a drawing frame, due to lag. Considering the EXE itself is having major framerate and other issues, this shouldn't be too surprising. ~Inuyasha

MascaraSnake 05-21-2010 09:12 PM

http://i45.tinypic.com/4iybms.png

The elevator/teleporter at the end of ERZ2 did this to me. homremoval was obviously off, and resetting the camera didn't work, even though I was still able to move? It glitched up when moving during the teleport, so that was probably the issue.

Anything specific done to create this? -Jazz

Prime 2.0 05-21-2010 09:33 PM

Some FOFs(such as water in DSZ) will flash or turn black depending on the angle you look at them.

One of the zoom tubes in DSZ2 in the current maze failed to trigger initially, IIRC it was the one at left-left-right. I have yet to test it extensively, but I think I fixed it. -Jazz

Possibly due to physics changes, Brak eggman has become almost impossible to hit while he is still in the air using his grab missiles.

Using the strafe keys in combination with up or down while climing a wall will cause knuckles to jitter oddly, moving generally in a vertical direction.

Using tunes while supersonic, entering a space countdown area, and then exiting the countdown area will cause the music to revert to the supersonic tune. May also apply to other powerup music.

You can do this to avoid all of Brak's attacks:
http://img203.imageshack.us/img203/156/braknux.png

Continuing on, flame jets(and presumably all projectiles, player created or not) still hurt match supersonic.
Still intentional... ~Inuyasha

Eggman's flashing is suddenly really weird.
http://img265.imageshack.us/img265/3042/eggwhut.png
I'm pretty sure this is intentional, since it's sort of like how Brak has always been. ~Inuyasha

Fred 05-21-2010 09:36 PM

Changeteam is broken. It no longer kills you -- it only deals normal damage, and immediately switches the offending player's team, but not his or her color, ie. havoc.

The change team menu option is also mysteriously missing...

Can't recreate. -Jazz

Try it in Two Player Mode, that's where it happened to me. Might work differently in a netgame?

Changeteam in Two Player Mode has always been broken (since the beginning of 2.0, at least), and as it's such a low priority nobody's bothered to fix it. ~Inuyasha

time gear 05-21-2010 09:55 PM

Not sure if it's just a problem with my copy, but for some reason shields are no longer transparent. Fire is the same way, but thats less of a problem.

Edit: http://img257.imageshack.us/img257/2982/srb20004.png

Edit 2:
When exiting the game, it still says that the most recent copyright was 2009. (I know thats not really a bug, but it kinda bugs me.)

Cyan Ryan 05-21-2010 10:14 PM

Spindashing in some shallow water causes the character to disappear randomly. I'll reproduce this and take a screenshot.

The bug with the extra column in match netgames is still there.

Fred 05-21-2010 10:34 PM

http://nande.planetaclix.pt/205bug1.png

This area in Deep Sea Zone 1 is still very much broken.

For the record, I had to take three screenshots before a proper one came out. What gives?

Prime 2.0 05-21-2010 10:53 PM

OpenGL is enabled in 2.0.5. The OpenGL settings menu however is not.

A new build will naturally solve that. -Jazz

Fred 05-22-2010 12:09 AM

http://nande.planetaclix.pt/205bug2.png

The set of springs that are supposed to bounce you out of the lava when you take this chute are seemingly missing:


http://nande.planetaclix.pt/205bug3.png

Until you examine the surface of the lava. Hey there!

http://nande.planetaclix.pt/205bug33.png

Prime 2.0 05-22-2010 12:24 AM

The old laser is used pretty much everywhere in ERZ1.
What old laser? The laser block we have isn't deprecated by any means. ~Inuyasha

Also, hold right here and laugh a little.
http://img97.imageshack.us/img97/4143/holdrightand.png

That might be intentional, considering you can do that on each of the tubes. -Jazz
It's intentional enough to not warrant fixing. -Spazzo

Fred 05-22-2010 02:11 AM

When you search for games on the master server, by default the list shows up ordered by ping, from lowest to highest.

If you switch to another sorting method and then choose ping again, it orders from highest to lowest instead.

---------- Post added at 03:11 AM ---------- Previous post was at 02:50 AM ----------

http://nande.planetaclix.pt/205bug4.png

Misplaced rings in Castle Eggman Zone 1.

http://nande.planetaclix.pt/205bug5.png

(Egg Rock Zone 1) These rings aren't deafed, and because they're gravflipped they seem to burrow into the ceiling (the perspective is off).

Spherallic 05-22-2010 09:31 AM

While playing RVZ1, I encountered this weird lava block:
http://i50.tinypic.com/2yjr3tv.jpg
http://i45.tinypic.com/5d6lid.jpg
It's higher than the rest of the lava in this room, you should lower it.

This has been around for a long time. The room kind of looks funny with it lowered. -Jazz

I also found a lava block with the old lava flats:
I search/replaced old lava flats and textures, should no longer be a problem.
http://i50.tinypic.com/24w96h4.jpg
http://i46.tinypic.com/2ia4v0w.jpg

Ezer.Arch 05-22-2010 03:24 PM

Nimbus Ruins Zone: monitor with wrong Z-offset.

http://img638.imageshack.us/img638/3752/srb20001.png

Fred 05-22-2010 05:04 PM

So I was playing in NAGZ as Sonic, taking my time to collect lots of goodies. The timer is already over 20 minutes when I get to the conveyor belt section at the very end, and at this point the game just starts lagging ridiculously (didn't check, but it was something like 2-3 frames per second). It ends up killing me, even though I was flying as Super Sonic, but here's the thing: the minute I touched the death pit, all the lag disappeared. When I respawned at the star post directly before said section, the game was going at full speed again.

Quote:

Originally Posted by akirahedgehog (Post 672302)
Couldn't recreate on my end, with or without HOMREMOVAL. Is anyone else having this problem? -Jazz

Yes. It seems to happen when frameskip is taking effect. FOFs do not get drawn, and sprite/texture/flat visibility rules clearly break.

Cyan Ryan 05-22-2010 05:59 PM

You can jump back into the shrink machine in ERZ2 and make it play the shrink sound infinitely. D:

You can go through forward as many times as you like, but you can't go backward anymore, as fun as breaking one's ears might be. -Jazz

Kancsar 05-22-2010 07:04 PM

A sigsegv out of friggin nowhere during a Standard room Match party on Desolate Twilight...I springed up in the SRM section of the map when it occured

EIP=0048c912

D00D64 05-22-2010 08:29 PM

http://i199.photobucket.com/albums/a...4/srb20399.png

I was a spectator when I entered the room, but I was NOT in a "ghost" state, and was on a "neutral" team during a Team Match. I just entered the room, prepared to spawn, then I was hit and killed by a weapon, and noticed I wasn't a real spectator. I was able to fight like I always did (sadly without seeing my weapon ring totals, but ah well), and stayed as a lavender Sonic the whole time. I think I caused a lot of consfail kicks too, but it might have just been the server's consfail protect options.

Do you know of any way to recreate that? -Jazz

glaber 05-23-2010 02:42 AM

For some crazy reason, I'm getting a black bar that pops up in Software full screen mode that screen shot can't capture

Sorry for the bad picture, Print screen was the only way to capture it
http://img.photobucket.com/albums/v215/Glaber/ugh.png
Check the hud.

Game renders as expected with the unsupported Opengl renderer.

Spazzo Edit: See if STRETCH ON helps.

Glaber Edit: That worked. Now for the next question, Why did this happen in the first place?

For some reason at some point during development, stretch was defaulted back to off. This has been rectified. -Jazz


All times are GMT. The time now is 02:55 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.