SRB2 Message Board

SRB2 Message Board (https://mb.srb2.org/index.php)
-   Bug Reports (2.1.X) (https://mb.srb2.org/forumdisplay.php?f=104)
-   -   Fixed [2.1.18] Addfile has trouble loading a file (https://mb.srb2.org/showthread.php?t=42279)

Rapidgame7 01-15-2017 09:06 PM

[2.1.18] Addfile has trouble loading a file
 
I wasn't sure what to write on the title.
I have SRB2 set to use a different folder as the home (-home files), so every WAD I have is located in "[SRB2 folder]/files/srb2".

The problem resides in that addfile works in a weird way when this command line argument is used.


http://i.imgur.com/z8Ywqgq.png
When addfile is being used at the titlescreen, the files load correctly as expected.


http://i.imgur.com/ot2QftO.png
But when addfile is being used in-game, it doesn't load the WAD unless it is located in the home folder.


http://i.imgur.com/8mlpLHv.png
Also, when addfile is used for a file that actually doesn't exist, the error message is different. This error is the same in-game and in the title screen.

Monster Iestyn 01-16-2017 01:08 AM

I vaguely remember encountering something similar with files in the DOWNLOAD subfolder recently-ish, even without changing the home directory. IIRC sometimes I had to explicitly use "DOWNLOAD/filename.wad" and sometimes I was able to just use "filename.wad" even if it existed only in that folder. Haven't looked into that much since but it could be the same issue.

choalover 01-16-2017 02:15 AM

I had the same issue before in SRB2 before it was even reported, and I never really mentioned this issue cause it isn't like anything too major.

Sky The Destroyer 01-16-2017 07:14 AM

Are you in a netgame when you're adding it in-game? If so, you need to specify the subdirectory like Monster Iestyn said. SRB2 will not look inside subdirectories unless specified during netgames.

Monster Iestyn 04-25-2017 12:50 AM

Apparently I forgot to mention here before, but I made a fix for this bug which has just been merged in: http://git.magicalgirl.moe/STJr/SRB2/merge_requests/166

Lach 04-25-2017 05:41 AM

I believe the issue actually only applied to netgames in the first place. Adding files from subfolders in single player always worked fine for me.


All times are GMT. The time now is 11:41 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.